Question about Car Audio & Video

1 Answer

What's wrong with my speakers and amp? They sound like ****!!!!

I bought the amplifier install kit and followed it to a tee to hook up jensen xa-2100 200w amplifier to my Kenwood kdc x493 cd/mp3/usb player. The two pioneer tens {not in a box cause that wont fit under my backseat} sounded good in my friends truck but kinda sound weak in mine. The speakers are 6 or 7 yrs. old. I have no idea what the adjustment knobs on the amp do but i messed with them to get it as good as i could. WEAK!!! Any tips?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Master
  • 2,226 Answers

Your woofers are not going to sound very good unless they are in an enclosure (box). Very few woofers are designed as free air.

Posted on Dec 11, 2012

  • Jonathan L. Jaegerman
    Jonathan L. Jaegerman Dec 20, 2012

    this was the deal. Thanks. I have very little space. Is a band pass box a good idea?

  • kenw392
    kenw392 Dec 20, 2012

    Most decent car audio stores may have a box that is designed for your particular vehicle.

×

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
KaeZoo
  • 156 Answers

SOURCE: No Sound - boat stereo

Assuming that the four speakers are connected to the amplifier, then the amp is the most likely problem component. Does the amplifier show a power light when the system is turned on? Note that there is probably another fuse in the amplifier power wire, near the battery.

Posted on Mar 16, 2007

hawkwatcher
  • 67 Answers

SOURCE: my kenwood kdc-mp235

I assume the amp is turning on (lighting up) No audio may be due to Burnt rca ground trace in your kenwood radio. If you have a ohm meter measure continuity from rca's ground terminal to radio chassis. Should be close to zero resistance. If there is no no continuity there are fusible traces on radios main board that burn open at times when to much current is flowing thru rca ground
Just a good possibility , haver seen this happedmany times.
If you need service manual let me know kstahl65@att.net

Posted on Jan 26, 2008

SOURCE: Kenwood KDC-322 volume cutting out

there buggers rewire the earth/ground

Posted on Jul 27, 2008

vetteman3002
  • 2299 Answers

SOURCE: my Kenwood KDC-X493 deck is flashing "Protect" ,

You can unplug the unit for 10 minutes. This will clear this.

Posted on Jan 19, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jensen ka4400 400w amp


Hello Brian,
I have done a search for the Jensen KA-4400 Amplifier manual, without any luck. Sorry.
However the following might be useful for you to continue the search:
(1) Jensen Customer Support: 800-732-6866
(2) Go to: http://caraudio.manualsonline.com/manuals/mfg/jensen/jensen_car_amplifier_product_list.html
(Be careful to copy ALL of the URL address).
Then click on "Ask the membership for help locating your Jensen Car Amplifier manual"at the bottom of the screen.
Then fill in the form.
Good luck.

Dec 13, 2011 | AMP Car Audio & Video

1 Answer

Similar prob.did the 12 steps on how to install amp(jensen4100,blue).red protec light comes on when starting car then goes out and is not followed up by the green protec light .green one never comes on....


If you are running a set or a single subwoofer with the jensen amp than you will want to hook up the rca cord to the subwoofer rca connection on the back of the stereo unit-the other rca outputs are there in the event that you want to run a 2 or 4 channel amp to power the speakers that are generally located in the doors or back deck-with that set up properly you would still be able to adjust the balance and the fader just as though you were powering the speakers with the deck. Pug the free ends of the RCA cord into the input rca receptacles of the amp- the stereo now will feed a signal to the amplifier that only contains bass - good luck

May 16, 2009 | Jensen LXA300 Car Audio Amplifier

1 Answer

220 watt car amp -- 8 or 10 gauge amp kit?


when in doubt go bigger, you might want to get a bigger amp down the road, so its better to not have to buy another wiring kit later.
and the bigger the wire the less line loss you will have so your amp will sound and perform better.

Apr 03, 2009 | Car Audio & Video

1 Answer

No audio output Jensen LXA300


well the "turn on" is just that - a relay inside the amplifier that allows the 12V Main to connect with the power supply on the inside of the amp.
hook up the remote turn on wire to a switched ignition source, and your amplifier will turn on.
If you are looking to TEST the amplifier - you can temporarily Jumper the remote terminal and the + terminal to get the amplifier ON - however when you instal it - you will want to put it on a switched power source so it goes on and off with the car.

If you need more help - im here.

Thanks for using FixYa - a FixYa rating is appreciated for taking the time to answer your FREE question.

Apr 01, 2009 | Jensen LXA300 Car Audio Amplifier

2 Answers

How to connect mey speakers to the amp?


hi,i have 1000w 4 speekers but i have one amp.how do i connect to that?

Jun 24, 2008 | Jensen JHT525 System

1 Answer

A300HLX Amp + 600 Watt JL Audio Sub


Ill go for a better GROUND , sounds like its not grounded properly and thats why the RED LIGHT . DO A RE CHECK on the installation . hope this helps

Apr 29, 2008 | Jensen A300HLX Car Audio Amplifier

1 Answer

Jensen Amp and Sub


If you followed the instructions correctly, then the amp must be defective. This is sort of simple.

My generic suggestions:
You have the power, the ground, the outputs to the speakers, and then the input.

Make sure that none of the speaker wires are somehow being grounded. Make sure that nothing is shorted that feeds the speakers.


Jerry G.


Apr 27, 2008 | Jensen A300HLX Car Audio Amplifier

1 Answer

No sound from speakers.


try with different speakers but disconnect all power (20min) cables first.

Aug 19, 2007 | Jensen XA2250 Car Audio Amplifier

1 Answer

Jensen XA4100


try using power directly from main to the remote terminal to see if headunit has a problem or the amp.please disconnect remote from head first.

Aug 18, 2007 | Jensen XA4100 Car Audio Amplifier

1 Answer

My amp keeps going into protective mode.


try to lower the SLA option on ur deck maybe the amp is pulling to much current from the battery try putting a battery with more AMPS

Jan 06, 2006 | Jensen LXA400 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4862 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

The Knight
The Knight

Level 3 Expert

74251 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...