Question about Infinity BASSLINK Car Subwoofer

Open Question

Power light on, servo light blinks faintly with music but no sound from the baselinkii. was working fine then just stopped.

I have a baselinkii for about two years was working great then just stopped. checked all the wiring for any damage, none. Checked the lights for power, its on, fuse is good, servo light blinks with music but no sound from the baselinkii..

Posted by Anonymous on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: amp keeps blowing fuse

I have this same problem. You have blown the internal amp. I have had 2 of these do the same thing. There is nothing you can do but report it to infinity and try to get the unit replaced.

Posted on Feb 08, 2007

SOURCE: Basslink servo light constant on

defect age,short worn its time through had the same thing happen to mine,A SUGGESTION PUT A 25 AMP FUSE,AND PULL IN AND OUT THE GAIN TUG IT,IT SOMETIMES STICKS AND SHORTS YOUR UNIT OUT,GOOD LUCK

Posted on Sep 26, 2007

BEERbrooklyn
  • 101 Answers

SOURCE: Power LED lit, Servo LED lit as well, no output

check the power cables on the amp and the inputs.isome time when ground cable disconnect the lioghts will light up any way. depending on the way ur vehicle is ground ed .toyota chssis r usually posite un like the norm which is neg.rating please

Posted on Jan 23, 2008

  • 65 Answers

SOURCE: Power Light, Pulsating Level Control, Blows Fuses

you may of caused a short in the connections or it got moisture why in storge if so the hole subwoofer is screwed

Posted on Jun 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why isn't my amp working anymore?


What is the question? More information is needed before somebody can help you. Try replacing the cable.

Apr 30, 2014 | Samson Servo 200 Amplifier

1 Answer

My 2002 gmc yukon slt wont switch out of auto fwd? It was working fine in 2 hi then i switched it to 4 lo the light on the 4 lo started blinking while it was still blinking i accidentally hit the auto...


You need to replace the lockup servo mounted in the front differential housing. the light will blink to indicate that the lockup servo is not engaging/disengaging. you can get the servo at a local parts place. It is very easy to replace and is easily accessible.

Mar 23, 2011 | 2003 GMC Yukon

2 Answers

I BOUGHT TWO HELICOPTER FOR CHRISTMAS FOR MY TWO SONS. THE ESKY LAMA V4 AND THE BIG LAMA. THE BIG LAMA WORKS GREAT AND FLIES WELL, BUT THE ESKY LAMA V4 ACTS STRANGE. WHEN YOU CONNECT THE BATTERY THE SERVOS...


I have exactly the same problem. It used to work fine for a long time but all of a suffen i got this problem. Do not yet know how to solve it.

Carl C

Jan 09, 2011 | Esky Toys

1 Answer

My Toshiba 50H81 screen black, no sound & power light blinking


sounds as if your power supply needs to be repaired. the capacitors over heat and crown or leak.

Jan 01, 2010 | Toshiba 50H81 50" Rear Projection...

1 Answer

No picture, no sound, no lights, faint clicking sound, fuse ok


HT transistor, or rectfying diode from chopper transformer is blown.

Apr 24, 2009 | Samsung DynaFlat TXN2668WHF 26" TV

1 Answer

LCT3701AD will not come on


I have the exact same problem. I believe we need Part # MLT386X PCB according to the other posts. It's around $179.

Mar 06, 2009 | Akai LCT3701AD 37 in. LCD Television

1 Answer

Basslink red light on but no sound


check the all power lines and regulator .is any of them overheating?
then check the power amp ic or transistors.

nuwan.

Jan 12, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

Control pod on bose companion 3


try to check the circuit board with an expert

Nov 16, 2008 | Bose Companion 3 Computer Speakers

Not finding what you are looking for?

Open Questions:

See all Infinity BASSLINK Car Subwoofer Questions

Infinity BASSLINK Car Subwoofer Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Infinity Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you an Infinity Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...