Question about Sony PlayStation Portable (PSP) Slim (PSP-2000) Console

1 Answer

Iso cannot be recognized in 5.02

After upgrading my psp version to 5.02, i cant get to play my preivous downloaded games

Posted by on

  • SBL Games May 11, 2010

    You were running custom firmware and now you upgraded to official firmware 5.0, correct ?


  • SBL Games Jul 18, 2014

    You unhacked your unit as soon as you updated to official firmware. You will need to downgrade and then re hack your PSP.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 71 Answers

You had m33 custom firmware(plays iso) installed on your psp and then you upgraded it with sony officail firmware(doesnt play iso) you will need to downgrade your psp

pandoras battery

youtube an google r ur friends

Posted on Mar 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My psp version 6.20 cant play ISO games.


If it's not hacked. It can't play anything other than UMDs really.

Sep 15, 2011 | Sony PlayStation Portable (PSP) Console

1 Answer

I have psp slim (PSP 2000) with 5.03 GEN C (Full), i cant play with the new downloaded games,,,...what's the latest cfw i can upgrade my psp, so i can play the new games i have,,,<>?? thank...


Hey there.
Before updating to 5.50 Gen-D3 (which is a higher version than yours), try knowing your PSP MoBo first. Why? Because, you may brick your PSP with the upgrade. Use PSPident to do that. Here's a link for that (MONSTER here!!!). Don't mind the monster, I just thought it's kinda nice doin' that. LOL
Now, do that PSPident in your PSP. If your MoBo appear to be TA088v3, DO NOT (never ever) upgrade to 5.50 Gen-D3 or you will have your PSP dead... If your MoBo is LOWER than TA088v3 (like, say, TA085v1 or v2) then go on with the 5.50 Gen-D3.
If upgrading doesn't solve your problem with playing homebrew, you may have downloaded a corrupted ISO or CSO file... Find a new torrent for that game again...
Happy playing...

Jun 07, 2011 | Sony PlayStation Portable (PSP) Slim...

1 Answer

My psp used a 6.20 version.but when i update it into 6.37 version,i cant open my games.what i need to do to use 6.37 version.my psp is 3000


If you had custom firmware on your PSP, and upgraded to 6.37, there is currently no way to downgrade to the old CFW or to play any downloaded ISO files. You will need to wait until a new custom firmware is release or a down grade patch is available.

Feb 27, 2011 | Sony PlayStation Portable (PSP) Console

1 Answer

Lost my iso file, i cant play games.........help!!!


First you have to upgrade your PSP firmware to 5.03

connect your PSP to PC in USB mode, Double click on downloaded exe file. It will copy firmware data

Note : Yo cannot download any psp games unless you it is version 5.03. VERSION 6.31 cannot download games. try this link on how to downgrade you system if thats the case http://www.youtube.com/watch?v=4COQtaUPNHU

Nov 23, 2010 | Sony PlayStation Portable (PSP) Console

2 Answers

I cant play the game in memory stick..


you'd first have to downgrade your psp. try to lower it to 3.50 or 4. something. then insert the .pbp file... this file is a hack.. or an upgrader for a psp.. once you do this.. your psp will be back to version 5.03 but now you can play downloadable games.

Jul 27, 2009 | Sony PlayStation Portable (PSP) Console

1 Answer

I upgrade my psp in version 5.01, now i cant play my games


the PSP has to be hacked in order for you to play downloaded games. If you get a magic memory stick and a pandora battery it can be done easily even with the 5.50 firmware version. Google pandora battery, and magic memory stic or (psp mmj tutorial) and you get lots of good info.

Hope this helps.

Jun 03, 2009 | Sony PlayStation Portable (PSP) Slim...

1 Answer

I cant play games in my psp memory stick after i updated to 5.2


Please check you update. If your update is low, you must upgrade it to 3.52 m33 then download a firmware 3.70 m33 or higher to get the m33 recovery.
As your PSP start press SELECT and you can see a menu then go to "UMD ISO MODE" from "normal" change it to "Sony NP9660" then exit.
Now enjoy playing ISO or CSO game. Happy playing.

Jan 29, 2009 | Sony PlayStation Portable (PSP) Console

4 Answers

I upgraded my psp slim to ver 5 and it cant read iso games.


U had disbled m33 updater in slim now u need to create pandora and magic stick to reflash slim

Dec 08, 2008 | Sony PlayStation Portable (PSP) Console

3 Answers

I cant play games on my psp v5.01 in its memery stick


IF YOU WANT TO THE OLD VERSION BACK AND PLAY AGAIN...... HOLD THE SWITCH UPWARD AT THE SAME TIME HOLD THE L AND R BUTTON AFTER THAT THE M33 RECOVERY MENU APPEAR... IF YOU HAVE SOME QUESTION JUST EMAIL AT SPONG3BOB11@YAHOO.COM

Dec 03, 2008 | Sony PlayStation Portable (PSP) Slim...

1 Answer

AFTER UPGRADE MY PSP CANT READ ISO FILES SO I CANT PLAY ANY GAMES


your ISO Games....
Presumably these are 'backup' of yours or others games ??
Do you have 'any' level of homebrew installed to be able to read your ISOs ??
If this is the case - you will need to revert back to the original firmware. . . if you need more detail, please comment.

Aug 16, 2008 | Sony PlayStation Portable (PSP) Console

Not finding what you are looking for?
Sony PlayStation Portable (PSP) Slim (PSP-2000) Console Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Video Game Consoles Experts

Iron
Iron

Level 3 Expert

3018 Answers

Troy Gorman
Troy Gorman

Level 3 Expert

508 Answers

Marc
Marc

Level 2 Expert

68 Answers

Are you a Sony Video Game Console Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...