Question about Audio Players & Recorders

1 Answer

PROTECTOR LIGHT STAYS LIT ON THE AMP, NOT POWER LIGHT

AMP HAS GOOD POWER SOURCE, GOOD GROUND VERIFIED WITH TEST LIGHT, BUT THE POWER LIGHT WONT COME ON

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 19 Answers

The protect light is on because there is a internal problem with the amp, causeing it to over heat,

Posted on Dec 03, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix my Jvc the screen won't power on. When I reset it the lights on the buttons light up...but shut off right away. It has power because the red light on the bottom left corner stays lit.


JVC LT-46AM73 LCD TV Won't Turn On - YouTube

? 3:28
https://www.youtube.com/watch?v=y5j3RGUe4gM
Feb 25, 2015 - Uploaded by Awesome Things
JVC LT-46AM73 LCD TV won't turn on after power outage. ...LCD & LED TV Repair - No Image & Blank Black ScreenFlashlight Test - How to ...

JVC wont turn on - JVC - Streaming Video & TVs

www.tomsguide.com/answers/id-1677424/jvc-wont-turn.html
May 15, 2013 - JVC lcd tv will act like its turning on then the green light after 2 seconds ... wont turn on Forum; SolvedAcer Laptop V4DA2, screen won't turn on.

My Jvc Av-32F476 Tv Won't Power On, The Green On Timer Light Stays ...

www.diyforums.net/my-jvc-av-32f476-tv-wont-power-on-the-green-on-...
Dec 8, 2013 - My jvc av-32F476 tv won't power on, the green on timer light stays on and m. ... On the remote control, look for the buttons PICTURE MODE and DISPLAY, with ... My Jvc Lt24dd52j Won't Turn On The Blue Light Is Flashing But ...
Nov 1, 2014
I Have A JVC LT-42TG30J, Randomly The Tv Has Decided It ...
Aug 29, 2012
I Have No Picture On My 47 Inch On My Jvc Big Screen Just A ...
May 23, 2012
My Dynex 42" Wont Turn On Power Led Is Lit Up But It Won't C ...
May 24, 2011
More results from www.diyforums.net

Jan 18, 2016 | JVC Televison & Video

1 Answer

Lanzar vibe 262n amp has power, everything hooked up, remote good, but amp does not come on., no indicator lights on,


In most cases if you are positive that you have power from 12volt and remote, the negative source is the culprit. It's best to double check power sources with a test light. I've had many times thinking my remote was good but found it not by connecting the 12volt source to both remote and positive for confirmation. Ground sources are often over seen as a problem but some metal parts are often coated so it's best to sand grounding surface before connecting. Trouble shooting seems difficult but with a simple test light you can run many test. Even including testing your if your channels are operating by watching the light flash to the music. Worst case, the amp is burnt. Hope this helps. GL

Oct 04, 2014 | Car Audio & Video

1 Answer

How to i find out whats wrong with my bazooka tube i tried to hook it up to a car battery and car stereo out side but wont work ???


follow this steps and fix it. GOd bless you

  • Verify that the amplifier is turning on by looking to see that it is lit up.

  • 2
    Use a voltmeter to verify your power supply is a good 12 volts by touching the ground lead to you amplifier's ground screw and the positive one to the amplifier's constant power supply screw. Also verify that you have 12 volts coming from the remote lead wire which is usually a thin blue wire between the ground and constant 12 volt supply.

  • 3
    Look for the "thermal overload" light. It is usually a red LED on the side of the amp. If the amp feels really warm and this light is lit, the amp has probably overheated from being tuned wrong or turned up too loud and shut itself down to cool off.

  • 4
    Check the fuses on the amplifier. These can blow with extended use or during heavy bursts of use.

  • 5
    Make sure the "Gain" and other volume controls are turned up.

  • 6
    Confirm that the signal wire is still attached to the amplifier and has not come disconnected by vibrations in the car. Also check that the wires running out of the amp to the speakers are still attached to the amp.

Oct 27, 2013 | Car Audio & Video

1 Answer

Citroen C4 automatic. After car has been driving then stops, the fan keeps going until battery runs dead. The AA fitted brand new battery but problem persists. Any ideas?


Most "CCC" Or computer comand controlled vehicles supply power to the electircal components automaticaly via a relay, there will be one power source with the ignition off,& a second power sourse when the ignition is turned on,In this case the temp sensor will supply a ground to the cooling fan circuit when the engine temp reaches a specified temperature and the fan comes on. In my opinion you most likely have a relay that has malfunctioned(gotten too hot & fused internaly) find your engine cooling fan relay(s) & remove them.If the fan stops you may have found your problem.to check the power supplied to the relay you will need a simple test light, connect the clip to a good ground & probe the relay socket with the tip of the lights probe. where there is power the test light will light up. Ignition off-1 power source,Ignition on-2 power sources/ to check for the ground supplied by the temp sensor connect the test lights clip to a battary+ source & probe the relay socket again if there is a ground supplied the test light will light up, there may be more than one temp sensor in the cooling system.you should be able to aquir a wiring diagram online if you do not have a book.one of the sensors sends the temp signal to the gauge in the dash, & the other is the ground supply for thr fan relay. I hope I have been of some help.

Dec 15, 2012 | Cars & Trucks

1 Answer

On my 94 jeep im having an electrical problem, something is killing my battery and i checked the alternator and my starter and i can not find the solution something is killing my battery rapidly please...


START THE VEHICLE, PUT A VOLTMETER ON THE BATTERY. THE VOLTAGE SHOULD READ 13.90 TO 14.80. IF THAT IS OK, THERE MAY BE A BATTERY DRAIN. TURN OFF EVERY SWITCH IN THE CAR.CLOSE ALL THE DOORS. MAKE SURE ALL THE COURTESY LIGHTS ARE GOING OUT. & THE GLOVE COMPARTMENT LIGHT. RAISE THE HOOD. DISABLE ANY UNDER HOOD LIGHTS. DISCONNECT THE NEG. CABLE FROM THE BATTERY. PUT A 12 VOLT TEST LIGHT, ONE END ON THE NEG BATTERY POST & THE OTHER END ON A GOOD GROUND { METAL }. IF THE LIGHT COMES ON THERE IS A BATTERY DRAIN. NO LIGHT , NO DRAIN. IF IT'S ON, ONE AT A TIME PULL THE FUSES OUT OF THE POWER DISTRIBUTION BOX. IF THE LIGHT STAYS LIT, PUT THE FUSE BACK. DO THIS WITH ALL THE FUSES BIG & SMALL. IF THE LIGHT STAYS LIT, DISCONNECT THE ALTERNATOR. THEY CAN CHARGE THE BATTERY WHILE RUNNING, & DRAIN WHEN STOPPED.

Jan 11, 2011 | 1994 Jeep Grand Cherokee

1 Answer

Signal light stays on even with the flacher off the circuit mechanic work for two hours trying to locate the source. disconnected the hazard light flacher and the firont and back signal light stays on,


A bad ground circuit will present a power to ground situtation. This will keep a light lit. Check all grounds in the problem area
Good luck

May 12, 2010 | 1993 Lexus Es 300

1 Answer

Just bought used bike, bought new motor hooked it all up, even new ecm's.test light shows power from all sources motor turns just wont start


Hi and welcome to FixYa,

Initially, check for the presence or absence of spark at the plug(s). If none, check if there is a +12 on one terminal of the ignition coil and a pulsating ACV on the other. Additionally, verify that the neutral light is lit. Try starting with the clutch lever pulled in and/or the side stand folded up.

Postback results of tests.

Good luck and thank you for using FixYa.

May 26, 2009 | 1980 Honda GL 1100 Innerstate Gold Wing

1 Answer

Amplifier Problem


never ask geeksquad about amps lol check your ground wire connection and push on sub do you feel scratching if so its blown sub also never turn an amp up all the way it starts pushin dc voltage witch a 200 watt amp can blow a 800 watt sub dc voltage is not good for subs also up all the way can burn out the internal battery in the amp lets hope thats not it just make sure ground is good protection light means that the amp has power but a connection is not bien made sum where to complete the circut

Apr 12, 2009 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

1 Answer

Kenwood kac-5201 amp


12 VOLT FROM THE BATTERY SOURCE GOES TO 12VOLT BATT CONNECTION.12 VOLT GROUND RETURN MUST BE FIXED TO THE FRAME OF THE VEHICLE.SOME VEHICLES HAVE FACTORY GROUNDS UP HIGH ON THE SIDES OF MOST VEHICLES, U CAN USE THIS GROUND LOCATION. IF CONNECT REMOTE WIRE FROM THE RADIOS REMOTE TURN ON LEAD WHICH IS A BLUE/WHITE WIRE OR A STANDARD BLUE IF ITS JUST ONE BLUE WIRE. CONNECT THIS LEAD TO THE REMOTE TURN ON CONNECTION ON THE AMP , SOME KENWOODS HAVE TWO ,INPUT AND OUTPUT LEADS.U ALSO NEED A TEST LIGHT, OR U CAN USE A SPEAKER TO TEST FOR POWER AT UR CONNECTION.IF U USE A TEST LIGHT , CLAMP THE END U WOULD GROUND TO THE VEHICLE, TO THE AMPS GROUND, THEN TOUCH THE PROBE END OF THE TEST LIGHT TO UR WIRED CONNECTION TO VERIFY U HAVE POWER AND GROUND TO YOUR CONNECTION.IF TEST LIGHT DOESN'T WORK ,CHECK UR FUSE AND REMOTE TURN OR LEADS.

Sep 02, 2008 | Kenwood KAC-5201 Car Audio Amplifier

2 Answers

My Power Protector Light wont turn Green


switch off the amp then take off all the wires off including the speaker wire and then reconnect the wires on like before the problem is that the amp is on protection and if that dont work then get it repaired another thing is make sure ur amp fuses havent blown.

Nov 04, 2006 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5113 Answers

The Knight
The Knight

Level 3 Expert

74185 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...