Question about Hifonics Brutus Brz1200.1d 1200 Watt RMS at 1 Ohm Monoblock Super Class D Amplifier

1 Answer

Not powering sub

When I turn on my car, i hear the subs bump on and the amp will have its lights on except the power light. Help?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Is your remote wire hot?

Posted on Nov 30, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Planet Audio PX1500M Amplifier Problem


Check the FUSE to ensure that current is not cut off.

Jul 16, 2013 | Planet Audio PX1500M - 1500W MOSFET...

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

3 Answers

Red Power Protector light


Hi, the only way i can see the amp resets the stereo is that power is dropping. The amp should have its own wires directly to power/battery so as to not affect anything else.

On the protect, try to disconnet all the speakers, make sure the power is OK. If it appears to work, the there could be a problem with speakers/cables. Try a different speaker to see if it works. If the problem continues with speakers off, a different speaker etc, then there is a problem with the amp. Hope that helps

Jul 21, 2009 | Sony XM-2100GTX Car Audio Amplifier

1 Answer

Wheres the power.. No bump


it might be that your subs are too powerful for the amp, check the model of the sub or subs online and check out how many watts they can take, because you might need to upgrade your amp or downgrade your subs

Jul 03, 2009 | Alpine MRP-M450 Car Audio Amplifier

2 Answers

My subs don't bump to the beat, they just go THUMP THUMP THUMP...


It sounds like you need to ask for pro help mate, mybe the amp just needs setting properly, Is the amp on bypass for bass, or does the amp run the complete system

Jun 13, 2009 | Cadence TXA 750D High Power Mono Amplifier...

1 Answer

INFINITY AMP PROTECTION LIGHT FLASHING


Overload maybe. If the amp is run at an improper impedence, the amp will shut down. If you are "CLIPPING" speakers / subwoofers the light will blink to indicate a hard clip . Example: 4ohm/2ohm stable amp with 4 ohm subs wired at 1 ohm.

Jan 28, 2009 | Infinity Reference 7541a Car Audio...

1 Answer

Status light red


You may have your subs hooked up to it wrong. Either way the amp is definitely blown. Have a stereo shop check it out and examine your wiring.

Sep 13, 2007 | AudioBahn A4125HCT Car Audio Amplifier

1 Answer

Power light


This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Jul 08, 2007 | Hifonics Titan TX 8805 Multi-Channel Amp...

Not finding what you are looking for?
Hifonics Brutus Brz1200.1d 1200 Watt RMS at 1 Ohm Monoblock Super Class D Amplifier Logo

Related Topics:

162 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Televison & Video Experts

The Knight
The Knight

Level 3 Expert

73619 Answers

Cindy Wells

Level 3 Expert

5056 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Hifonics Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...