Question about Audio Players & Recorders

Open Question

My OPTIMUS PRO-SW200P 200-Watt Powered Sub just stopped working. Everything seems fine, it's still getting power and transferring sound through it to my tower speakers, but the sub itself has no sound coming out at all. The red light on the knob to turn it up and down is on but the green standby light on the back is not? Please help!!!!

Posted by on

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Loud humming noise from subwoofer

if it is a powered sub you should lift the ground. you can do this by adding a three prong to two prong adapter. you know, like when you go to plug something in and the cord your plugging in has three prongs and the outlet your plugging in to only has two. it doesn't have the hole for the ground so you go get a little grey adapter that has three holes on one side and two prongs or tabs on the other.if that doesn't take the hum out (actually, is keeping the hum from getting in) you have a problem with the amplifier.

Posted on Jan 27, 2007

  • 1 Answer

SOURCE: Klipsh Promedia 2.1

I was face the same problem 2 year's ago.This problem occur when you move the speaker's here and there.at that time speaker's wire diconnected in inside...please check the whole wire by electricians for where exactly it is disconnected...

Posted on Aug 25, 2007

robotek
  • 1512 Answers

SOURCE: Powered Subwoofer won't work

This problem has many causes... but try this one... often when a faulty subwoofer speaker is to blame this test will tell you. Connect another speaker(any speaker) temp to check if there is audio still to the sub. Keep the levels down to ensure you dont go on a trail of destruction.
The spider wires from terminals on the speaker to the cone may be intermittent. I have seen this a lot on all types and makes of subwoofer driver!! This a common failure and can often be detected by tapping the speaker cone when it does the cut out thing. If it starts up, and they often do..., then you probably have intermittent spider wiring to the cone. A GOOD “Hi Fi speaker repair dood” can help here and replace the spider wires for you and save the expense of replacing the driver.
This is just one solution to the problem you are having.... there are many more..... and you should try this FixYa and see what happens. If you cant tell WTF then hit me back up here again. I work WITH YOU, to get the problem out for you.

If it sorted what you suspected... then rate me !FixYa!!.... Thanx

Posted on Dec 28, 2007

hawkwatcher
  • 67 Answers

SOURCE: sr7200 LFE (sub woofer) output stopped working

Chances are if The Receiver only has sound in Stereo Direct Mode and all surround modes and Sub out are Inop the DSP (Digital Signal Processing) Card is most likey defective. These boards are not available from marantz (D&M Holdings) and must be Component level repaired which usually is not cheap. If Only the Sub out is not working check setup to be sure sub woofer is set for on. Also If On Screen setup menu does not appear on video monitor Unit may need to be Reset manually which entails discharging a Capaitor on main P.C.B Contact kstahl65@att.net for details

Posted on Jan 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I took my 1000 watt amp and kit out of my old truck and put it in in my new ride. It worked just fine at first then the subs started going out for hours even days but amp was still powered on then i hooked...


You may need to run a larger wire to the amp or upgrade your alternater to get enough voltage to the amp. double check all of you wire connections going to the battery and from the alternator also. Clean all terminals and maybe even beef up the wires from the alternator to your battery. Your smaller amp works due to it needing less current to work, your big amp can't even power up with the lack of available current.

Apr 01, 2013 | Car Audio & Video

1 Answer

My kenwood kfc ws252 moves but does not make sound. what's the issue?


Many different problems could be occuring. if the sub is not in a box, it will not produce any bass, get in a box and problem solved.
if you have more than one sub you could have them out of phase, reverse the positive and negative on ONLY ONE SPEAKER and it should fix this problem.
if its amped you could have the crossover set improperly, set to LPF or low pass and set frequency to about 90 to 120 and you should be good with that.
other than that it could just be under powered, a good 200 watt amp should be enough to push it and get good sound, it can handle more but thats up to you. hope the info helps.

Jan 13, 2013 | Car Audio & Video

1 Answer

No sound from subwofer


If it is a powered sub, a fuse may have blown inside or the amplifier may have failed

Sep 24, 2012 | Denon Avr 2307ci 7.1 Channel 945 Watt...

1 Answer

Problems with JBL PSW D110


The speaker level input option is designed for receivers that don't have digital output for the sub, used this way when you set to digital the speaker outputs only get the higher range outputs so won't reproduce much bass. To get the sub to work in digital mode you need to use the digital output (single RCA) from the amp to the sub

Mar 06, 2012 | Audio Players & Recorders

1 Answer

I have a 2005 Mitsubishi Eclipse with the Infinity high end stock radio installed, which has a 200 watt amp under the seats. The head unit does does not have direct speaker outputs. The head is connected...


I am going to refer you to the live help
at crutcfield.com audio

They can give you ideas on compatible equipment and designs that will achieve your desires without the OBVIOUS overlad/mismatch.

Your search for comparison returned these articles

Free factory (usa market) wiring diagrams
BBB Industries Premium Alternators Starters Power Steering Products

Mar 11, 2017 | Infinity BASSLINK Car Subwoofer

1 Answer

My subwwofer does not seem t power on .....it is also not picking up a signal...... can you help with this


Hi slikrik

Please check your external connections, power if everything is ok then.. First please confirm when did you purchased this Active sub., This sub system is having 5years warrantee on Speaker and 3year on Amplifier. Hence, if you are the due date please give it for free checkup and replacement for parts.

-sai kumar

Dec 28, 2010 | Definitive SuperCube II 8" 1250-Watt...

1 Answer

Subwoofer loudness


Do you have enough amp to power the subs, sounds like the coils are heating up and shutting down. Twice the amp for the wattage of the speaker as in 100watt sub 200 watt amp supply and so on.. 1000 watt sub would need at least 1500 watt continuous out put

Mar 09, 2010 | Car Audio & Video

1 Answer

Kenwoodxw1000f shut off after 10 sec


the problem sounds like your new sub is drawing to much power and your amp can not handle it. bridging the amp is a good way to get the full power out of your amp. But it isnt always suggested, my solution is to get a bigger amp. I install stereo systems for a living, and i tell my customers that it is smart to get an amp about 100 more watts then the rms rating of your subwoofer.

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

Subwoofers were said to be bad


overpowered definitely. when you bridge subs your almost doubling the power. if the subs were set for 2000 then the guy he took them too should have known better or at least turned the power down on the amp.

Mar 13, 2009 | Car Audio & Video

2 Answers

Can't get my Accurian subwoofer to work


Sounds like you have everything hooked up properly. Make sure the outlet is providing AC power to the sub. Check the power switch on the sub.

If it is not working still; bring it back and swap it for another one before you warranty runs out.

Jan 28, 2009 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

312 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73635 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...