Question about Polk Audio PSW10 Subwoofer

Open Question

My subwoofer was working fine for months then it started fading in and out and now it doesnt do anything at all. it isnt blown. how can i fix it?

Connected to pioneer sx-580 receiver and low pass is set to 100(hz)

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

fcollingwood
  • 58 Answers

SOURCE: subwoofer

Most AV receivers do not have a built in amplifier block to drive a subwoofer, and merely provide the subwoofer output channel at line voltage. Thus, a powered subwoofer is required. Does the subwoofer require mains power? From your description, I'm guessing it doesn't. If not, it does not have a buit in amplifier, you will need to purchase a monoblock amplifier, which is just a mono amplifier with a volume control, no tone controls or anything else. Make sure that the amplifier power rating is as close as possible to the subwoofer power rating, as it is quite possible to blow a speaker by using an amplifier whose power output is too low, by overdriving the amplifier , and putting DC through the voice coil when the amplifier clips. If it does require mains power, it will have an amplifier built in, but does not have line level inputs.

Posted on Sep 14, 2007

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whats wrong with my subwoofer


Chances are there is a short pulling the amplifier down. To track this down you'll have to remove the amp from the rear panel (unplug before touching anything!). Look at the wires going from the amp to the speaker itself. Make sure they haven't melted together or are touching in any way. If that looks / checks fine, you should look at the capacitors on the amp board to see if any have overheated or blown. This is apparent from a slight to severe bump on the top of the capacitor where an "X" has been etched on top to relieve pressure for safety reasons. These are very cheap to replace and find. Go to PartsExpress.com and call them with the value listed on the cap. If you know how to use a soldering iron this will be a quick and cheap fix.

Feb 22, 2016 | Infinity PS-8 Subwoofer

1 Answer

My subwoofer isnt working


it is completley possible that your sub has in fact blown itself out mine has some CRAZY excursion to the point ive turned down the bass on my laptop in hopes to keep it alive so order a new sub SPEAKER if the speaker works the amps FINE

Oct 26, 2012 | Cyber Acoustics CA-3001 Computer Speakers

1 Answer

The fade button isnt turning on the speakers in the bakc of the wagon. we just bought the car but have no owners manual. front speakers are good


They could be unhooked. If they were hooked up but blown, you would here static. If you hear nothing theyre either unhooked or the radio console is messed up.

May 09, 2011 | Car Audio & Video

1 Answer

My Ada 880 speakers work fine, but the subwoofer isnt making any noise....it doesnt seem like its getting power but if the speakers work id assume the fuse is good right? i cant seem to find alot of...


Hi there bud, this could also mean that something in the Subwoofer has blown or shorted, the best thing to do is too take it back too the shop where you bought it and ask them too replace it .its not worth opening it up yourself and losing the warranty...
Happy new year . Hope you come right :)

Jan 03, 2010 | Altec Lansing ADA 880 Computer Speakers

1 Answer

Ok my sub woofer isnt working, the front and back speakers are working, the sub used to work then it would cut in and out then i tap the box and it works but no it doesnt work at all, i am not sure if the...


bad connection. try hooking up a different test speaker to your amp. if it works you can trace the short into your sub. if not the terminals in your amp may need to be re-soldered.

Oct 10, 2009 | JBL GT150 Car Subwoofer

1 Answer

Infinity Basslink not producing any sound. Green light on.


check that fusse under the hood if its blown pull it out and replace it wont hurt anything if u pull it out an put it back in if the cars off.but if ur getting power lights on the amps then more then likely ur fuse isnt blown.id start by checking the audio cables are produceing sound.if u need more help let me know bertman285@hotmail.com

Sep 29, 2009 | Infinity BASSLINK Car Subwoofer

2 Answers

I have a thunder 5604 and all of the suden the short light came on and stop working, i disconect it and , put it back but th light still on an no sound. it doesnt smell like burn, im a mechanic and...


theres a few possible issues pull and replace all of the fuses also use atleast 4 ga power and ground wires if ur ga is 6 or up get a new amp kit i know my protect mode goes on when the ground isnt connected if none of that works take it to the company you got it from and have them check out the internals

Jun 17, 2009 | MTX Thunder5601 300W x 1 Car Amp Mono...

1 Answer

2 car subwoofers, one doesnt play


Short in amp ? try swiching wire's to speaker's around . if other speaker then work's , speaker's are both fine . if not , then short in amp , or blown channel in amp . get new one or find someone who know's more than i do about amp's

May 24, 2009 | Kicker CVR12 Car Subwoofer

1 Answer

Kenwood hac 9152d, was working fine now doesnt output any sound


Check the fuse on the amp.

My girlfriend had the same thing, light was on, no sound whatsoever. The fuse on the amp had blown, but I'm guessing some current must have made it through to just put the light on. Make sure you have a 40 amp fuse in it, that's what it needs.

Good luck

Dec 10, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Problem with Amp sustaing Power


I fixed it. Believe it or not, it was a fuse. I looked at them all and they did not look blown. So I got mad and replaced the remote wire and the fuses. And when I put in the last fuse it was fine. Apparantly from diligent research, fuses can look ok but have issues with soldering problems. Thanks peeps.

Mar 03, 2008 | Alpine MRD-M300 Car Audio Amplifier

Not finding what you are looking for?
Polk Audio PSW10 Subwoofer Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polk Audio Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

The Knight
The Knight

Level 3 Expert

74118 Answers

ed_dantes

Level 1 Expert

7 Answers

Are you a Polk Audio Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...