Question about Grilling

Open Question

Install wick on everglow pe2 - Grilling

Posted by Anonymous on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 16 Answers

SOURCE: Where can I find an Owner's manual for an Everglow

First you need to get the shell off the unit, and get down to the main burner area. There should be 4 wing nuts holding the wick tower down to the fuel tank. These must be removed, and the wick and the adjuster apparatus removed up and over the top of the center tower. Having a towel or old rag handy to set the unit on when you get it off is a good idea, so you can work on it. Remove the old wick, taking care to see how the fabric band on the cloth wick is positioned on the bottom edge of the wick carrier band. Install the new wick at the same level as the old one on the carrier and set it aside. Make sure you clean the tower, especially all the black carbon buildup around the center and near the top. I use a wire brush on a cordless drill to buff the stuff off, works great. Remove the old kerosene from the tank and clean the tank best you can, then put the new wick inside the carrier, down on the tower, being careful to get the bottom portion of the wick down into the tank area, (it should be quite loose down there once you get the rest of the carrier on the tower. Make sure the whole apparatus sets down evenly and fairly easily on the bottom tank part and screw it down with the four wing nuts. I use a paper cup to pour clear, K1 kerosene onto the new wick all the way around the tower, then make sure it moves easily up and down with the height adjuster knob and while it's in a down position, pour some more kero in on it. You can pour several cups of kero on the new wick and then when it's working up and down well, turn it up and lite it before you put the whole thing all back together. It's best to do this outside as sometimes you can get smoking, if you don't get the flame spreader cage on quickly enough. Once it's on and the flames come up and look good, then turn it off, let it all cool off and you can put it back together. Remember, don't use anything but absolutely clean, clear, K1 Kerosene in the unit and burn it completely dry at least once a week, if you use it a lot. It's called dry burning, and it's a wick cleaning function. If you do this, the wick can last years and years.

Posted on Apr 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Mitsubishi 73 dlp when i turn on the tv it works for about a min and turns off status indicator blinks once red then 7 short yellow


looks like you have error code 17, which indicates you have

A) loss of 12volts from PWB-power pcb to light engine

B)Loose PE or PE2 connector

C) Engine failure.

light engine part# would depend on your model#, but first check your PE & PE2 connections, & make sure you have you 12volts DC from poer board to light engine.

Jan 16, 2015 | Mitsubishi Televison & Video

1 Answer

Adjust the wick on a dyno glo kerosene heater


Robin, without knowing which model Dyna-Glo, I can only generalize. But, if you are not getting an even burn with the wick turned all the way up, then upon dis-assembly, if the wick is NOT pinned (pins in the wick engaging the lifter system) then remove the wick and raise it about 1/2". Lower the wick down into the wick lands and check for level. Trim as necessary to get a level top. Reassemble.
If the wick IS pinned, then no adjustment is possible. Remove and discard and install a new wick.

Dec 20, 2014 | Heating & Cooling

1 Answer

I have a Dyna Glo model RMC 95 C2 kerosene heater and the wick has gotten to the point it doesn't want to crank up, and then when I get it up it doens'tn want to fall down when I need to shut it off. I've...


Sorry about your luck with installing the wicks, honestly there are no parts that have gone bad and need replacing. I have six of these and every year I change wicks in them, you want to talk about a royal pain in the @$$ wick installation is a precise science with very little room for error. I know you do not want to hear this but please take the heater apart one more time. I find it easier to install the wick in the full high position, then to put the wick assembly over the center tube and get the fingers of the wick down completely in the kerosene this is where I mess up but if you use a twisting motion when installing the wick down in to position it seems to seat the wick and work out better. As to why I could not tell you. These are built with such close tolerances it is not even funny. Take your time and test once you have the wick assembly in and four wing nuts on. Even test by quickly tipping it over to trip the extinguisher. PATIENCE PATIENCE PATIENCE can not state it enough. Have you a beer and attempt it one more time. Good luck and remember patience.

Jan 14, 2011 | Heating & Cooling

1 Answer

Replacing the wick for an Everglow PT-E16 kerosene heater


@gggg698
That was close enough to get the job done, thanks, but not exactly correct for this model.

Nov 10, 2010 | Heating & Cooling

3 Answers

The wick will not raise


If you allowed the fuel to run out then the wick is probably ruined, you will have to replace it.

Feb 26, 2010 | Corona 23-DK Compact Heater

1 Answer

Where can I find an Owner's manual for an Everglow Kerosene Heater or in structions on how to install the wick and burner.


First you need to get the shell off the unit, and get down to the main burner area. There should be 4 wing nuts holding the wick tower down to the fuel tank. These must be removed, and the wick and the adjuster apparatus removed up and over the top of the center tower. Having a towel or old rag handy to set the unit on when you get it off is a good idea, so you can work on it. Remove the old wick, taking care to see how the fabric band on the cloth wick is positioned on the bottom edge of the wick carrier band. Install the new wick at the same level as the old one on the carrier and set it aside. Make sure you clean the tower, especially all the black carbon buildup around the center and near the top. I use a wire brush on a cordless drill to buff the stuff off, works great. Remove the old kerosene from the tank and clean the tank best you can, then put the new wick inside the carrier, down on the tower, being careful to get the bottom portion of the wick down into the tank area, (it should be quite loose down there once you get the rest of the carrier on the tower. Make sure the whole apparatus sets down evenly and fairly easily on the bottom tank part and screw it down with the four wing nuts. I use a paper cup to pour clear, K1 kerosene onto the new wick all the way around the tower, then make sure it moves easily up and down with the height adjuster knob and while it's in a down position, pour some more kero in on it. You can pour several cups of kero on the new wick and then when it's working up and down well, turn it up and lite it before you put the whole thing all back together. It's best to do this outside as sometimes you can get smoking, if you don't get the flame spreader cage on quickly enough. Once it's on and the flames come up and look good, then turn it off, let it all cool off and you can put it back together. Remember, don't use anything but absolutely clean, clear, K1 Kerosene in the unit and burn it completely dry at least once a week, if you use it a lot. It's called dry burning, and it's a wick cleaning function. If you do this, the wick can last years and years.

Feb 21, 2010 | Grilling

1 Answer

Have a Dyna-Glo. Took it apart to change the wick


take the wick back out lower your nob and install wick, I hope this help you, I have made this mistake too

Oct 23, 2009 | Corona 23-DK Compact Heater

1 Answer

CPSS over L2ckt over fast ethernet


[NB3600]---fr_uni---(PE1)----FE----(PE2)---fr_uni---[NB3600]----[NB NMS]

below is the config.

> *PE1*
> fe-0/0/0
> description "conctd to PE2";
> mtu 1546;
> unit 0 {
> family inet {
> address 192.168.0.1/30;}
> family mpls;}
>
> e1-1/0/0
> description "conctd to NB3600";
> encapsulation frame-relay-ccc;
> lmi {
> lmi-type ansi;}
> unit 0 {
> encapsulation frame-relay-ccc;
> point-to-point;
> dlci 513;
> family ccc;}
>
> l2circuit
> neighbor 192.168.1.254
> interface e1-1/0/0.0 {
> virtual-circuit-id 513}}
>
> *PE2*
> fe-0/0/0
> description "conctd to PE1";
> mtu 1546;
> unit 0 {
> family inet {
> address 192.168.0.2/30;}
> family mpls;}
>
> e1-1/0/0
> description "conctd to NB3600";
> encapsulation frame-relay-ccc;
> lmi {
> lmi-type ansi;}
> unit 0 {
> encapsulation frame-relay-ccc;
> point-to-point;
> dlci 513;
> family ccc;}
> l2circuit
> neighbor 192.168.0.254 {
> interface e1-1/0/0.0 {
> virtual-circuit-id 513;
> }}

Jul 03, 2009 | Alcatel Newbridge MainStreet 3600...

Not finding what you are looking for?
Grilling Logo

Related Topics:

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Grilling Experts

paulcarew

Level 3 Expert

2460 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Are you a Grilling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...