Question about T-Mobile MDA

1 Answer

T-mobile MDA sceen doesnt function properly.

I have my T-mobile MDA in which I have changed new batt. around 3 times. And now I added new battery 4th time and turned on my phone. After an hour or so the screen got shakey and now it doesnt display anything correctly. I mean to say that my phone turns on screen gets brighten up and display some bad output. I have tried reseting it several times but still the display remains the same. I am able hear ring when I get any calls and able to receieve it. Please help me with this problem as I was not able to find its solution anywhere on net. Thanks a lot for your help.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 25 Answers
Re: T-mobile MDA sceen doesnt function properly.

Hello Shivang this more of a problem that it has to be looked into by engineers in theworkshop. find ou t if you still have any warranty in place from the manufacturer. the problem is that the screen controller is faulty an it has to be fixed in the workshop it is pure electronics stuff

Posted on Aug 11, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Smashed my screen on my mda vario got a new phone now want to active sync in but cant remember my pssword is there a work around?

Yes, you need to perform a hard reset.

To perform a hard reset

1. Press and hold the Comm Manager button and Voice Command
button on the device. At the same time, use the stylus to lightly
press the RESET button.

T-Mobile MDA Vario hard reset soft reset hardreset softreset
2. Keep the Comm Manager button and Voice Command button
pressed, and the following message will appear on the screen:

T-Mobile MDA Vario hard reset soft reset hardreset softreset

3. Release the two buttons, and press the Send button to perform a
hard reset



Feb 05, 2011 | T-Mobile MDA Vario Smartphone

2 Answers

Active Sync. on an MDA Vario 3

i had this problem, everytime i refreshed the mda the pc showed that the phone was connecting then once the mda vario had stopped the connection was lost, what i did notive was that the com port for active sync showed up on my pc as com port 4? which isnt a choice on the mda as there is only 2 ports available com 6 and com 7, what i did was to add new serail services to the pc until i was given com 6 as a choice,(because by default the pc starts off as com 4 then com 5 etc, so goto the bluetooth configuration then click on client apps and keep adding new service until you get com 6 then try and sync via activesync on your phone, if that doesnt work make sure that you have added new bluetooth device which gives you options of what services you would like the phone to use with the pc, click activesync then configure it to connect on com 6 voila that should work fine iv just updated mine to netframework 2.0 and can now run all the apps i want, any problems email me on il be happy to assist any way i can as i was stuck on this problem for ages and ages until i finally solved it hope you succeed.

Aug 31, 2008 | T-Mobile MDA

1 Answer

T-Mobile MDA won't hold a charge

if you insurance on your phone I recommend using it, I had a MDA for a couple years and had about every problem in the book, but not that one. It sounds like you've done everything possible, the only other thing i could think of is a hard-reset. Anything beyond that would tinkering with the internal hardware.

I think you can get a MDA pretty cheap on ebay these days

Jul 19, 2008 | T-Mobile MDA

1 Answer

T mobile mda

mine also did it and finally nothing on even I thought battery died I bought a new one.

Jun 14, 2008 | T-Mobile MDA

6 Answers

Battery won t charge or operate phone Problem - T-Mobile MDA Compact Smartphone

Okay, I searched and searched until I found a solution that worked for me. I tried the USB thing, I got my phone to turn on once, but never to charge. Here's what I did:

(Do this at your own risk)
I zapped my battery with a 9v battery. One wire on each terminal and then held it to the MDA battery (positive to positive, negative to negative) for about three seconds. I did this about five times. (Don't let the wires touch while they are connected to the 9v battery.) I IMMEDIATELY plugged my phone into a wall charger, NOT my computer (The computer wouldn't charge my phone). As soon as it was connected to the wall charger, I turned it on. After starting up, the orange light came on, and it started charging. I was skeptical about this solution at first, but trying everything else I resolved to do this and then if it didn't work buy a new battery, but it worked and my MDA is charging as I'm typing. The original ideal came from a post on the xda-developers website by dew1989. I added the additional steps that got my battery charging again. I hope this helps!

Dec 04, 2007 | T-Mobile MDA Compact Smartphone

1 Answer

T-mobile mda

buy a battery new

Sep 14, 2007 | T-Mobile MDA

1 Answer


throw the phone battery into a zip lock bag and put it in the freezer for about 12 hours...then put it back in the phone...should work just fine! same thing happened to me

Sep 12, 2007 | T-Mobile MDA

2 Answers

T Mobile MDA Speaker control

Update teh firmware from tmobiles website. Download the latest firmware and upload it to your mda... Should fix it.

Aug 01, 2007 | T-Mobile MDA

Not finding what you are looking for?
T-Mobile MDA Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top T-Mobile PDAs Experts


Level 3 Expert

56798 Answers

Martin Murray

Level 3 Expert

1614 Answers


Level 2 Expert

166 Answers

Are you a T-Mobile PDA Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides