Question about Kenwood KDC-519 CD Player

1 Answer

Unit will not power up

I have checked the wiring and the fuse on the back of the unit to my displeasure nothing changed

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers

Check the faceplate electric connector for breaks.

Posted on Jun 02, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Boss bv9364b audio system i have no power check fuse ckeck wiring still nothing


If the fuses in both the car and the unit are all good & the wiring is all correct & secure but you still get no power, your head unit is fried.

Oct 04, 2016 | Boss Car Audio & Video

1 Answer

Harley troubleshooting


First if the radio/stereo head (main unit) doesn't turn on (back lights illuminating, display showing, etc.) there might be a fuse in the back of the unit.

If the head works, and nothing to the speakers, a wire might be broken/disconnected.

May 29, 2014 | 2005 Harley Davidson FXDLI Dyna Glide Low...

1 Answer

Amp light is green getting a base like heart beat nothing else fuses are good


The only thing I'm wondering is if you shorted out the RCAs somehow. Try switching the RCA's to another output on the back of the deck, if you have more than one set.

If that's not it...you will have to add pieces of the system one by one, starting at the deck, to see if you can troubleshoot the problem. Very Odd.

Good Luck

Dec 07, 2013 | Autotek Car Audio & Video

1 Answer

Fuel guage not registering fuel, can it be a fuse


YES, CHECK ALL FUSES, IT COULD BE SHARING A FUSE CIRCUIT WITH ANOTHER ACCESSORY, CHECK ALL FUSES ! THE FUEL RELAY ALSO MIGHT HAVE A FUSE ON FIREWALL. THE FUEL PUMP HAS THE SENDING UNIT IN THE TANK, IF THAT WENT BAD, WELL THATS WHERE IT IS. THOROUGHLY CHECK THE GROUND WIRES @ TANK, & PUMP WIRING HARNESS, THESE WIRE HARNESSES CAN GO BAD, UNDER THE CAR, SALT, ROAD DEBRIS, GROUND WIRES GET OVERLOOKED, AND THEY SHOULD'NT !!!!!!!!!!!!!!!! POWER FROM BATTERY NEEDS TO GET BACK TO BATTERY, THE GROUND (NEGATIVE) IS HOW THEY GET BACK TO GO AROUND AGAIN !! ELECTRICITY NEEDS TO COMPLETE THE CIRCUIT ! WITH OUT GROUND, YOU GOT NOTHING !!!!!!!! HOPE YOUR SENDING UNIT IS OK, IF NOT, YOU'LL HAVE TO DROP TANK, TO ACCESS THE PUMP & SENDER, REPLACE THEM BOTH IF YOU DROP YOUR TANK, ITS LIKE WHILE YOUR THERE, ................................HOPE THIS HELPS !

Mar 24, 2013 | 2006 Chevrolet Trailblazer Ext

1 Answer

Im not getting any power to it


hi lizzy, please make sure that the power wiring (red, black and yellow cables) of your unit is correctly connected to the vehicle. next check if the blk wire(ground) is connected to the chassis(metal body part) of your unit (use a mutimeter). if not then attach a wire from the body of your unit to the blk wire. also make sure that your antenna lead is connected to the unit, and that the antenna is securely grounded to the body of vehicle. once power is correctly connected your unit will light up a red LED light in the power/source button. if all this does not help it will be advisable to have unit checked at jvc service center. cheers!

May 22, 2012 | JVC KD-G110 CD Player

1 Answer

I have a 98 Cavalier 4-door model. For some reason the dome light, glove compartment light and trunk light do not work. Fuse changed, bulbs changed and still nothing. Any ideas??


If you didn't use an OHM meter or a test light to check the fuse, it still could be a bad fuse. Alot of times the fuse looks good to the eye but is in fact bad. Plus, in some autos, there are more than one fuse. Check to make sure there isn't an additional fuse somewhere. If all the fuses are good, check your switches for power, If your not getting power to the switches, go back and make sure there is power to the fuse. If no power there, then you have to trace the wires for where there is a break in the wires.

Mar 18, 2011 | 1998 Chevrolet Cavalier

1 Answer

Got a new Kenwood KDC-128 car radio recently, fitted it but the radio presets would not stay when the ignition was turned off. Then it stopped working altogether and I noticed the 10amp fuse at the back...


you need to hook the yellow wire off the back of the radio up straight to the battery this keeps memory power to the head unit then wire the wires in color coded sequence red to red black to black so on and so forth if this doesnt fix it you might want to think about replacing head unit

Jan 02, 2009 | Kenwood KDC-128 CD Player

1 Answer

Kenwood KDC-MP438U acts as if there is no power to it,dead nothin


The speaker wires are very sensitive. You need to make sure that they are not grounding out. Once the unit senses this it will shut off. Pull the plug out of the back and start over.

Dec 30, 2008 | Kenwood KDC-MP438U Car CD/ MP3 Player

Not finding what you are looking for?
Kenwood KDC-519 CD Player Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4979 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

81294 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...