Question about Directed 600D Car Audio Amplifier

1 Answer

Amplifier directed 600/4

I have a directed 4 channel amp connected to two subs in my trunk. When I turn on the stereo now I get a low rumbeling sound regardless of the volume. It sounds almost like feedback from a mic. Can you help.

Posted by on

1 Answer

Re: Amplifier directed 600/4 - Directed 600D Car Audio Amplifier Car Amplifiers

Chenge the seting thu the microfon for minim

Posted on Jun 01, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Have two front ,two rear speakers, and two tens that i want to hook to my stereo. How do i do it and get the maximum sound?

If the Sony amp (I'm not familiar with that one) has its own crossover and subwoofer output, use that, and set your crossover point for what sounds best to you. Honestly, it is best to have a SEPARATE two-channel amplifier & crossover for the 10" subs. Whatever you do, make sure you use a large capacitor (2 Farad or more) at the power input of the amplifier for the subs. This will help prevent blown fuses. (It is also a good idea to use at least a 1 Farad capacitor at the power input of the amplifier for the other four speakers.)

May 11, 2015 | Sony XPLOD XM-554ZR 600 WATT AMP XM554ZRRB

2 Answers

We have an old amplifier from back in the 80's and 90's. Its 500watts, the right channels (both main and sides) work fine and loud, but the left channels produce very low sound. I checked the fuse and its...

Have you checked the final transistors on that weak channel? They may look fine but may be weak. You can pull them and check them on your multimeter with the diode check and cross it with the data sheet for that transistor.

Mar 07, 2011 | Kenwood KAC-5204 350 Watt Max Power Stereo...

1 Answer

Can I hook up 2 single coil subs at a 2 ohm load on my sony xm-1252gtr?

If your sub woofers are SVC (single voice coil) 2 OHM each, then connecting one to each channel would make the amplifier run in 2OHM stereo Then again, if your sub woofers are 2OHM each, it would be better to connect both together in series and connect them to the BRIDGE specified speaker terminals of your amplifier making it run a 4OHM load into one channel. This will give you all the power the amp can give and still run stable. A 2OHM load into one channel will likely damage your amplifier. Do not forget to set the LPF (low pass filter)on if you are going to use the amplifier to run sub woofer/s. dreamsystems

Feb 07, 2011 | Sony XM-1252GTR Car Audio Amplifier

1 Answer

What is the very best way to wire 3 sets of speaks and 2 subs through a 4 ch. amp and a 2 Ch. amp.?Thank you, Paul

Ummmm Im gonna give this a try-If it were me i would run the 4 channel ground pounder on the doors and rear panels -the front 2 channels run the component set exclusively at 2 ohms per channell and run the 8 inch 3 ways in parallel with the rear deck speakers for a combined load of 2 ohms per channel on the rear channells-naturally the 8 inchers and the 6.5's are going to be able to handle a little bit more bottom end than the component set so you can feed a little more midbass to those rear channels- I dont know the resistance of the coils on your subs or the model of the MA amp you are using but if you can throw 600 or 700 on your subs that should be sweet enough- hope its not a waste of your time or maybe you already tried it set up that way-good luck though

May 27, 2009 | Alphasonik (PMA640A) Car Audio Amplifier

1 Answer

Installing two amps

No, thats what you don't what to do. Even if you have 2 matching amps you don't do that. Every amp puts out different, and for 2 subs, you want to play at the the same time. If your only running 2 10's, I personal would just run the alpine (it's a mono amp made especially for subs) thats plenty for what you have. make sure you bridge them to get the full response. And your other amp i would use for your highs or mids, but run it @ stereo , which is 300 w @ 4 ohms. (Note: 600w @ 2ohms would be bridged and would play in Mono)

Building Competition stereo's is a big hobby of mine.

May 04, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers

It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Oct 31, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Da2200w wont kick out sound....

try using another input device for sound like a differert stereo or an ipod or try using another input channel on the amp such as high level or low level please rate -jeff

Aug 31, 2008 | Digital Audio 2, CHANNEL 600 WATTS HIGH...

1 Answer

Improper function

try hooking up your subwoofers in series. then connecting them bridged to the amplifier. as follows: positive from sub#1 into positive of amplifier left channel.. negative sub#1 into positive sub#2. negative sub#2 into negative amplifier right channel. turn the gain down as this will sound pretty loud.

Jul 13, 2008 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

600 watt 2 channel power acoustik sterling amp

On your amp, there should be a switch (on the side probably) that has "LP", "HP", and "FULL" or "OFF". This is a switch for the low pass/high pass filter. Switch it to "LP" as this will allow only low frequencies to go to your subs, what you want. If you don't have that switch, go to an audio store or online audio supplier and get either a low pass filter, band pass filter, or a cross-over, and follow the wiring diagram that comes with it to filter out the high frequencies before they get to your subs.

Oct 09, 2007 | Power Acoustik TS1440-2 Car Audio...

2 Answers

Amplifier On - No Sub Sound

Are you certain you put the wires back on the amp the exact way they came off. I am not familiar with this amp but most amps if you look at the terminals where the speakers hook up there will be a plus and a minus. And generally there are four terminals. hence stereo plus and minus left and right. Some even have eight for, four channels. Since the amp is on, not getting hot and you tried two different audio inputs I would suspect speaker wiring or maybe the stuff you put in your trunk bumped a switch on the amplifier. I know this is not the exact answer you are probaly looking for but it is at least a place to start

Jan 11, 2007 | Sony XM-DS1300P5 Car Audio Amplifier

Not finding what you are looking for?
Directed 600D Car Audio Amplifier Logo

Related Topics:

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Directed Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Ric Weide
Ric Weide

Level 1 Expert

5 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Directed Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides