Question about Jl Audio 500/1 Car Audio Amplifier

1 Answer

Hok up amp and all fuses blow on distribution block

Hi i have this jl audio 500/1 amp, everything is great and all of a sudden all my 3 fuses just blew out of the blue. i checked and double checked all power wire and grounds and reinserted the fuses and turn on the ignition and all fuses blow again. Also on my 40 farad cap from rockford the voltage goes to 9.5 within a couple of seconds and the fuses blow again. PLEASE help i love this amp for being a smaller amp. And by the way i have hooked a different amp a us amps de1000 and NO FUSES blew thanks scottie

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers
Re: hok up amp and all fuses blow on distribution block

Somehow, DC car voltage has gotten to the speaker outputs of your amp! your fuses are saving your speakers from meltdown. your amp has melted down. toss it after checking with ohmeter as follows: disconnect amp completely. red wire from ohmmeter to +12Vin. black wire to SPK+. if ohms are anything below 1000 ohms, then toss it. An electrical short is equivalent to flooding your entire house with a leaky faucet. No telling what that rapid current will encounter along the amplifier section. you could get lucky and find all power MOSFETS have shorted and replace them. good luck.

Posted on May 31, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Hello, I've Got the JL Audio 500/1 and I am running two 15" Kicker Comps. in a sealed box and bridged to my 500/1 and for some reason all of a sudden the amp now powers off then on none...

If your sure the unit is getting the correct power, check the ground cable, make sure it is connected to a clean surface. (remove any paint where the ground is connected.) Double check your wiring. Make sure all of your connections are good. Do not forget the fuse holder, check it too.

Apr 03, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a jl audio slash 500/1 series amp, and it keeps blowing the fuse. am i using the right one? which one should i be using?

if its the fuse in the fuse link then you should be using the a 50A fuse thats if on your amp there is fuses that total 60A when you add it up and if it still blows then you might have a short in the power wire between the battery and the 50A fuse

Aug 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a jl 500/1 . The distribution block is lit showing 12v plus. no green power light on the amp? I disconnected pwr and ground and reconnected. the green light came on for 10 seconds and shut off. all...

The amplifier will not power on unless/until it recieves the turn-on signal from the head unit.

It seems the issue is with the head unit in this case.

Check the fuses and verify constant and switched power with a multimeter.

Once the Head unit powers on - the amplifier should also.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Jun 18, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs

maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1 amplifier will not turn on

you may have burned the channel you were using..try taking the cover off the amp and checkin for burned spots or any wires that may be loose or touching within the amp.

Feb 24, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Fuse keeps blowing

The amplifier probably has shorted output transistors. If the amp only blows the fuse after remote voltage is applied, the damage may be minor. They generally blow two transistors. Sometimes that's all that needs to be replaced.

Let me know if you have any other questions.

Aug 29, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl audio 500/1 amp

You may have the amp set to turn on via an audio signal. Set the Signal Sensing switch to OFF.

Jun 13, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl Audio 500/1 Car Audio

There are no fuses inside the amp.

Are any of the lights lighting up on the amp?

If so, which ones?

Jun 09, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

500/1 and 300/4 jl

Need more info here. did you run power from the 500/1 to the 300/4, or did you run the signal from the 500/1 to the 300/4? Also which amplifier is cutting out for a min...the 500/1, the 300/4, or both? each amp should be wired to a distribution block with 4 awg power wire recommended for each. the amps should also be wired without any capacitor.

Mar 17, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Blowing fuses

You will need to have the amp bench tested at full load to see if there is a pending problem. It will need to see with speaker loading resistors, how much current the amp is drawing and at different frequencies. if the amp checks out with the proper current, at the rated output, have the speaker checked out. Good Luck

Jun 15, 2007 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 500/1 Car Audio Amplifier Logo

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides