Question about Car Amplifiers

1 Answer

My amp works but something is wrong with the wiring or something.

Ive had my amp for about a month and it just quit working all a sudden. I tried my amp in my friends car and it works fine. but when i put it in my truck it will sometimes will ficker on off when the truck is cut on. ive took my radio out and checked it out and all my wiring. So what could be the problem??????

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 4 Answers

There is a loose connection on the power supply going to your amp,check the fuse holder

Posted on Jan 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

8" compact subwoofer not working it was installed


post more information about your amp. its likely the vibrations moved something in the amps, or buttons.

Oct 10, 2013 | Alpine Swe-1000 8" Compact Subwoofer...

1 Answer

800 watt mono block sony xplod amp blowing my dual coil 1500 watt subs


if the wiring to the sub is correct, then you have something wrong with the amp itself... something is power surging to the subs which is causing them to blow

Aug 25, 2012 | Car Amplifiers

1 Answer

My amp quit working i might have overloaded it. ive checked all the fuses on the out side all wires r hooked up properly. i was wondering if there is a couple of fuses on the inside and what can i do if...


The only servicable components on your amplifier are the extrenal fuses if any.

If you have checked them and there is othing wrong then you will have to send your amplifier in to a reputable dealer to have it checked and repaired.

Nov 07, 2009 | Pioneer GM-5300T Car Audio Amplifier

1 Answer

New amp


Something is def. wrong. did you check the fuses on the amp after the light went out? probly have a bad connection somewhere. check ground wire and power make sure they have a good connection and arent cut up and shorting out.

Oct 21, 2009 | Pioneer Car Amplifier GM-7100M - Mono Bass...

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Something Wrong With my Fosgate 500-a2 Amp


Is the amp being fed directly from the head unit's RCA preamp outputs or is it being fed by another amp's preamp outputs? Try temporarily wiring up a speaker you know is good in place of the sub and see if anything changes.

Apr 01, 2008 | Rockford Fosgate Punch 500a2 Car Audio...

2 Answers

Lanzar Vibe 1200D protection light


You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

2 Answers

Amplifier stop working


this problemis your amp is dead powerflux you need the asistance techinic

May 27, 2007 | Crunch BlackMaxx BLX2000D Car Audio...

3 Answers

Phase Linear UPA424...No sound


I had the same problem with mine but i had the 224 version first worked nice just for a small system but i just got this one today and i hooked it up to a small sub box how i had the one before and it just dosent work the other one quit beforhand and i thought it just went bad so i figgerd id buy this one but after about and hr n 1/2 of work to show nothing kinda was a depressing moment, ive gone through my wireing about 4-5 times now and drawn it out 2 times on eveything ive done im just lost, ive even tryed diffrent rca and also tryed a diffrent radio and still nothjing tryed messing aorund with settings still nothing its kinda a bummer

Sep 10, 2006 | Phase Linear UPA424CS Car Audio Amplifier

1 Answer

My amp quit working


ok I thought I anwered this one but first thing to try is disconnect all your speakers and see if the light goes out if it doesnt then your gonna need a schematic and a working know how on solid state amplifiers. first check al the outputs for the speakers for dc If theres dc on an output then that output device is shorted or leaky. Ive have open drivers as well as current control transistors leaky or shorted to that made the protection come on.. Good Luck

Apr 07, 2006 | AudioBahn A6004T Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...