Question about Aquabot Turbo T

Open Question

My Aquabot T doesn't turn on. It was working yesterday but will not today. It is dead. It is about 6 months old.

Posted by on

  • witch-1 Mar 30, 2009

    I have no power to bot from transformer. I just purchased a new transformer.

  • Shell06 May 11, 2010

    The website: http://www.i-love-my-aquabot-automatic-p... gives great troubleshooting advice, and if you are near Phoenix AZ I'll be glad to help you. S. Christian dansker01@msn.comh

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power supply will not turn on


make sure outlet has power if so check for fuses if no fuses need new power pack

May 25, 2014 | Aqua Products Aquabot Turbo T-jet By

1 Answer

Problem with the Aquabot Robotic Pool Cleaner Just


The service center is stonewalling you; contact them again and demand they look at it. The unit should run consistently regardless of water balance. Water balance will affect the lifespan for a product like a pool cleaner but not whether or not it works at all. As for climbing, water temp plays a roll but 65 should be enough...what material are the pool walls? Fiberglass or some lines are too slippery for the standard brushes to climb efficiently. The service center should be able to recommend any changes that may be required due to certain pool materials you may have. Discuss that issue further with them or the manufacturer.

John

Mar 29, 2011 | Aquabot Robotic Pool Cleaner

1 Answer

Started filter yesterday for 4 hours and then shut it off. do i need to do anything different when i restart it today?


no just turn it on pumps and filters are sized to turn over the pool volume in 6 hours so install a flow meter or just let the pump run for 6 hours to be safe

Sep 01, 2010 | Hayward SAND FILTER, PRO SERIES

1 Answer

Aquabot wont pump or move, intermmittent


Well either you have a jammed up motor, or a bad motor, or the Controller unit has faulted.
http://www.robotshop.ca/PDF/aquabot-turbo-t2-manual.pdf
Above is a manual, this should help you it has exploded diagrams to help. There seem to be many ways that it could get tangled up, or maybe the belt has come off, any way it's about time to A: Get a screwdriver, or B: Call a service man....

Jun 01, 2010 | Aquabot Aquaproducts Automatic Swimming...

1 Answer

The pump doesn´t work, i bought another one, new, and only worked one hour


Extremely dirty pools or very fine dirt can clog the debris bag and cause the unit to stop operating. IF the unit comes up with debris in the bag, it's working.

Nov 28, 2009 | Aquabot Turbo T

1 Answer

The rollers are not turning. It is not an electrical problem because water shoots from the top.


There are two motors usedi n an Aquabot. The pump motor is separate from the drive motor, and the drive motor acts to drive the wheel tubes by means of a belt drive system. If the drive motor is working ( lookiing at the unit under power, the drive motor shaft which an be seen on either side of the unit is turning) ,t
Then you have a dive belt problem, solved by replacing the drive belts. If you happen to be in or near Phoenix, Arizona, I can help you replace the belts. If not, the belts can be purchased fairly inexpensively and are not hard to replace. If the drive motor is shot, the only answer is to contact an authorized repair center. S. Christian dansker 01@ msn.com

Aug 14, 2009 | Aquabot Turbo T

1 Answer

I just bought replacement scrubbing brushes for my aquabot. The new ones are different. How do I install the new style cleaning brushes?


http://www.i-love-my-aquabot-automatic-pool-cleaner.com/Aquabot-Troubleshooting.html my give useful instrucyions, or, if you are near Phoenix Az I'll be glad to help! S. Christian dansker01@msn.com

Jul 12, 2009 | Aquabot Robotic Pool Cleaner

2 Answers

My aquabot does not reverse


check with the website: http://www.i-love-my-aquabot-automatic-pool-cleaner.com/Aquabot-Troubleshooting.html which gives a wealth of information and ideas to try. S. Christian dansker01@msn.com

Jun 30, 2009 | Aquabot Robotic Pool Cleaner

1 Answer

Aquabot Turbo T won't climb


1.`. Replace your old, water logged floats. They will dry out when the unit is out of the pool, and the unit will work fine until they water log again, which may takes as few as 10 minutes in the pool. 2. Stop using all those words *********** didn't teach you and probably didn't even know...This is a common problem. http://www.i-love-my-aquabot-automatic-pool-cleaner.com/ gives some really good insight, too! S. Christian dansker01@msn.com.

May 11, 2009 | Aquabot Turbo T

Not finding what you are looking for?
Aquabot Turbo T Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aquabot Pool & Spa Pumps Experts

Jay Finke
Jay Finke

Level 3 Expert

1222 Answers

Rich Florenzen

Level 2 Expert

333 Answers

Mike

Level 3 Expert

4331 Answers

Are you an Aquabot Pool and Spa Pump Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...