Question about Alpine CDA-9885 CD Player

1 Answer

My kenwood amp wont push my 10" rockford falsgate punch sun

I got it all intalled and it worked fine then a week or 2 later i turned my radio on and it didnt work. i have power to the amp and good channels. Everything is fine it just wont push it. But when i hook my two 6"s to the amp it pushs them untill i turn it up about a quater of a way then it will kick off untill u turn it back down. I evened tried changing subs, rewiring all the wires in and out of the box, and put it on another cheannel. It just cant push it anymore. Could it be a bad conection on the ground or pire wire? If not do you know exzactly what it is?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 57 Answers

It sounds like a bad ground, I would go through all your connections

Posted on Jan 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just bought the used car and radio was working. Came with a Kenwood KDC-148 stereo. 2 days later, radio just was dead. Have checked fuses, wires and everything looks good. Everything else electrical...


Check the power from the harness. The yellow wire which is usually for constant 12v power and the red wire which should only have power when the key is turned on. check those wires and if you have power on both then the radio is fried. Try pushing the pins in the back of the radio harness in and see if maybe there is a loose pin, other than that, like i said , the radio may be bad.

Jun 28, 2011 | Kenwood KDC148

2 Answers

Kenwood kdc-mp442u protect mode came


First of all , your Kenwood shows only Protect on the display when your speakerwires are conflicting with each other , but when you cannot find the problem there....

disconnect them one by one to see wich speaker in your car is conflicting (shortcuts).

Replace that speaker and your kenwood will work just fine.

I had the same problem here with a brand new Clarion speaker .

Oct 08, 2010 | Kenwood KDC-MP442U

2 Answers

Kenwood kdc mp228 now working with amp/subs


Hi, ensure amp has 12v on the "+" and "rem" terminals and has a good ground to the amp, This is all the amps needs to start up

May 05, 2010 | Kenwood KDC-MP228 CD Player

1 Answer

Wont turn on


first ck your fuse panel either from 15 to 25 amp bottom of your left leg if the driving position of left side or European on right side,than you might also have to ck that hot wire constint at the back of a radio"IF "the fuse is not the problem,and power wire when Ignition is turn ON...you will need a test light and a volt meters.but do not used a meter to ck. for AMP unless you have a best volt meter could handle with 25 amps and over..ck all your radio connt. wire if its loose wires or radio tips contact with wire connt.,,ck for grown and negative connt. also...some model of a radio aftermarket have a fuse at the back of the radio also,you will need to ck that with test light is it OK or not,if all seem to work fine than Sorry is RADIO need to replace....REMEMBER any radio is over 1db will cause your hearing problem in the future remember thats when you turn on too much of a WATTS

Apr 02, 2010 | Kenwood KDC-5090R CD Player

1 Answer

Kenwwod DPX303 dead, Worked yesterday and today wont power on. Fuses are all OK . Hit the reset button no change. Any Ideas? Rgds R


There may be multiple fuse boxs in your car, you need to make sure to check all of them listed in your owners manual. Checking involves a voltmeter and not just checking the 2 fuses you think supply power to the radio, there may be multiple fuses that supply the necessary power to the radio. Yellow and red at Kenwood need to see 12 volt positive with the key on and the black needs to have ground in order to turn on. If all three have correct voltage then pull the harness from kenwood and check small 10 (red) or 15 (blue) fuse held in and protected by the harness. Good luck!

Feb 28, 2010 | Kenwood DPX303 CD receiver

1 Answer

Truck keeps going dead


250 mA drain isn't enough to be a short circuit...it most likely is the capacitors continuously charging.

One way to confirm this is to put an ammeter (with a fuse inline) in series with your main power feed to your stereo power supply. By adding or disconnecting individual components, you can quickly determine where your power drain is coming from.

Feb 05, 2010 | Car Audio Receivers

1 Answer

My radio was working until my ipod was pluged in and some buttons were pushed and now the radio will not work. we check all the wires and antenna conections and the are all pluged in. my radio is a Kenwood...


Yes, I'll say you pushed some buttons.. By reading your scant descritption of your problem i would guess that
1. You do not have an amplifier driving the speakers, and using the deck to power the speakers?
2. If this is so, in your button pushing bliss you turned off the built-in amplifer. See the deck thinks you have a amplifier running the speakers so to conserve power you can choose to turn off or on the built in amplifer. I see that frequently at my shop but you must of been playing those buttons like a piano because it is like 3 subsets back from the main menu... But enough lets get you back to good shall we?? OK here is all you do..
1. Get the unit in "Stand-by" mode
2. Than choose Menu .
3. Scroll all the way down until you find "AMP"
4. Using the side to side knob choose "ON" because you set it to "OFF" .
5. Get out of Stand-by and turn on the radio and enjoy. I will say that damn deck has more settings and options than the Space Station. Time delay, crossovers up the gazoo, every audio do-dad imaginable. Which you have just found. Good for you... Mark @ Sounds Good to Me . Tempe, AZ remarkable53@aol.com

Aug 17, 2009 | Kenwood KDC-X492 Car CD/ MP3 Player

1 Answer

Installing kenwood kdc-mp238 in a 2001 dodge ram 2500 quad cab


No ur radio is fine to fit the wiring harness into ur dodge the wiring has been crossed so it wont work, if u go 2 the Kenwood US site and down load the KDC MP 228 manual it has a good wiring dirgram and with a bit of work u can work out what goes where :0 Hope this helps

Oct 11, 2008 | Kenwood KDC-MP228 CD Player

1 Answer

My kenwood kdc-mp235


I assume the amp is turning on (lighting up) No audio may be due to Burnt rca ground trace in your kenwood radio. If you have a ohm meter measure continuity from rca's ground terminal to radio chassis. Should be close to zero resistance. If there is no no continuity there are fusible traces on radios main board that burn open at times when to much current is flowing thru rca ground
Just a good possibility , haver seen this happedmany times.
If you need service manual let me know kstahl65@att.net

Jan 23, 2008 | Car Audio Receivers

Not finding what you are looking for?
Alpine CDA-9885 CD Player Logo

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio Receivers Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Alpine Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...