Question about Sony XM-504Z Car Audio Amplifier

1 Answer

Amp worked fine for 1year, all of a sudden it just does the following

Http:// ( Hello, I got this set up for a year now, a sony 500w amp with an xplod sony 300w subwoofer ... I got my battery changed last week and 2 days later my Amplifier turns off, at high volumes, I saw the exact same problem on another post, but the "help" didn't help, or let's say I don't nessiceryly know what a 4 gauge wire and a 8 gauge wire are, and why my setup started doing this just now, after one year! (is my battery giving out too much volts, or too much amps? it seems to be getting real hot on the outside (like when I put my hand on it I feel a little pain the first touch but after a while my hand gets used of the heat!? is that an overheating problem? it sometimes happens and sometimes it just doesn't for a while! I don't want to go back to sony and give it for service!? they'd only want more money! I'm even thinking of buying a new one!? please help me! (It does this also when the device is cold) I checked the wireing already, and everything seems fine! (I connected the Amplifier to a random MP3 player and had the same problem for a while, and all of a sudden .. it stoppen, and started working normally!) Comment by eXiscute, posted on May 26, 2007 when it shuts off, it goes into protection mode... Comment by eXiscute, posted on May 27, 2007 there is another thing! when I turn off my Radio, or if I lower the volume to 0 ... from vol 1 to vol 0 , my sub does some kinda cracking sound!, is that the grounding? )

Posted by on

1 Answer

Re: Amp worked fine for 1year, all of a sudden it just does the following - Sony XM-504Z Car Audio Amplifier Car Amplifiers

You need the asistance the specialiti

Posted on May 27, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Car amp not working

is amp getting power or not could be wires came loose inside speaker box

Mar 29, 2012 | MTX JackHammer JH600 Car Audio Amplifier

1 Answer

Amp is only driving the subwoofer when in low volume. If i raise the volume amp shuts down and only works again if i turn power completely off.

Hi, please do the checks at the following post and let me know if you have questions;

Jun 04, 2011 | Alpine MRP-M500 Car Audio Amplifier

1 Answer

Can you run a 8 gauge power wire to a jl audio 1000/1 amp and not have problems even though jl reccommends 4 gauge power wire?

Hi, if you're going to run a smaller wire, you also need to use a smaller fuse. A 50 amp fuse is needed for 8 gage wire. The fuse is there to keep the wire insulation from melting, which is what will happen if you run too much power thru the wire. If you don't plan to turn the amp up too high, this may work fine, but I would test it first with a 50 amp fuse before installing. You will need all of the speakers hooked up and the gain set to max to test the power draw. See the following link on wire sizing for more info:

Mar 14, 2011 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Amp will not power on at all all of a sudden, fuses look fine

Hello schapman81,

You do not say if there are any indications or errors displayed.

I'd recommend you follow the troubleshooting steps here starting at Step 2 (B+ and Remote Voltage:). This should tell you if there's a problem in the wiring or if the amp itself has failed.

Hope this helps.

May 09, 2009 | Crunch Powerzone P2200 Car Audio Amplifier

2 Answers

Chicken head knobs

I get alot of amp building supplies at Hoffman Amplifiers.
Follow this link and click on the TUBE AMP PARTS button:

Hope this helps!

Dec 30, 2008 | Peavey AMPLIFIER, 1000 WPC, DDT, 8/4/2...

1 Answer

Internal capacitors keep burning

youre overloading the output reduce to at least 4 ohms impedence speakers

Oct 31, 2008 | Power Acoustik A3000DB Car Audio Amplifier

2 Answers

Sony xplode 1000 watt amp

Make sure you don't have a short circuit somewhere. Make sure the wiring is all intact.

Also look at this link:


Nov 07, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Amp protection light

Hi again, Looks like you posted twice, in any case pls have a look at your other post @

Aug 15, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
Sony XM-504Z Car Audio Amplifier Logo

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56631 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides