Question about SpeakerCraft BB275 2-Channel Amplifier

1 Answer

Power problem When I turn on the power switch the red lcd light comes on after about 3 to 4 seconds it fades out. All the fuses look good. inside it looks like new, boards are clean, no signs or smells of any burning. any suggestions? thanks for reading, chenk

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 883 Answers
Re: power problem

Look for a small pinhole and insert a pin while powered up to reset the device

Posted on May 26, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a sony s-master digital amplifier which will not power up: when I plug it i to power it takes about 30 minutes before the red standby light comes on but no other functions operate.

So the standby indicator never changes state? If so, more than likely, your amplifier has DC Offset(a damaged amplifier inside) which will keep the speakers off, and disable any use of the front or remote functions. If you are interested in having your Sony repaired, please refer to my website, You may contact me there. Thank you.

Jul 11, 2015 | Amplifiers & Preamps

1 Answer

Hi, My protection indicator should change from red to green after 3 seconds after power is switched on on my SM 7100H amp, after 30 years it has decided to stay on red and i have no power, any advice,

The power detector, will not sense the correct voltage available. So it won't apply the power to the amplifier. Just to avoid damage to the amplifier. I don't have a technical manual, so I don't know what voltages you should measure, but at least one is not good. You could check is there is any fuse in the system, or perhaps you even can measure the voltages. Perhaps a diode failed or an electrolytic capacitor?

Feb 03, 2015 | Amplifiers & Preamps

1 Answer

Hi, my sony ta-fe370 has stopped working. All fuses seem fine and there is no obvious visual problems inside. The red led next to the power button comes on but then goes out again. The source selection...

What power are you meaning that Also, all of the other decks connected to this also have lost power Is this mains power If so check the power on the switch

Oct 12, 2013 | Sony TA-FE370 2-Channel Amplifier

1 Answer

Stereo Amplifier fades out. My Sansui dolby pro

No that's how to describe a problem, folks - with details. Using internal FM as the source is always the preferred way of troubleshooting system-wide receiver audio problems (no cables or setting in the way).

Does the sound come on immediately with power and then fade or is there a small delay while the electronics stabilize, a click and then sound that fades?

The fizzle probably means something is rapidly overheating or a capacitor is malfunctioning. If both channels do it, I'd suspect a common power supply problem. Can't help much more than that.

Dec 12, 2009 | Amplifiers & Preamps

1 Answer

Nad c 370 no power

You need to look inside. There will be a fuse inside too. If your lucky it will restore the amp once replaced, but if it blows again you have a fault. You can track it down yourself if your any good, you might even see a burnt out part when looking for that fuse, otherwise get the repairman in.

Sep 20, 2009 | NAD C370 2-Channel Amplifier

1 Answer

Behringer EP2500 trips immediately when turned on

Power supply section is overloading probably because of audio power amp problem.

Mar 31, 2009 | Behringer EUROPOWER EP2500 Amplifier

2 Answers

Europower Beringer PMH3000 power turns on then turn off?

when you turn on the AMP and the red light comes on give the amp 2 seconds and turn it back on the red light should turn off. That is what I do with the amps at my church and it works for me, I hope that this works for you too.

Mar 25, 2009 | Behringer EUROPOWER EP2500 Amplifier

1 Answer

Onkyo amplifier

Is power coming out of transformer at the right voltage. Also may have a power i.c. shorting to ground.Final anp i.c. may have a place to go to ground through a shorted capacitor.
Big Red

Dec 17, 2007 | Onkyo TX-SR674S 7.1 Channel Up-Converting...

2 Answers

Problems with the Operation circuit on Technics SU-A900 MKII aplifier.

Hi There Cushy,

The Amp needs Power.....and if the power switch is turned on and the light doesnt come on then there is no power....

Have a good look around the back of the amp and see if you can find a fuse please...

Its a small circular plastic item labelled "FUSE" with a screwdriver slot in it..

Turn the power off at the wall socket then unscrew this fuse holder, the glass / ceramic fuse will come out,,, replace it with one of the same physical size and of the same rating probably 1.5Amp.

Turn the amp back on and it should go if not then there is a major failure inside the case.....Needs a serice call Im afraid....

Cheers From YUBEUT

Nov 17, 2007 | Amplifiers & Preamps

Not finding what you are looking for?
SpeakerCraft BB275 2-Channel Amplifier Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top SpeakerCraft Amplifiers & Preamps Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5327 Answers

Gil Shultz

Level 3 Expert

3250 Answers

Are you a SpeakerCraft Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides