Question about DeLonghi DSM7 Stand Mixer

1 Answer

Runs fast for a few seconds , then runs very slow

M/N DSM7 S/N 0048558 I'm trying to find out what the cause of this proble is. and are the parts avalible for it?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I had the same problem and fixed it.

  1. I took it apart, unplug unit, remove the small black cover inside the stand portion, 1 screw. Underneath you will find four screws with a white plastic wire junction.
  2. Loosen two screws and remove the black and brown wires which connect to the control panel with the dial attached.
  3. Remove rear attachment cover, front top cover, and front delonghi cover.
  4. Remove top three screws where the blender attachment goes. Now remove the aluminum cover that covers the entire top.
  5. Slip belt off. Remove three screws with plastic washers that attach motor to chassis.
  6. Remove 2 torx screws that are located next to metal bar that keeps top half from swinging too far from bottom half.
  7. Now you can pull the motor out and the control panel with the dial. Remove the three slip on electrical connections on the control panel and reinstall. Carefully remove the two slip on electrical connections on the motor and reinstall.
  8. Re-assemble and test unit.
I thought I had a problem with the control panel or the motor, as it turns out the connections were the problem. Carefully removing them and reinstalling them solved the problem.

Posted on Feb 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mixer works fine with speeds up to 6, but changing to 8-10, speed stays the same.


Sometimes can be caused by running too fast on the lower speeds. Should be 13 to 15 revolutions in 15 seconds on speed 1 then a slight increase only on speed 2.

Aug 01, 2013 | KitchenAid K5SS Heavy Duty Commercial...

1 Answer

STAND MIXER SPINS FOR A SECOND OR SO THEN STOPS


can you clarify a little more, it is either a gear problem or an electric problem, are there any other symptoms? Like sound noises, grinding fast speed when it does run for those few seconds or really slow. if it is running fine while it does run then it is more likely a speed plat or phase control board. please let us know

Sep 13, 2012 | Food Mixers

1 Answer

I have a KM800 and the speed setting doesn't work properly, on slow it will go fast then slow and doesn't speed up and slow down as it should. is this repairable, as it's bloody annoying when you disa


Hi Emma,
Not going to be much help here to be honest. We have the KM020 and this is the only problem we have had with heavy machine use in 4 years - and a minor issue at that.
This place is good for spare parts http://www.buyspares.co.uk/

If you're in the UK, you can call this number 02392 392 333 and give them your post code, they'll let you know who the local service agent is.
All the best,

Dec 17, 2011 | Kenwood KM800 Major Classic Stand Mixer

1 Answer

Kitchenaid K45SSWH Mixer only starts fast then sometime slows


You can try adjusting the speed control as shown in section 6 of the service manual:

http://lib.store.yahoo.net/lib/mendingshed/kitchenaidservicemanual.pdf

Also remove and clean the brushes as shown in the same manual pg 8 fig. #30.

Apr 11, 2010 | KitchenAid KP2671 Professional 6 Series...

1 Answer

Kitchen Aid stand mixer just started going really fast at the lowest speed. I tried checking the sensor as some have suggested but is still goes really fast. It's only been used a few times. Is there...


Hi. Goto www.mendingshed.com , locate and download the free Kitchenaid Service Manual. This is a comprehensive manual and will help you with your task. You can also go to the Kitchenaid website and download the Parts Catalog for your mixer model.
Good luck!

If this solution has assisted you, please rate it. ricardok45.

Mar 10, 2009 | KitchenAid K45SS Classic Stand Mixer

1 Answer

Mixer motor shut down


Mine did almost the exact same thing one day. I have the Artisian Model, It would do it on any of the lowest speeds. Dont know if this will help you or not but I just ran mine the next day on all the way high with the spash guard on for making whipped cream for about 6 minutes full throttle and for some reason it hasnt went slow and shut itself off since then. Mine is about 7 months old. I called Kitchen Aid but their customer service all of a sudden seems to not know english worth a poo...

Try running yours on full blast for 5 minutes with something simple in the bowl. If its a 250 watt or higher make whipped water out of 2 cups of water and a tablespoon of cornstarch. Run it till you get what looks like whipped cream. Oh yea. Use the Balloon whip. The lubrication in the motor is supposed to last for at least 5 years but I have seen on numerous post's that if you run them on all the way for at least 5 minutes the oil will even out in the motor. Running the mixers at low speed alot will cause the oil inside not to move as freely since the motor doesnt heat up the oil in the gears.

Good luck.

Nov 15, 2007 | KitchenAid KITCHEN AID 5 Quart Artisan...

Not finding what you are looking for?
DeLonghi DSM7 Stand Mixer Logo

184 people viewed this question

Ask a Question

Usually answered in minutes!

Top DeLonghi Food Mixers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Custom Exchange
Custom Exchange

Level 3 Expert

397 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a DeLonghi Food Mixer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...