Question about Orion 1200D Car Audio Amplifier

1 Answer

Orion cs150.2 "red" power light=need "green" power light, is this a amp problem or install problem?

Posted by on

  • Jimmy Hall
    Jimmy Hall May 11, 2010

    dude, need more input. has this set-up ever worked?
    what wire gauge are you using? fuse rating? are you connected to a single 1 ohm sub-woofer or dual 2 ohm speakers? see? lots of possibilities. reply & we'll go from there. in the mean time I'll try to find an install manual for this.

    peace out

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Could be either... check to make sure that you have a good ground... it should be grounded to a place on the vehicle that is bare metal... if you have a good ground then it is a problem with the amp and you should contact the manufacturer to setup repairs...

Posted on Jan 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Amplifiers

1 Answer

Hi there, i have a orion cobalt 2105xp 400. i have hooked all up, but very little bass. i have 1 10" boston acoustic sub. i noticed that the led is constant red, is it supposed to be green, crossover...


amp is in protect mode. check your wiring and make sure your sub is wired properly for ohms. dual 4 ohm in parallel = 2ohm. dual 4 in series is 8 ohms. dual 2 ohm parallel= 0.5 ohms and in series 4 ohms. check ground and power wires. make sure sub isnt blown. a blown sub WILL cause this on any amp.

Sep 10, 2011 | Orion Cobalt 2105 XP Car Audio Amplifier

1 Answer

Directed d2400 red and green lights on constant and no output...whats the solution


ok ive had an orion amp do this before. oiron is made by directed audio now so its the same style amp. after i checked the ground, power, subs to make sure they were good and not shorted together, i came to the conclusion the amp was bad. its in protect mode right now so check everything with a multimeter and make sure everythings good. if all is ok the amp may be bad. good luck.

Dec 23, 2009 | Directed 2400d Car Audio Amplifier

1 Answer

Orion hcca 250 digital reference


if its hot its drawing to much current sound as if you have something improperly hooked up..if i could see your wiring i could help u out better steve

Feb 27, 2009 | Orion HCCA-D5000 Car Audio Amplifier

1 Answer

Orion cs150.2 amp power light "red"for protected need "green"


remove the load (subwoofer)...
ensure the power and remote have 12V (remotoe only when the car is on)....
And make sure the ground is a good one - sanded and screwed.
If you now turn on the car, and the red light for protection still stays on, your problem is internal, and it will need to be serviced. This is not something that you can crack open and fix, as there are lethal amounts of stored energy in the power supply and capacitors.

If the light goes on, youe sub(s) is/are at fault. Check the impedence with a multimeter set to OHMs and read the voicecoil. It should read pretty near to 4 or 8 ohms.

But since your amp is the only piece new to the equasion, chances are the problem lies within the amplifier.

It either has fried components, or your subwoofer(s) are wired to a low enough impedence that your amplifier does not like.

With more info... model #s voicecoil configurations I can help you better. I will c/p an answer I wrote recently regarding amplifier failure.

Jan 05, 2009 | Orion 1200D Car Audio Amplifier

2 Answers

Orion 2400 mono


My esp light is blinking yellowish and the amp isn't putting out. I have power to it, just not putting power to my subs. anyone know how to help?

Feb 25, 2008 | Orion XTR Pro 2400 Car Audio Amplifier

1 Answer

Wiring for 2500d orion amp


ground wires(heavy black)is connected when the red light lit.so no need check the red hot wire which is connected to battery terminal maybe loose.or theres no power comming in.thre are 2 hotwire in that amp one is red which is the main and yellow or sometimes orange which is the remote on. now if you sure that the power terminals is properly connected,ur speakers is working and input wires are good and still no sound. your amp is probably gone...do not try experimenting the wires or hook up two amp by any means..u might destroy all ur amp. hope this help u....

May 11, 2007 | Orion 2500D Car Audio Amplifier

Not finding what you are looking for?
Orion 1200D Car Audio Amplifier Logo

Related Topics:

181 people viewed this question

Ask a Question

Usually answered in minutes!

Top Orion Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

yadayada
yadayada

Level 3 Expert

60960 Answers

Are you an Orion Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...