Question about Car Audio & Video

1 Answer

Power protect light red,

Ground good unhooked all wires then reconected power and ground only still red

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Car Audio & ... Master
  • 33,359 Answers

The protect light is indicating that you have an internal problem wit the amplifier. The problem will have to be corrected before the amplifier can be used again

Posted on Nov 05, 2012

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: my amp goes in protect mode

Maybe the audio amplifier IC´s are damaged

Posted on Feb 07, 2009

etirbynnor
  • 655 Answers

SOURCE: !!!red protect light is on!!!

Hello beaugarcia26,

Unless the amp itself is defective, there's a short or ground somewhere.

First disconnect the speaker wires and RCA (or high level) inputs, leaving just ground, remote turn-on and power leads connected. Then see if the amp powers up normally. If it doesn't check the ground with a multimeter and make sure it is good. If the amp powers up normally, check the speaker, speaker wires and inputs for shorts or grounds.

Hope this helps.

Posted on Sep 03, 2009

  • 113 Answers

SOURCE: stock red light protection in my crunch amp

it is most likely a blown mosfet inside the amp

Posted on Sep 04, 2009

  • 631 Answers

SOURCE: my lanzar vibe 266 goes straight into protect so i

It likely has shorted output transistors.The following page may help.
http://www.bcae1.com/repairbasicsforbcae1/repairbasics.htm

Posted on Nov 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Its on protect mode how do i take it off?


Generally if your amplifier goes into protect, you have a bad ground.
Unhook your power wire from the battery and trace your ground wire to the chassis of the vehicle. Strip the paint from the ground location, Put the ground wire back on the grounding location. Tighten the ground wire down securely with no play and hook back up your power wire.

Other cases revolve around the RCA cables.

Unplug the RCA's and see if the protect light goes off.
Plug one in and see if the protect light comes on and then the other.
If the protect light comes on, you have bad patch cables. Replace them and see if your issue is resolved.

If the amplifier was shorted, the system board made have been damaged.

Jul 28, 2010 | Car Audio & Video

1 Answer

I have a alpine mrp-m500 for about two years no problems at all. but one day it stops producing sound. i check all fuse on the whole system. is the a protect mode? and how do get it out of it?


If you have checked all the fuses.
Trace your ground wire that goes to the frame. It may be possible your ground is no longer grounded properly. You may just need to unhook the fuse from the battery, Unhook the ground wire from the chassis and restrip, put on a new connector, chisel off the paint around where the amp was grounded to and tighten it back down. Hook back up your fuse to the battery and check and see if it removes the protect light.
Also check to make sure your RCA cables aren't bad. If the RCA cables ground it'll put the amp into protect mode too. Basically just switch out the RCA cables for a good pair.
If the remote wire on the amp is touching the ground, it'll throw the protect light too. That's pretty much the extent, unless the amp has a short inside it.

Hope this helps!

Jul 26, 2010 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

My red power protect light is on and i dont know what to do ive unhooked it and checked the fuses but nothing


Power it on with only the 12Volts from battery, the ground, and the remote from your stereo. If it still turns red, then your amp is shorted. Check all your speaker inputs to make sure you don't have a wire shorting out the speaker inputs. Now if it turns on green when you test it like this, then install one speaker input at a time to check and see if you have a grounded/shorted wire. it will turn red as soon as it's plugged in. hope this helps.

Apr 13, 2010 | Pyramid PB1615X Car Amp

1 Answer

Amp stuck in protect mode.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Double check all connections. Good Luck.A thumbs up would be greatly appreciated if this answer is helpful to you. Worth fixing.
amp-stuck-in-protect-mode-flhv0giodkaywsjitcb2uyf1-2-0.jpg

Nov 22, 2009 | Power Acoustik Car Audio & Video

1 Answer

My 1985 ram 50 has lost all electrical power


How old is the battery? How are the cables and ends that hook up to the battery? If you have a Voltage meter check the batt. voltage should be about 12.6Vdc. Check your cables for crossion and clean that off and reconect the battery. You will also have whats called fuseable links that are conected to the main red or positive cable these fusable links are fuses that look like wires. They protect the car from major shorts, but do break internal sometimes. The best way to check these is with a voltmeter also, should have volts at both ands as it is checked to the ground side of the battery.  

Nov 21, 2009 | 1985 Dodge Ram 50

1 Answer

!!!red protect light is on!!!


Hello beaugarcia26,

Unless the amp itself is defective, there's a short or ground somewhere.

First disconnect the speaker wires and RCA (or high level) inputs, leaving just ground, remote turn-on and power leads connected. Then see if the amp powers up normally. If it doesn't check the ground with a multimeter and make sure it is good. If the amp powers up normally, check the speaker, speaker wires and inputs for shorts or grounds.

Hope this helps.

Sep 02, 2009 | Hifonics Brutus BX 1205D Car Audio...

3 Answers

Amp overload protection mode


it sounds like the ground is bad to begin with and check the positve cable for oxidisation on the battery terminal and at all other places that the power wire is connected to

Aug 09, 2009 | Kenwood KAC-8104D Car Audio Amplifier

1 Answer

I have a power acoustik ps2-2600 it went out this morning the red light was on i checked the ground it was fine when i unhook the remote or the audio cables it turns off if i hook up the audio alone it...


unhook all the cables including power let sit for 15 minutes and than hook up the ground rca cables remote and than power in that order with the car off and the battery unhooked that hook the battery up the amp went to protect mode to keep it from blowing i hope your amp isnt like some that only the factory can reset most amps arent and reset themselves

Apr 20, 2009 | Car Audio & Video

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Mine is actually a q4000 4 channel amp


First of all, you MUST HOOK UP YOUR GROUND WIRE FIRST. You may have damaged it if you hooked your power and trigger wire first and then the ground wire. Unhook EVERYTHING except the hot wire, ground wire and trigger wire. If you still can't get the unit to come on then it is time for a trip to the repair shop. Good luck.

Feb 01, 2007 | Cadence Q200 2 CHANNEL POWER AMPLIFIER...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

485 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

The Knight
The Knight

Level 3 Expert

73691 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...