Question about Car Audio & Video

1 Answer

Amp light turns on then quickly turns of

Everything is wired right good ground even when i lut direct power it does the same thing

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 689 Answers

The amp has developed a internal (Problem) Will have to be taken in for repair, If you got it used , Some one didn,t have the speakers wired up right, End fried some thing inside of it,

Posted on Nov 07, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 883 Answers

SOURCE: Problems with Infinity Amp 611A

are you running a large ground wire directly to the battery negative terminal?

Posted on Jun 03, 2007

imseth85
  • 30 Answers

SOURCE: amp not turning on

wouldn't be the first JL amp I saw fried...but there are some tests you can do. First of all, double check your fuses, they may appear to be fine, but sometimes they are blown even if you can't see it. Either blindly change them or test them for continuity with a digital multimeter. Also, disconnect the remote turnon and jump power directly over from the power wire to the remote terminal on the amp, if the amp powers on then you have to go double check your remote wire. Hope this helps.

Posted on Aug 06, 2007

  • 113 Answers

SOURCE: Amp will not turn off and the Remote wire is correct.

check pwm chip ,may need replacing

Posted on Aug 22, 2007

  • 631 Answers

SOURCE: Protection Light

This is almost always caused by shorted output transistors. To eliminate other possible problems do the following.

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down (goes into protection), the amp likely has blown output transistors.

Generally, an amp with blown output transistors can be repaired.

Posted on Dec 28, 2007

nate6556
  • 103 Answers

SOURCE: MTX Terminator Amp...Red light comes on when it should be green.

its just a power light to let you know its on

Posted on Jul 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my amp both my red and green light are on at the same time and won't play any bass. How can I fix this?


First make sure your amp is grounded good to the frame of the car..

If it is.. Try unplugging everything except your power wire, ground and remote wire. Turn amp on and see if both lights are still on.. If they are then it's most likely you have a blown capacitor inside the amp(little battery looking things on motherboard).. This normally happens from over heating.. Or wrong size wires.. But both lights coming on is normally from your positive and negative touching somewhere

Jan 24, 2015 | Car Audio & Video

3 Answers

My 1998 dodge v8magnum dies out


Check your batter cables. Sounds like they got brittle and broke when you disconnected them.

May 06, 2014 | 1998 Dodge Ram 1500 4WD

1 Answer

My amp doesn't turn on but all wires are plugged in. I tested it right before I bought it, it's grounded to a bolt in the chasis. What could be wrong?


If you have a voltmeter or a 12V trouble light, check to see there is 12V at the remote terminal when everything is on. The remote wire coming out of the head unit cant supply a lot of current (usually around 1/2 amp). even a quick short to ground on the remote wire can render it useless.

Jan 30, 2013 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Hello, I have a 85' buick regal and I'm having


This is a tough one with out being able to see the wiring. i will enclose a wiring diagram for the complete lighting system.
You will need to locate the correct wirng and make sure its going to the correct light. Most times a bad ground wire will make the light do funny things like your car is doing. With the diagram i enclose locate the ground wire to the rear lights and make sure ground is good, even if you must cut old ground out and run a new ground to a good metal ground.
3_18_2012_3_37_44_pm.gif

Mar 18, 2012 | 1985 Buick Regal

1 Answer

Amp is getting power but its not playing


Checking wires doesn"t help unless you are checking them with a multi-meter. Amp needs 4 things to turn on. 1) 12volt power from battery, 2) 12 volt power from radio (remote turn on), 3) ground (solid ground to the chassis or the car free from paint or rust), 4) fuses on side of amp need to be good. If any of these 4 things don't measure up then fix them so they do. If all 4 are verified with the meter and still no lights then you might have a dead amp. If the lights are on but no sound, then there are many other things that needs to be checked.

Feb 27, 2010 | Car Audio & Video

1 Answer

Our Chevy 1989 S-10 seems to run good until we put it in gear, and try to drive. For awhile it was doing fine as long as we put a little pressure on the gearshift so it was at the top most part of drive....


I think the firstr thing you should do is check for loose ground wires, and wires that are being pinched. Check your battery cables for tightness on both ends. It seems like something is shorting out when your engine tips when you put it in gear. Check all the wires that are anywhere near the transmission. Good luck.

May 19, 2009 | 1987 Chevrolet S-10 Pickup

2 Answers

Amp keeps blowin the two 30amp fuses on the amp.


Make sure that the speaker wires are wired correct at both the amp and the speakers......otherwise it sounds like the typical death of a power acoustik amp (great amps, but prone to a premature death)

Mar 29, 2009 | Power Acoustik GOTHIC OV2-1200 Car Audio...

1 Answer

My fiance purchased a pair of P1 RF speakers and their matching amplifier. when he hooked them up in our car everything worked well. we unhooked everything and then ran all the wires and re-hooked...


well let me see i can bet something happened so what happened??? i bet the amp is not working right? hahaha here's my sign right!!! all right enough fun. is the light on the amp coming on? you might also need to turn the key all the way to the run position, if not wired exactly right then amp will only power up when vehicle is running or key is in the run position i need to know this before we really go any further. let me know so i can get you up and running quickly.

Mar 07, 2009 | Rockford Fosgate Car Audio & Video

2 Answers

Amp


Sisnce you didn't mention the protection LED, I'll assume it's not on.

You need to measure the voltage across the B+ and ground terminals of the amplifier to confirm that the voltage at the terminals is least 11 volts. Also check the voltage on the remote turn-on terminal. Place the black meter lead on the ground terminal of the amp and set the meter to DC volts.

Nov 07, 2007 | Power Acoustik LT-980/2 Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

126 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

The Knight
The Knight

Level 3 Expert

73647 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...