Question about Kenmore 35912 / 35913 Progressive Upright Vacuum

1 Answer

Won't **** I have a kenmore progressive upright bag vacume. when I turn it on it sounds find, then all the sudden it sounds like it has sucked something into it blocking the suction. Can you help?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 281 Answers

There is what they call an intake.disconnect the hose and see if it make the same sound.if not then its clogged up in the hose.if it still makes the same sound with the hose off then here is what you have to do.on the top of the base there are 2 slide buttons ,slide them outward to unlock the cover.remove the cover and you will see where the suction intake begins.it will be on your left side as your facing the vcuum.the tube sets into a slot just raise it up and look inside and see if theres anything in there.take a coat hanger with the end bent so it is round and work it down into the tube where you disconnected the hose.if theres anything in there you should be able to push it out with the coat hanger.you can take the bag cover off and remove the bag then you will see the outlet tube that dumps the dirt into the bag.see if there is anything there..see if you can blow into the hose if not thats where the clog is.if so take the hose off completely and put it in the sink and run water through it,better yet take it outside and blow it out with a garden hose

Posted on Apr 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ther is no suction and rolar prush is not runing in my kenmore vacume progressive


Remove the rotating brash and check it, something is blocking the suction, probably you need a new belt

Mar 24, 2013 | Kenmore 31912 Progressive Direct Drive...

1 Answer

Vacume does not suck from the brush but it sucks from the hose


take your brush out and take a coat hanger bend it straight then push it through the dust channel until it comes out where hose is. you probably just have an obstruction between those two places

Feb 13, 2013 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Unbeknownst to me, someone took the bag out of my Kenmore Progressive vacuum and failed to replace it. I have been vacuuming without a bag for months, and today the vacuum stopped sucking. When I opened...


Sounds like you need to buy a new motor. All that grit and dust will ruin a motor and I'm surprised it lasted as long as it did.
This is where a vacuum that won't run without a bag would have been nice. (Aerus for one)

Nov 16, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmoore Intellivac w direct drive suddenly started making internal sound like something was stuck. Hose is clear, and sound is made when hose is detached from main unit. Vacuum sounds find at lower...


Shut off the vac and open container and remove the bag. Try dropping a coin into the hose, then raise up to see if it falls thru to the bag area. If it does check the throat of the vac where the dirt is sucked upward to dump into the bag itself.

Sep 05, 2009 | Kenmore 35912 / 35913 Progressive Upright...

2 Answers

Vacum not sucking the dirt and the light is not turning on


loss of vaccum brush head not spinning check belt turn over remove bottem plate check belt assmble. remove any string or hair build up sear is the best bet for the belt

Mar 31, 2009 | Kenmore 34923 / 34925 Progressive Bagged...

1 Answer

Kenmore direct drive model 116 31912100 lost vacuum


Check the inlet where the dirt is first sucked in for a clog, also your hose may be clogged.

Sep 01, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore 31913 Upright


same problem.... roller won't turn, nothing stuck in it.... no solutions?

Jun 20, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vacuum is not sucking at all.....


I took out the air flow filter at the back of the vacuum and turned it on, somehow the clog cleared. Then I put the filter back in and it works perfectly! Barb

Mar 01, 2007 | Kenmore 35912 / 35913 Progressive Upright...

Not finding what you are looking for?
Kenmore 35912 / 35913 Progressive Upright Vacuum Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

61249 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...