Question about Televison & Video

Open Question

Hitachi Ultravision 50UX19K bad inputs?

My 50UX19K (1994) seems to have a bad video 1 input. If I use the S-video with a dvd player the picture is fine with no problems. If I use the Video 2 input it requires a warmup time till the picture becomes viewable with a slight waveiness. the vidio 1 input at this time is B/W instead of color and not clear. The symptoms started with the picture rolling which could only be cleared by banging on the side of the set, and have gotten progressively worse with time. I hate to replace the set since the picture is still bright and clear when using the s-video input. Any ideas where to start looking would be appreciated. I do have the repair manual so I could component troubleshoot, just need to know where to start.

Posted by on

1 Suggested Answer

  • 192 Answers

SOURCE: Component Video inputs do not work

I started back in the day of tubes. A family would have one set and it would be a 19" black and white. There are different resolutions now. The components probably do work, but, they don't pass the 480i signal. The satelite converter's analog signal needs to be set to 480p and the DVD needs to be set to progressive if it does have that setting. If the DVD is not a progressive scan DVD, then, the only inputs that it will show on is the analog signal. Some of the dish converters have a switch on the face for changing the resolution. If yours doesn't then put it in an analog source and go to the menu and change it there. Then move it to the component input. Hope this helps.

Posted on Jun 24, 2007

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Blu screen


Your on the wrong input! Press the input button and turn on all your tv viewing receivers such as DVD player. FTC or dish network box. Or cable box. And press input till you find picture! The blue screen is an input with no video or audio source being sent To it!

Apr 28, 2012 | Hitachi 50V710 50" Rear Projection...

1 Answer

Hear a click when turning on, but the red light, no picture


Please make sure that the video source is on and that the source input on the TV is set properly. I am thinkig that the TV is working properly but has no input signal to display.

Feb 26, 2009 | Hitachi 60UX57B 60" Rear Projection...

2 Answers

57H82-no picture from DVD input


How does line out from the DVD player do? I would suspect a bad preamp/buffer on the TV...accordianman

Mar 17, 2008 | Toshiba 57H82 57" Rear Projection...

3 Answers

Color Issue


i,m pretty shure the problem is the lamp, just replace it and it should correct the problem

Sep 02, 2006 | Hitachi UltraVision CineForm 55VG825 55"...

1 Answer

Video input from dvd player shows as black screen w/ squigly color lines


have you tried other devices for input...vcr, or other dvd players to see if it is a problem with the player or with the tv? Check the output setting for the dvd player (1080i etc) and ensure you are connecting to the proper inputs for either analog or digital signals (RCA inputs or RGB).

Aug 15, 2006 | Hitachi 57S715 57" Rear Projection HDTV

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

69654 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6364 Answers

yadayada
yadayada

Level 3 Expert

63291 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...