Question about Audio Players & Recorders

1 Answer

Pioneer M770 has cracking sound every a few seconds

My Pioneer M770 amplifier has very lound cracking sound every a few seconds. Initially it was not lound and the cracking occurred every 10 --20 seconds, but it is getting louder and more frequent. What could be wrong? Is there any simple fix?

Posted by on

  • achen9 Jan 18, 2009

    Yes, it was during music play. I have not used it for a while, then I turned it on. It doesn't have the cracking sound anymore, but a heavy static noise. It synchronizes with the level of volume, the louder the music, the louder the 'static'. When it is silent between songs, the static stops as well. It does not matter if I'm playing a CD, tape, or using the tuner.

  • Dazzarus
    Dazzarus May 11, 2010

    Is this during music play?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 85 Answers

Neads all boards checking for dry joint on solder connections and if found resolder,other possible causes are the control pots need cleaning

Posted on Jan 08, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Buzzing sound car stereo


A lound buzzing sound is an indication that the Driver (transistor) for the amplifier final is bad. This is not so much a buzzing and it is extreme in loundness.

May 05, 2013 | Chrysler concorde amplifier. radio. ....

1 Answer

Faint sound from the speaker have a poineer cx-7705 and m770


Check to be sure that your tape monitor button or lever is switched off.

Jul 07, 2012 | Pioneer Audio Players & Recorders

2 Answers

No Sound


It sounds like the amplifier with-in the deck is blown or the fuse inside the unit is blown. I would take it to a shop and have them test it for you . Pioneer will no longer repair that model but there are various repair companies around the world . If you would like a list for your area please email me back with the city and state you live in and I will give you 3 options . mmaudio545@yahoo.com

Jul 25, 2009 | Pioneer AVH-P6400CD Car DVD Player

1 Answer

Shuts down after 30 seconds


Maybe the audio amplifier IC are burned

Jun 29, 2009 | Pioneer VSX-D307 Receiver

1 Answer

What amplifier should I use for 2 650W Subs?


HI DUDE .. I JUST GIVE suggestions Boss Car Audio D5504 "Diablo Series" 4-Channel Car Amplifier 2200 Watts ITS REALY GOOD FOR SOUND SYSTEM DUDEaaf1faf.jpg

Jun 10, 2009 | Pioneer GM-6300F Car Audio Amplifier

1 Answer

Loss of picture on Pioneer Plasma Tv


i have a pioneer 43 inch bought in 06. tv wont turn on light flashes red the light means standby. what does this mean

Jun 07, 2009 | Televison & Video

1 Answer

Protection mode


It's normal for some amps to go into protect for a few seconds when initially powered up. If it remains in protect mode, it may have shorted output transistors. To eliminate other possible causes, read through the following troubleshooting page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Dec 11, 2008 | Phoenix Gold Titanium 800.1 Car Audio...

1 Answer

Bass in Car Gone, i don't know why!!!


Does the amplifier power up? If so, then check the voltage at the outputs...sounds like the outputs fried. Also, check the RCA cable to make sure it is getting a signal to the amplifier.

Jul 08, 2008 | Pioneer TS-W301R Car Subwoofer

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

451 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

101642 Answers

 Grubhead
Grubhead

Level 3 Expert

4767 Answers

The Knight
The Knight

Level 3 Expert

71736 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...