Question about Amplifiers & Preamps

1 Answer

Pioneer M770 has cracking sound every a few seconds

My Pioneer M770 amplifier has very lound cracking sound every a few seconds. Initially it was not lound and the cracking occurred every 10 --20 seconds, but it is getting louder and more frequent. What could be wrong? Is there any simple fix?

Posted by on

  • achen9 Jan 18, 2009

    Yes, it was during music play. I have not used it for a while, then I turned it on. It doesn't have the cracking sound anymore, but a heavy static noise. It synchronizes with the level of volume, the louder the music, the louder the 'static'. When it is silent between songs, the static stops as well. It does not matter if I'm playing a CD, tape, or using the tuner.

  • Dazzarus
    Dazzarus May 11, 2010

    Is this during music play?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 85 Answers

Neads all boards checking for dry joint on solder connections and if found resolder,other possible causes are the control pots need cleaning

Posted on Jan 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix my problem I m having with my pioneer sa-1510 amplifier


You simply have a bad solder joint somewhere. A visual examination of the solder joints should show you the problem.

Mar 03, 2016 | Pioneer Amplifiers & Preamps

1 Answer

Problem with pioneer m f10


Sounds like a capacitor is failing.

May 04, 2014 | Pioneer Amplifiers & Preamps

1 Answer

Faint sound from the speaker have a poineer cx-7705 and m770


Check to be sure that your tape monitor button or lever is switched off.

Jul 07, 2012 | Pioneer Amplifiers & Preamps

1 Answer

My VSX 517 amp's sound is outputted before the vision on the TV. The sound seems to be anything up to half a second ahead, it is not always out it depends on how long someone is speaking for, plus which...


Lip Sync issues are the nature of the beast. The TV has to process the digital video bitstream a lot more than the receiver has to process the audio so the result can be a gradual lagging of the video behind the sound...

http://en.wikipedia.org/wiki/Lip_sync

Some receivers have a sound delay control which you can use to try to sync them up. You didn't name yours so one does not know. I don't think this unit has that function. Look in the manual.

Register and download the manual for free at retrevo.com


http://www.retrevo.com/support/Pioneer-VSX-517-S-Receivers-manual/id/2526bh740/t/2/

Apr 05, 2011 | Pioneer Amplifiers & Preamps

1 Answer

My pioneer A-109 amplifier has stopped emitting any sound. power is still being recieved, but no sound from any inputs or sound devices, also no feed back noise. speakers and cables are as should be. any...


If there's not even a hiss from the speakers it may be that you've inadvertently hit the small button underneath the power button which turns the speakers off in favour of the headphones.

Oct 12, 2010 | Pioneer A109 2-Channel Amplifier

1 Answer

Hi, i have a marantz pm720 amp, when i switch it on, straight away it starts to make loud cracks through the speakers like spikes,then it will cut sound all together for a few seconds then back on, when i...


Hi Paul;
There are one or more transistors failed in the output circuit
I would have tech look at the amp and see what the power supply is doing without spkrs connected

Aug 20, 2010 | Marantz PM7200 2-Channel Amplifier

1 Answer

Hi, I have a Pioneer SA-520 Amplifier (vintage 1982 or thereabouts). It works brilliantly except for the (getting worse) thump on my woofers when I switch it on. I know this is one or more caps that need...


Actually, it sounds more like its speaker protection relay is not protecting the speaker(s) while the electronics stabilize on power up. The relay should pick a few seconds after Power.

Jan 18, 2010 | Amplifiers & Preamps

1 Answer

800 watt pioneer mono block blue light comes on then goes off


sounds as if u have a short going on somewheres maybe a loose gound wiredo u have the gain set to hi.check all connetions..check sub connections a sub short will put your amp in protect mode

Sep 01, 2009 | Pioneer 800W Class-D Mono Amplifier With...

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

451 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68301 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...