Question about Car Audio & Video

1 Answer

My orion 2150sx is smoking when powered

THE AMP HAS A BIG PROBLEM.WHEN POWERED CORRECTLY IT STARTS TO SMOKE AND 1 COMPACITOR IS LOOSE.IS THIS A COMMON PROBLEM AND FIX FOR THE OLD SCHOOL ORION 2150SX?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 444 Answers

No some one did not have the speakers hooked up properly ,End probably went under the OHM,Rateing for the amp, Or use the wrong OHM SUb on it, OR if they used a Dual voice coil sub,Didn,t have it wired up Properly.

Posted on Oct 31, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

The Marv
  • 72 Answers

SOURCE: Smoking Amp/Fuse Blowing

Sounds like you may have a shorted switching Transistor in the switch mode power supply causing a short to ground. If you are technical enough. Remove power remove cover and do a continuity test on the transistors on the heatsink. non of them should read zero resistance between the three legs. in all connection configuration you use to hook up your meter. If one or Two or even all of them do you must replace with proper part.

Posted on Aug 03, 2006

  • 631 Answers

SOURCE: orion 2100 hcca

I have a few photos of the 2100hcca. Where are the burned resistors on the board?

Posted on Nov 05, 2007

SOURCE: jl 1000/1 amp not working w7 like it should

also you can call the jl service they will help you they will charge you like $115 to fix it

Posted on Oct 10, 2008

  • 631 Answers

SOURCE: red protector light

Try this first:

Amp in Protect - Troubleshooting

If nothing there helps, you need to return it to the seller if it's under warranty.

Let me know if you have any other questions.

Posted on Nov 16, 2008

  • 17 Answers

SOURCE: orion hcca 2100 old school

Try this page:

http://www.orioncaraudio.com/Support/Manuals/Amplifiers/HCCA%20Series/Orion%202100HCCA%20Installation%20Manual.pdf

Posted on Dec 09, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1984 honda big red smoking out the exhaust littel oil coming out tho also it has the wrong carb on it the carb come off a honda atc 200x


If it is black smoke, it could be running rich and the correct carb will fix that. If it is blue smoke, then it is burning oil.

Apr 10, 2014 | Honda 84 Atc200 Big Red 200 Engine Stator...

1 Answer

White smoke came from the exhaust pipe and the car killed in motion. I check all fluid levels were fine, once i started the care again and proceeded the accleration was a bit rough. After a few minute


white smoke mostly is caused by over fueling so what i suggest you do is first of all check if there is no leak on the injectors and if there is none which means your valve sterm seals are damaged.When the head gasket is blown out you may have problems like :-loosing power when driving,over heating,idling problems and oil mixing with water, its not your head gasket.

Oct 21, 2012 | 2009 Ford Focus

1 Answer

Black smoke and 'juddering' when stationary.


YOU HAVE RICH MIXTURE. CHECK FOR YOUR TEMPERATURE SENSOR WHICH I BELIEVE IS NOT SENDING THE CORRECT MESSAGE TOY PCM AND STILL WORKING ON COLD START.

Aug 30, 2012 | Audi A6 Cars & Trucks

1 Answer

The fuses blew but then smoke came out of my orion 2400.If I replace the fuses should it still work??


If you are a lucky person..maybe.. but i highly doubt it. ..Sorry.. Smoke is never a good sign when it comes from within the amplifier. Be aware i am advising according to the info you provide. Have it checked and repaired if required, it is a good amp. (find an authorized technician) dreamsystems

Feb 08, 2011 | Orion HCCA-D2400 Car Audio Amplifier

1 Answer

I have an Orion 2150sx and an Orion xtr2150 will either of these run on a one ohm load ? If not what is the best way to run either of these amps to get the most power out of them. I have two Orion xtr...


EITHER OF THEM WILL WORK AT ONE OHM WITH NO PROBLEM, MAKE SURE YOU MAINTAIN VOLTAGE INTEGRITY, USING EITHER 2 OR 0 GUAGE POWER AND GROUND AND A POWER RATED ALTERNATOR AND BATTERY.

Nov 03, 2010 | Orion 2500D Car Audio Amplifier

2 Answers

How to wire 2 dvc subs to a orion 2150sx ? dont know the wire colors or how to hook um to my amp.


what impedence are the voicecoils?
Dual 4 - Dual 2 - Dual 1 ??

Orion SX / GS / HCCA amp Wiring guide:

Orange = Right Positive
Black/ Orange = Right Negative
Yellow = Left Positive
Black/ Yellow = Left Negative
Blue = 1+1

Bridging of SX or HCCA Amps:
1. Use the Orange wire for Positive.
2 Use the Black/ Yellow wire for Negative
3. Push "in" the Mono Button
That amplifier is only 4ohm mono stable - so assuming the subs are dual 4 ohm voicecoils...

First wire both in Parallel Independently So each subwoofer is now a 2 ohm load. (combine + and + - and- on both subwoofers)

Now Take a positive on one voicecoil of sub #1 and attach to amplifier+(orange)

Take a - on that same subwoofer and attach it to a + on the OTHER subwoofer.

Finally, take a - from the second woofer to the amplifier -(black/yellow)

Now you have a 4 ohm load on your bridged channels.


Thanks for using FixYa - a FixYa rating is appreciated!!

Feb 23, 2009 | JBL 1200GTi Car Speaker

3 Answers

Power Acoustic A3000DB mono amp problems


Broken legs on the rectifiers or an intermittently shorted common mode inductor would be the likely suspects. The common-mode inductor is just to the right of the capacitors in the photo. Install a single 15 amp fuse in ONE of the 4 fuse holders (other 3 fuse holders empty) and power up the amp. Twist the inductor to see if the amp draws excessive current (which would blow the fuse) or to see if it sparks.

Let me know if you have any other questions.

Oct 31, 2008 | Power Acoustik A3000DB Car Audio Amplifier

1 Answer

Smoke problem


hey
there are couple of smoke type.blue smoke is oil, black smoke is fuel, and white smoke is water, if it clears after starting and running a few minutes it's probably your valve guide seals leaking oil down on top of your pistons, causing it to smoke until burned off and foul your plugs.

Jun 28, 2008 | Peugeot Liberte Cars & Trucks

1 Answer

MTX 1501 D


If the terminals were smoking, it's probably due to loose screws in the terminal block or wire that's too small.

Did the amp work properly after the terminal blocks smoked?

Apr 29, 2008 | MTX Thunder 1501D Car Audio Amplifier

2 Answers

Smoking Amp/Fuse Blowing


Sounds like you may have a shorted switching Transistor in the switch mode power supply causing a short to ground. If you are technical enough. Remove power remove cover and do a continuity test on the transistors on the heatsink. non of them should read zero resistance between the three legs. in all connection configuration you use to hook up your meter. If one or Two or even all of them do you must replace with proper part.

Aug 02, 2006 | Legacy LA838 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...