Question about Klipsch Edifier M1350 2 Speakers

Open Question

Edifier m1350 subwoofer intermittent and now very weak volume

The subwoofer part started acting up, it started goin in and out then now it has very low volume and barely plays. The satellites work perfectly

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound playing from either speaker on the Edifier Multimedia Speaker M3300 setup.


Go to http://www.edifier.ca/french/speakers/m3300/m3300-EN-FR-manual.pdf and check the troubleshooting guide. I notice it says to check to make sure the mute button on the remote is off. Try it without the remote plugged in, also. Try hooking up another device with a headphone jack like an mp3 player. The only other thingI can think of would be a blown fuse, which sometimes lets a small signal through with some amps, but I don't see any fuse holder.

Dec 09, 2014 | Edifier Audio Players & Recorders

1 Answer

My Edifier M1360 speakers will only work when plugged into the headphone jack and I can't get all three speakers working at the same time. What can I do?


the sub woofer green 1/8 inch plug goes into the audio card either the front or the back of the pc. the jack it plug into is normally the green one. the two speakers normally join together on one card and plug into the subwoofer. also look for a on/off know to the speakers for power. normally on one of the little speakers. make sure it is on.

Nov 09, 2014 | Edifier M1360 2.1 Multimedia Speaker...

1 Answer

Edifier m1350


As long as the woofer is functional, get a pair of 8 Ohm matching speakers from Radio Shack.

Jan 09, 2014 | Edifier Audio Players & Recorders

1 Answer

No side speakers


Make sure you test your wires and that they are running paralel, un wire and rewire, and make sure no speaker wire is exposed or touching.

Dec 12, 2013 | Edifier M1360

1 Answer

Edifier C2 amplifier repair


My Edifier HCS2330 Amplifier stopped working and now the system is useless. Any recommendations on where to get it fixed from? Or any place i can buy the amp separately? or maybe even any other brand amp i can buy for cheap price?

Jul 14, 2013 | Car Audio & Video

1 Answer

2003 Tacoma Intermittent Starting problems


If your able to drive to Autozone,they will check your alternator and battery for free.

Aug 28, 2012 | 2003 Toyota Tacoma

1 Answer

Sub woofer got weak


If there is an adjustment, turn up the subwoofer volume. After you started shaking the house somebody may have adjusted it for you.
Check your computer control panels volume too, cause they may have a subwoofer volume there too.
If there is an equalizer (software) then make sure the low frequencies are set properly (middle or above). Check for this in your computer audio control panels.

If there is no adjustment anywhere, take it back, 'cause it is busted. If it is too late to take it back, sent it to logitech for repair under warranty. If it is too late for that, go buy a new one.
--Dave

Feb 07, 2010 | Logitech X-540 Computer Speakers

Not finding what you are looking for?
Klipsch Edifier M1350 2 Speakers Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Klipsch Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

73619 Answers

rhodesworks

Level 3 Expert

3082 Answers

Pieter Vleeshouwers
Pieter Vleeshouwers

Level 3 Expert

1773 Answers

Are you a Klipsch Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...