Question about Alpine MRP-M350 Car Audio Amplifier

1 Answer

No sound from subs.

I just installed subs in my 2006 Silverado with bose. I used a PAC-Audio C2A-GM24 and an Alpine MRP-M1000 amp. Overnight my battery drained. The light on the amp stays on all the time even without power to the remote turn-on.

Posted by on

  • dblack901 Jan 04, 2009

    There is a constant 12v on the remote wire with the key off and door open (radio off). This is the reason for the drained battery. According to PAC this is the correct module for my truck but according to the instruction manual of the module it isn't. There is no voltage present with a dmm on the rca's which leads me to believe it is the wrong module. I am going to contact PAC on monday. Thanks for the reply.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Http://www.pac-audio.com/instructions/C2A-GM24.pdf

Sounds like you have the Remote turn on hooked to constant 12V instead of a switched power.
The Blue/White wire off the module should go directly to the amplifier remote terminal.
If this has a constant 12V when the key is off, the module is defective and needs to be repaired/returned.

Posted on Jan 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have the MRP-M1000 amp. I want to hook up 2 alpine subs to this amp. Which alpine subs would be the best for this amp? Please be specific with ohms and watts.


Your best bet will be to wire 2 subs in parallel to the amp. Each sub should be rated for at least 300 watts rms at 4 ohms. This will give you a total impedance of 2 ohms, and your amp will put out 600 watts rms at that impedance. That way, each sub will receive 300 wats rms. I would not recommend wiring subs in parallel, as you will need two 1 ohm subs at 300 watts rms, which are harder to find and will be more expensive. A parallel circuit is the most efficient way to do it.

Feb 23, 2011 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

I have the Alpine MRP-M1000 amp. I want to use 2 subs with this amp. Which Alpine subs would work best with this amp?


this amp is rated at 600w at 4 ohms and 1000w at 2 ohm so as long as you calculate your speakers to match the ohm specs of the amp you can hook up

parallel = pos to pos and neg to neg of the 2 speakres
2 - 8 ohm speakers in parallel = 4 omhs
2 - 4 ohm speakers in parallel = 2 ohms

series = pos to neg of the 2 speakers
2 - 1 ohm speakers in series = 2 ohms
2 - 2 ohm speakers in series = 4 ohms

Feb 22, 2011 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

Will this amp push 2 2000 watt subs?


hope this helps.

caution

About Power supply wires (MRP-M1000 only)

• 21mm2 is the minimum power and ground cable size

that should be used to connect this amplifier. The

length of these cables should not exceed 1m to assure

safe operation.

• If the length of the power and ground cables exceed

1m, or if you connect more than one amplifier, a distribution

block should be used with 33mm2 or 53mm2

power and ground cables depending on the length

necessary. Ensure that you install a correctly-rated

in-line fuse on the power cable near the battery positive

post.


RMS Continuous Power (at 14.4 V, 20 - 200Hz)

• Per channel into 4 ohms (?1% THD+N)

MRP-M1000 ......................................... 600 W x 1

MRP-M500 ........................................... 300 W x 1

• Per channel into 2 ohms (?1% THD+N)

MRP-M1000 ....................................... 1000 W x 1

MRP-M500 ........................................... 500 W x 1

Total MAX Power

MRP-M1000 ............................................. 1900 W

MRP-M500 ............................................... 1100 W

S/N Ratio

• IHF A Weighted, Reference: rated power into

4 ohms .................................................... 100 dBA

Input Impedance

• RCA IN .................................................. 20k ohms

• SP IN .................................................... 40k ohms

Frequency Response (200Hz/ -3dB) ....... 20 - 200 Hz

Crossover Frequency .......... 50 - 200 Hz (-24dB/oct.)

Input Sensitivity (RCA IN) ............................ 0.2 - 4 V

Dimensions

• Width (Heat Sink/Footprint)

MRP-M1000

......... 320 mm (12 - 19/32")/380 mm (14 - 61/64")

MRP-M500

............... 210 mm (8 - 17/64")/270 mm (10 - 5/8")

• Height ..................................... 60 mm (2 - 23/64")

• Depth .................................... 242 mm (9 - 17/32")

Weight

MRP-M1000 ................................................ 4.2 kg
MRP-M500 .................................................. 2.7 k

Feb 04, 2011 | Alpine MRD-M1000 Car Audio Amplifier

1 Answer

Hi ive got a alpine mrp-m1000 it lights up no sound was woking fine in the car didnt use car for 3 months then i wouldnt work all wires are fine and so is the sub please help


If your not getting any sound make sure the sub input is in the right spot on you radio. if not check the speaker wires on your harness

Feb 14, 2010 | Alpine MRP-M1000 Car Audio Amplifier

2 Answers

How do i hook up the mrp-m1000 to 2 type r subs since it is a one channel amp? the subs r 4 ohms so it should work right?


hook the positive to positive and negative to negative on both subs then run wire to the amp the amp will see a 2ohm load

Jan 07, 2010 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

I have one 12inch 1000 watt mtx sub what size amp should i buy


Hello taona80,

If the 1,000 watts is RMS, I'd recommend an amp in the 750-1,000 watt RMS range, perhaps like the Alpine MRP-M1000 or Rockford-Fosgate T1000bd. If the 1,000 watts is peak power, the subs continuous (RMS) power handling is much lower, probably 300-400 watts. In that case, I'd recommend the Alpine MRP-M500 or Rockford-Fosgate T500-1bd.

Nov 09, 2009 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Amplifier wont move subs


I dont know if this will help you but start at the deck and make sure that the outputs(RCA) arent crossed over to highpass and do the same at the amp make sure that its set for lowpass- set half gain -bass boost half gain- subsonic minimum - If that doesnt help try using an i pod with an adaptor that you can play it right into the amp this is to see if you are getting signal from the deck to the amp if it doesnt work with an i pod or mp3 plugged directly into it then you may have got you a blown amp going on- good luck with that

May 29, 2009 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

No light on Alpine MRP-M1000


Ok. Have you check the Ground and the Power connection.

Jan 25, 2009 | Alpine MRP-M1000 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRP-M350 Car Audio Amplifier Logo

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Alpine Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...