Question about RCA D52W20 52" Rear Projection HDTV-Ready Television

1 Answer

Cable connection is broken

The connection is loose

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • RCA Master
  • 14,553 Answers

It can be replaced but average is over 100 dollars---if have a cable etc box with video outputs connect them to one of the rear audio video inputs and bypass the cable fitting----even if have to pay for a box that is cheaper than fixing the fitting (better picture and sound as well).

Posted on Oct 30, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to make a backfires in discover 125m bicycle?


Hi, Anonymous and the usual suspects are:
1. A severely drained battery.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.

Nov 04, 2015 | Motorcycles

1 Answer

Gas gauge flutters backfires when starting


Hi Anonymous, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
Good luck and have a nice day.

Oct 14, 2015 | GAS Motorcycles

1 Answer

Motorcycle won't start. Stalled out, backfired trying to restart, now nothing?


Hi Guitarfield, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
Good luck and have a nice day.

Apr 17, 2015 | Motorcycles

1 Answer

My 86 shadow vt500 was running perfect n all of a sudden it started backfiring n evn stalled out on me. What's wrong?


Hi David, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
1986 Honda Motorcycle Service Repair Workshop Manuals

Jun 23, 2014 | 1986 Honda VT 500 C Shadow

1 Answer

Back firing


Hi Anonymous, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2001 Aprilia Pegaso 650

Apr 22, 2014 | 2001 Aprilia Pegaso 650 i.e.

1 Answer

Low speed esitation


Hi Anonymous, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2003 Aprilia Rst 1000 Futura

Mar 10, 2014 | 2003 Aprilia RST 1000 Futura

1 Answer

Does aprilia sr 50 2005 have a cdi connected to throttle cable in cable u stop it from starting if its broken ?


Hi Anonymous throttle only goes to carburetor and oil injector and the usual suspects are:
1. Fuel tank empty.
2. Fuel supply valve/petcock turned off.
3. Fouled spark plugs.
4. Engine flooded as a result of overuse of the enricher.
5. Vacuum hose to the fuel supply valve/petcock disconnected, broken, cracked, or pinched.
6. Fuel valve/petcock or filter clogged.
7. Discharged battery, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
8. Loose or corroded wire connection at the coil, battery or plug between ignition sensor and module.
9. Spark plug cables in bad condition and shorting, cable connections loose, or connected to the wrong cylinders.
10. Ignition timing incorrect due to a faulty ignition coil, ignition module or sensors (MAP, CMP, CKP, O2 and/or BAS).
11. Security alarm needs a reset.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2005 Aprilia Sr 50

Nov 04, 2013 | Aprilia Motorcycles

1 Answer

Backfire carb


Hi Binuya, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
Untitled Document

Jul 03, 2013 | 2009 Adly Thunder 125

1 Answer

]98 zx1100 wont idle and backfires when starting


Hi Terrance, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
1998 Kawasaki Motorcycle Service Repair Workshop Manuals

Nov 17, 2012 | 1996 kawasaki ZZR 1100

1 Answer

My 99 r1 backfires and reves hi and get hot what do i need to do


Hi Mokell, and the usual suspects are:
1. Loose, corroded, or broken battery cable ends inside the cable harness especially the "NEGATIVE" cable at both ends.
2. A severely drained battery.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
1999 Yamaha Motorcycle Service Repair Manuals

May 08, 2012 | 1999 Yamaha YZF-R1

Not finding what you are looking for?
RCA D52W20 52" Rear Projection HDTV-Ready Television Logo

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top RCA Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74106 Answers

matt martin
matt martin

Level 3 Expert

1210 Answers

Computer Repairing
Computer Repairing

Level 3 Expert

14641 Answers

Are you a RCA Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...