Question about Rockford Fosgate Punch P10002 2-Channel Amp Car Audio Amplifier

1 Answer

P10002 blown? Hello i have a p10002 amp and 2 p312d4s i hooked my speakers up wrong and the amp worked alright for a little while but there wasnt much sound coming out so i turned it up and the fuse blew now everytime i put in a new fuse it blows before them amp even turns on ill turn on the amp and it will humm for about 3 seconds then pop the fuse any help would be greatly appreciated thanks.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Expert
  • 113 Answers
Re: p10002 blown? - Rockford Fosgate Punch P10002 2-Channel Amp Car Audio Amplifier Car Amplifiers

Needs repair bad fets or outputs

Posted on Aug 09, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Red light on on amp

take speaker wires off amp if the lit is green then speaker are hooked up wrong or blown.

Mar 29, 2014 | Pioneer GM-5200T Car Audio Amplifier

1 Answer

I have a rockford fosgate p10002 amp when i give it power it blows a fuse like the power and ground are touching

make sure youre positive and negative wires aint touching maybe you have a tear i a gauge wire and its shortning out to save youre amp check all youre work if you installed it yourself...

Feb 22, 2010 | Rockford Fosgate P10002 Car Audio...

1 Answer

I was given a rockford fosgate 500x 4 channel amp and the rear 2 channels work fine but the 2 front dont when i hook up the speaker the speaker bottoms out and stays like that until i unhook the speaker...


Sounds like those two of the channels are blown. There is really nothing that can be done about that other than having an expert repair it. You might as well buy a new one tho, or just use it as it is.

You could look at all the fuses in it, make sure there not blown (they will be black and the little metal piece inside the plastic will be broke or cracked)

Post back if you have any further question's and comments. Thank you for choosing Fixya!

Nov 10, 2009 | Rockford Fosgate Punch 500X Car Audio...

1 Answer

I have a 1000w amp but it got burned why??


I'm sorry but your problem was a little confusing. Your speakers worked fine, you hooked up a 1000W amp and now you cant hear the sound ?

Then you say "they say because the wires were connected wrong in the amp it burned" does that mean your amp burnt out ?

Please post back and sort these facts out for further assistance.
As of right now im not sure if the problem is with the speakers or the amp itself.

Oct 01, 2009 | Alpine MRD-M1005 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp earlier today it was workin with no problems we parked then came back in the car 3 hours later and it wasnt workin wont come on or anything just red light which is protecting...

Check your speaker wires, make sure everythings connected right with no short circuits, and check all of the fuses in the amp, and make sure none of them are blown. If all this checks out just check the battery wire, grnd, and remote wires. It has to be a wiring issue unless you busted your amp, but if was working when you tuned it off it should be alright... hop this helps...

Sep 10, 2009 | Nitro BMW-484 Car Amp

1 Answer

1000 w sony xplode works at low volume then red lights at volume5

Most likely one of your subs are blown, or the Ohm's are too low for the ampliphier. Try hooking up one speaker at a time to the amp and see if it does the same thing. If it shuts off on one of the two speakers, that speaker is most likely blown.

Apr 19, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Amp turns on but doesnt power my subs

well ill need 2 know wat knobs are all on the front of your amp

Nov 07, 2007 | Rockford Fosgate P3001 Car Audio Amplifier

2 Answers


ok well this is easily checked with a ohm meter see what the resistance is then if ok you might have a problem with your amp wire the speakers direct to the amp do not use ground on the car to negative on the speaker the amp is making its own ground called a floating ground do not hook the speakers together cause then you might put the in series or in parallel this is dangerous to your amp will make it work harder. so put the positive of the speaker to the positive on the amp and negative to negative same for the other speaker

Nov 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My amp works but my sub doesn't...!!!????????????

Whats the condition of your amplifier? New , Used, Old?


You might have a blown channel off your amplifier, this may cause little or no sound. You will have some distortion, crackle sound and then maybe nothing at all. What kind of subs are you running to it? Make sure the subs arent blown and check the voice coils to see that they are not torn off the subs , these are the 2 little silver or copper wires that are connected from the speaker connectors to the sub itself.


Let me know what happens?

Oct 21, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Car audio

hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Punch P10002 2-Channel Amp Car Audio Amplifier Logo

Related Topics:

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Amplifiers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides