Question about Rockford Fosgate Punch P10002 2-Channel Amp Car Audio Amplifier

1 Answer

P10002 blown? Hello i have a p10002 amp and 2 p312d4s i hooked my speakers up wrong and the amp worked alright for a little while but there wasnt much sound coming out so i turned it up and the fuse blew now everytime i put in a new fuse it blows before them amp even turns on ill turn on the amp and it will humm for about 3 seconds then pop the fuse any help would be greatly appreciated thanks.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Needs repair bad fets or outputs

Posted on Aug 09, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i install a after market radio


the after market might of had the wires crossed for the speakers.. try switching the wire speakers around to make contact one at a time. If you still cant get sound from one after doing that, you might have to bypass with an amp

Nov 24, 2012 | 2005 Chrysler Pacifica

1 Answer

No sound from sub woofer


sub may be blown up, on protect, sub could be hooked up wrong. Did it work before and if so were all the wires hooked up the same? check to see if its being overloaded by blown speakers, check all speakers one by one, check your amp sub output with another speaker, I have had this problem form hooking up wrong.
Hope this helps...........

Apr 13, 2010 | Sony STR-DH500 A/V Receiver

1 Answer

I was given a rockford fosgate 500x 4 channel amp and the rear 2 channels work fine but the 2 front dont when i hook up the speaker the speaker bottoms out and stays like that until i unhook the speaker...


Hello,

Sounds like those two of the channels are blown. There is really nothing that can be done about that other than having an expert repair it. You might as well buy a new one tho, or just use it as it is.

You could look at all the fuses in it, make sure there not blown (they will be black and the little metal piece inside the plastic will be broke or cracked)

Post back if you have any further question's and comments. Thank you for choosing Fixya!

Nov 10, 2009 | Rockford Fosgate Punch 500X Car Audio...

1 Answer

I have a 1000w amp but it got burned why??


Hello,

I'm sorry but your problem was a little confusing. Your speakers worked fine, you hooked up a 1000W amp and now you cant hear the sound ?

Then you say "they say because the wires were connected wrong in the amp it burned" does that mean your amp burnt out ?

Please post back and sort these facts out for further assistance.
As of right now im not sure if the problem is with the speakers or the amp itself.


Oct 01, 2009 | Alpine MRD-M1005 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp earlier today it was workin with no problems we parked then came back in the car 3 hours later and it wasnt workin wont come on or anything just red light which is protecting...


Check your speaker wires, make sure everythings connected right with no short circuits, and check all of the fuses in the amp, and make sure none of them are blown. If all this checks out just check the battery wire, grnd, and remote wires. It has to be a wiring issue unless you busted your amp, but if was working when you tuned it off it should be alright... hop this helps...

Sep 10, 2009 | Nitro BMW-484 Car Amp

1 Answer

Problem with subs and amp


I would first suggest un-hooking the subs, and hooking them up to another known good radio other than the one its hooked to now. Just to make sure you didnt blow the speakers. What is the wattage of the subs? Then if the speakers do work I would hook them up bypassing the amp just to see if the problem exist before or after. Come back after doing this. Thanks

Jul 05, 2009 | Car Audio & Video

1 Answer

Kicker sub wont work


Im guessing that it is possibly blown... either you ran too much power to it, or it was hooked up wrong... you should unscrew the sub from the box and look inside to make sure that it is connected correctly.... positive to positive, negative to negative,,, if they so much as touched then the L7 could very well be blown.... smell the magnet and if you smell a burnt smell... it is blown... maybe turn your amp down a little... its possible that it is also in protect mode because you are running too many watts to the amp. Feel free to ask if you have any other questions.... Please rate! :D And good luck... i really hope its not burnt out. that stuff is not cheap.

Dec 29, 2008 | Kicker Car Audio & Video

2 Answers

Speakers


ok well this is easily checked with a ohm meter see what the resistance is then if ok you might have a problem with your amp wire the speakers direct to the amp do not use ground on the car to negative on the speaker the amp is making its own ground called a floating ground do not hook the speakers together cause then you might put the in series or in parallel this is dangerous to your amp will make it work harder. so put the positive of the speaker to the positive on the amp and negative to negative same for the other speaker

Nov 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My amp works but my sub doesn't...!!!????????????


Whats the condition of your amplifier? New , Used, Old?

 

You might have a blown channel off your amplifier, this may cause little or no sound. You will have some distortion, crackle sound and then maybe nothing at all. What kind of subs are you running to it? Make sure the subs arent blown and check the voice coils to see that they are not torn off the subs , these are the 2 little silver or copper wires that are connected from the speaker connectors to the sub itself.

 

Let me know what happens?

Oct 21, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Punch P10002 2-Channel Amp Car Audio Amplifier Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

seankane89

Level 1 Expert

53 Answers

hoyzee1

Level 2 Expert

150 Answers

Robert Rankin

Level 2 Expert

356 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...