Question about Power Generators

Open Question

ENGINE QUIT RUNNING GOOD ENGING CHANGED SOUND FOR A FEW MINUTES AND DIED. NO SPARK FROM COIL. FULLOF OIL. DISCONNECTED OIL SHUT DOWN . NO HELP.

Posted by on

  • JOJKING Jan 11, 2009

    MCCULLOCH 13 HP 5700 WATT GENERATOR

    MODEL FG6000MK

    SERIAL JF182FPH0508040729

  • 54generator
    54generator May 11, 2010

    Send me the manufacturer and model number.

×

3 Suggested Answers

bargainbin2
  • 123 Answers

SOURCE: Kohler cv15 no spark at the plug.

If you disconnected the stop wire it is a coil ground wire and still cannot get a spark to the head at about 1/4 inch from the head the coil is bad. The only other thing could be a broken or loose magnet under the flywheel but that is very very rare.

Posted on Aug 29, 2009

heatman101
  • 43501 Answers

SOURCE: My eu 1000 has erratic

Hi,

Two things.... the coil can cut out when it gets hot and then cool and work again....

The oil level sensor can cut out even though the oil level is up...then cool and read correctly again...

I would be tracking your problem to these two things...

heatman101

Posted on Feb 12, 2011

  • 1378 Answers

SOURCE: i have a portercable

Seems that you have covered all the bases. The problem that you describe could be related to fuel lock or restriction in the fuel delivery system. Easy to check. Remove the air filter and have carb cleaner ready. If you are near the gen when it begins to quit, spray just a little carb cleaner to see if engine tries to run. If engine begins to run or continues to run with carb cleaner, then suspect fuel delivery problem. If the engine seems to stop quicker with carb cleaner, suspect flooding caused by too much fuel pressure (fuel pushed past the needle due to pressure in the tank; open fuel cap and listen for air pressure release). Fuel delivery problems are caused by collapsed fuel line, restriction in the fuel cut-off valve, restriction at the fuel filter (use larger automotive type), negative pressure in tank caused by no vent at cap. Rare problem with fuel delivery is caused by sudden heat rise at the carb causing fuel to boil out of carb. This is caused by the engine running very hot, lack of air across cooling ribs caused by debris or fan missing blades. You can eliminate the complete fuel delivery system by mounting a small fuel tank on a stand and running fuel line directly to the carb for test. The tank needs to be higher than the carb so that you will have good gravity feed. Good luck

Posted on Aug 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Gentron 10,000 generator will not start.


Spray starting fluid into the engine air intake and see if that starts it, if that does then you have dried fuel clogging up the works.

Nov 21, 2016 | Gentron Power Generators

1 Answer

DuroMax XP10000EH Dual Fuel Generator runs well on gasoline, but will only start and run for about 2-3 seconds after priming regulator on LP gas. Changed regulator (new OEM) but same issue remains.


I am sorry to hear you cannot get your Generator started, First I think you should start by looking at the ignition system.
To find the fault please follow these steps:
  1. Removed the spark plug from the engine and re-attach to the Ignition HT Lead. Hold the end of the spark plug tip to a metal section of the engine, and turn over the engine. If all is working correctly, you should see a strong spark, and the engine should run smoothly.
  2. If you do not get a spark, you next need to check oil level is at correctly level (to the very top as if about to flow out) and repeat step 1.
  3. If you still have no spark or it stops running within a few minutes of starting, disconnect the oil sensor wire (you will find it on the front coming from your engine just to the top left of the oil filler cap) and try step 1 again.
  4. Still not getting a spark? Then you need to replace your ignition coil. You can order one from us from our website on this page: http://www.generatorguru.com/xp10000-xp10000e-xp10000e-ca/
If you are getting a spark, but still having trouble starting the Generator, there is most likely a fuel problem too. We can assist you with the next set of fault-finding tests if you need some help. Let us know how it goes. http://www.generatorguru.com/ask-the-guru/

Nov 20, 2016 | Power Generators

1 Answer

Allpower American. 10000w generator won't start? Changed spark plug, gas is flowing. What else can we try?


Make sure it has plenty of oil. Some engines have a low oil shut off. Pull the spark plug wire off and stick a screw driver down inside the spark plug boot and hold the screw driver about a 1/4 inch away from the top of the spark plug and turn the engine over to see if you have a good bluish spark. If you don't then you have a bad coil or rust build up on the flywheel. If you have spark make sure your gas tank is full with new gas. Make sure the air filter is clean. If that doesn't work try taking the bowl off of the bottom of the carburetor and verify gas flows through the float valve. If that doesn't work then you will probably have to remove the carburetor and clean it out.

Feb 15, 2014 | All-Power America All Power 10000w Apg3090...

1 Answer

I changed the magneto on my Honda GX160 QX2 5.5hp. small engine and I still have no spark. Any suggestions on what to check ?


There could be an issue with the oil sending unit, spark plug boot or faulty on/off switch. Easy tests. Always use a new plug for testing. Unplug the oil sending unit wire and retest for spark. If spark may need to change the oil or low oil. If still no spark, leave the sending unit wire unplugged and remove the boot from the plug wire. Insert a short piece of paper clip wire into the end of the plug wire and hold near metal of the engine for test. If spark, replace boot. If still no spark, unplug wire from on/off switch and retest. If still no spark suspect faulty coil ~ redo all tests using old coil. If still no joy return new coil for exchange. I use a growler to test coils(growler used for testing armature for short, place one leg of coil on each pad of growler and activate growler for short burst). Good luck.

Aug 10, 2011 | Power Generators

1 Answer

Honeywell generator HW2000i Bought it cheap and now I know why. Started it up and it ran for a few minutes then shut down like someone turned it off. Wouldn't restart. Waited an hour. Started right up....


I would test the coil by removing it from the circuit, and attaching a properly gapped spark plug to the secondary, then apply and un-apply 12 volts to the primary. If you get a good strong spark on the spark plug tip each time you apply or remove the 12V, then you know that the coil is OK. This doesn't give you a measurement, but you don't know what the voltage is supposed to be anyway.
You might also try measuring the resistance across the primary and across the secondary and compare these numbers to a known good coil (anything similar should be in the same ballpark). Make sure to do that with the coil removed from any other connections and short the terminals together to remove any residual charge before you try to measure the resistance.
I hope this helps, good luck Al K

Jan 27, 2011 | Honeywell Power Generators

1 Answer

I have a powermate 5500 that shuts off after 10-15 minutes. I changed the oil, gas, spark plug and the filters. Help!!!


If the unit has a low oil shut down make sure the oil if filled to the proper full level.
If you have the proper level then you can locate the low oil shut down wire and remove the wire to test and see if the unit will run.

If the unit runs with the wire off then you either have low oil or a bad oil sending unit.

Oct 07, 2010 | Coleman Power Generators

1 Answer

Won't start. No spark plenty of gas. Was running and just quit. Has there been a problem with any electrical on these? It has a briggs and Straton Motor.


This is going to sound way to over simplified but here goes. They have a low oil level sensor and when the oil gets low OR the sensor fails it kills the ignition. If the engine oil level is fine and you still have no spark.. disconnect ONE lead of the sensor and check spark again. If you have spark the Oil level Sensor is either very dirty or has failed.

Thanks for choosing FixYa.
Kelly

Aug 26, 2010 | Coleman Powermate Portable Generator...

1 Answer

Kohler cv15 no spark at the plug.


If you disconnected the stop wire it is a coil ground wire and still cannot get a spark to the head at about 1/4 inch from the head the coil is bad. The only other thing could be a broken or loose magnet under the flywheel but that is very very rare.

Aug 24, 2009 | Kohler CH25 PA-CH730-0040 Command Gasoline...

2 Answers

ONAN 4000 RUNS FOR ONE HOUR AND DIES--ANY IDEAS WHY?


does it have original oil in it? if so they use a lighter weight oil than recommended for engine break in. change your oil and filter and see if that doesnt solve it.could be thinning out loosing pressure when hot. i have seen this beofore.. :)

Mar 24, 2009 | Watts Onan Portable Generator - 4000 ,...

Not finding what you are looking for?
Power Generators Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Generators Experts

John Trevino

Level 3 Expert

1378 Answers

EugenesDIYDen
EugenesDIYDen

Level 3 Expert

479 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Power Generator Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...