Question about Pyle PLA2480 Car Audio Amplifier

1 Answer

PLEASE HELP!!! I have a Pyle PLA2480 car amp and a friend installed it for me, for awhile it worked fine and then one cold night in upstate NY one of the RCA cables broke inside the amp. After removing the broken piece from the inside out I plugged it back in and for starters (because I have to do this everytime I get in my car) to get it to work I have to plug the ground to the amp. then attach half of the hot to REM the other half into the 120batt it won't work on just one then the radio to either one of thoughs now it works great sounds beutiful but the bass-control that I convieniently installed under my steeringwheel does nothing the light comes on but no bass-control. Now that its on and working (except the bass-control) ITS ON and it stays on draining my capasitor and my battery when I shut off my car the only way I can get it to got off is to unplug all three wires. I am pretty handy and would love to fix this problem myself even if I have to go inside and replace parts, I love the sound when it is working propoly but don't want to fork-up for a new one. If anyone has any ideas that could help please let me know I would really love to keep my current amp. PLEASE HELP!!!

Posted by on


1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 22 Answers

The Amp stays on because you have a constant 12V to the Remote.
If your stereo remote is no longer working then run a wire from a 12 volt source that turns on and off with your ignition something like your radio fuse in the vehicle fuse box.
As far as the Bass Knob if it is connected properly and still not working check the line for wire kinks or cuts that may have happened during installation if you cant find any problems you can get a universal bass knob that plugs via your RCA cables for under 20 bucks.
Hope this gives u some ideas.

Posted on Jul 22, 2009


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Do The Pyle PLG6C need an amp? or can i just connect em straight to my stereo

It depends on your stereo you have installed. Some come with a good amp attached and others do not. I have a factory AC delco and it pushes them just fine. so the answer to that would be based on what stereo you have installed.

Hope that helps.

Mar 13, 2012 | Pyle PLG6C Car Component System

1 Answer

Pyle PLTAB8 Car Component System, Lights will not turn off. Help

Sounds like he did not wire a remote line from your radio to the amplifier, if he put a 12v from the battery to the amp and the remote spot on the amp then it will not turn off, you will need to either wore a toggle switch to the remote so you can turn it off manually or check the back of your radio for a remote line or splice a remote line from the accessory power supply on your radio so the amp will turn on when the radio is on

Feb 06, 2012 | Pyle PLTAB8 Car Component System

1 Answer

The heat in my 2005 Elantra will not work unless I am moving.

Change the thermostat and make sure to bleed the system of air when refilling with coolant.You should have lots of heat in a 2005 Elantra at idle or driving.

Apr 16, 2017 | 2005 Hyundai Elantra

1 Answer

Hooked the damn thing up power my subs wonderfully for that evening, and all day today, got in this evening and nothing, checked the amp and red light, ok, fine, checked the manual, says the light protects...

probably something corssed in your speaker wiring. be sure that you did not exceed the ohmage capabilities of the amp, and that no speaker wires are crossed, or shorting out on the frame. if you have too many speakers hooked up, that can reduce the ohmage, and your not supposed to go below 2 ohms -per channel, or 4 ohms bridged mono.

Mar 13, 2011 | Pyle PLA2200 Car Audio Amplifier

1 Answer

I live in upstate ny syr Ny I have a 1998 toyota camery Le 4 cylinder with 168,000 miles on it any one please help dont have much money so if possible find it in your heart please HELP!!!!!!


Feb 27, 2010 | 1998 Toyota Camry

2 Answers


I have a 1997 Mazda 626 and my headlights go out for no reason. My highbeams seem fine so if I have to drive at night I have to drive around holding my highbeams on. Nobody can figure out the problem. I really need help on this. I need to drive my car at night and can't.

Jun 25, 2008 | 1997 Mazda 626

1 Answer


If the ground terminal is connected to a ground wire, the ground wire isn't connected to a good ground.

Sep 24, 2007 | Pyle PLA985R Car Audio Amplifier

Not finding what you are looking for?
Pyle PLA2480 Car Audio Amplifier Logo

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers

The Knight
The Knight

Level 3 Expert

74999 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8830 Answers

Are you a Pyle Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides