Question about Hoover Numatic Nacecare Henry HVR200A Commercial Canister Vacuum Cleaner

Open Question

Economy mode not working

Our Henry has a red boost switch which activates the full boost mode when pressed. This switch now seems to be permanently on. Suction is fine. I have taken it apart and can see no visible fault so assume that either the switch or the circuit board is faulty... Any ideas welcomed. Thank you.

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My henry hoover wont work


check main cable & power switch, mAY BE FAULTY

Feb 12, 2015 | Hoover Numatic Nacecare Henry HVR200A...

1 Answer

How to disassemble henry hoover motor


There are a few Youtube videos that might help you get the job done.
I not exactly what you need, search your model, and problem.
Read down thread for additional repair discussion.
I hope this solves your issue. I don't believe it is on your unit, but double check it's not reverse thread. PEACE
https://www.youtube.com/watch?v=YaMBHkf0LUk

Jun 05, 2014 | Hoover Numatic Nacecare Henry HVR200A...

1 Answer

Hi i am also having problems with my Henry it started making noises from the motor then smoking and now every time I try to switch it on it trips the electric out. Could this be the carbon bushes need...


1st are you in America or Europe? 399$ here I did a bit of searching it took a while but these should give you some insight go to manuals click the Henry pict

May 07, 2014 | Hoover Numatic Nacecare Henry HVR200A...

1 Answer

Not working


XL 15 won't run at all? By checking all the connections, look at each component to make sure the machine is assembled so as to activate all of the safety features.
1) The back screen needs to be inserted so that the tab depresses the interior safety switch in the slot. You'll be able to hear it click. Wiggle the screen if the little tab seems loose. Some need to be inserted down on top of the switch, others need to push the switch back. Try both ways.
2) Have you checked the fuse? It's the little round knob on the back right corner. If it is blown, replace it with the EXACT same size, available from an auto parts store.
3) Is the wall socket live? (I know, that sounds totally stupid! But you'd be surprised at how often the wall socket is dead! (Often turned off by a switch somewhere else.)
4) If there's a switch on the far right side (some have this feature, some don't), set it to "Manual" and leave it there. The "auto" feature sometimes is deactivated or stops working.
5) Make sure the switch on the front is "On."
6) Try turning the knobs to different settings. Sometimes the lower settings are too low to activate the machine.
7) Make sure the plates are inserted firmly and correctly, in the grooves top and bottom. Make sure the contact fingers press firmly on the screen part of each side.
8) Inspect the inside of the machine carefully, looking for any wiring that is obviously loose, corroded, frayed, broken, disconnected. Fix it if you can, or take it to an electronics person.
Hope this helps. If none of these troubleshooting steps helps, you can call Vollara (new name for Alpine/EcoQuest) and they

Feb 13, 2011 | Alpine Air XL-15 Air Purifier

1 Answer

I have an Eagle 5000 air purifier. Stopped working


Just went thru this Tues. Get the top of screen in place and then push the plastic in on safety switch. I was having it push down and then slide screen in. That plastic piece is split like when you push it in, it hits 2 different heights. Instead of pushing it down get top in and push the plastic in, easy. Turned on then. Already had the switch on so it fired up soon as I pushed it in.

Jan 15, 2010 | Eagle Advantage Alpine Air Purifiers Eagle...

1 Answer

The buttons on the front don't work. This just started today


My buttons & remote do nothing, it seems the unit is in full power mode and I can't change any of the settings, all lights are on

Oct 17, 2009 | Ecoquest Breeze AT Living Air Purifier

1 Answer

Xl-115 Automatic setting not working?


your sensor board has failed , a realy common problem , most if not all are dead and no parts are made for it ...... you do not need the sensor anyway it was only installed as a knee **** reaction to fda worrys of ozone levels over 0.05 ppm in bedrooms . so the board was installed to cut at 0.05 ...... it was a failure , so a bypass switch was added to get around the problem board ... just set on man , adjust for your sq ft ... you will be fine

Sep 08, 2009 | Ecoquest Living Air Classic Air Purifier

4 Answers

Red Cleaning Light won't turn off


After cleaning the unit, replace the grid into the unit. Hold upside down for at least 30 seconds to reset.

Jul 19, 2008 | Sharper Image Ionic Breeze GP SI730 Air...

3 Answers

Red Light on front of Filter Queen Defender


When the red light is blinking, press and hold both up and down arrows until the red light blinks RAPIDLY, release both for a second or two, and press and hold both again until it stops blinking. It cured my problem.

Mar 06, 2007 | Filter Queen Defender Air Purifier

Not finding what you are looking for?
Hoover Numatic Nacecare Henry HVR200A Commercial Canister Vacuum Cleaner Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Air Purifiers Experts

Brad Brown

Level 3 Expert

17591 Answers

Argospete
Argospete

Level 3 Expert

1035 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Are you a Hoover Air Purifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...