Question about JVC TH-C40 System

1 Answer

Bass of woofer in my system is not working

I have 3200w woofer of advik brand. i have purchased it one year ago. now, its bass has stopped working. i would be thankful if u could help.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 1,070 Answers
Re: Bass of woofer in my system is not working - JVC TH-C40 System Home Theater Systems

Take it to a tech for repairs.good luck

Posted on May 02, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

3 Answers


mosfet's might have shorted and blew up a capacitor and might have took some surface mount parts with will be in the middle board with the metal shroud (shield). try to replace it .

Aug 12, 2008 | JVC TH-M606 System

1 Answer

My SONY Home Theater Model HT-6600DP unit was working fine and then about tow years after...present, my sub woofer is sounding distorted. Why is this happening? Please help me as I often watch my home...

Is it so even at lower volumes?

Are you sure it's the sub distorting and not the front or center speakers?

If you designate them incorrectly as Large (which tells the receiver they CAN effectively produce bass frequencies) they will probably distort in the presence of low frequencies.

See Page 17, 19

Register and download the manual for free at

Mar 13, 2011 | Sony HT-6600DP System

1 Answer

DR30G0 Bass

If you press "select," you can scroll through the individual sound channels and reduce the level of amplification to the sub-woofer.

Apr 08, 2009 | NexxTech (DR30G0) System

1 Answer

Front bose speakers and bass module stopped puttimg put sound

If you're saying you hooked the Bose speakers directly to the Yamaha's amp instead of the prescribed way through their own bass module - they're cooked.

Dec 23, 2008 | Bose Lifestyle 12 System

1 Answer


You need to take apart tthe sub woofer and check the connection to bass speaker for continuity. It sounds like an internal broken connection to speaker on sub woofer unit.

Aug 12, 2008 | JVC TH-M606 System

2 Answers

Bose lifestyle no sound

Hi, best practice when troubleshooting a no-sound Bose Lifesytle system is to first begin with the internal sources (i.e. the AM/FM). Bose Lifestyle system when connected properly (media center and bass box via the data cable) should show a steady green light underneath the bass module. Begin by simply playing AM/FM tuner and try to increase the volume till 45 (normally the sound becomes audible at this level). If the system still has no sound, then try to check if the bass module is steady green. When you see a blinking green LED (slow green) then do kindly check the DIP siwtch (red latch switch with white mini switches) just beside the Light and data connection. All of the switches should be in "ON" position (basically toggled upwards with the arrow marking indication). Before changing DIP switch settings do ensure that the bass module is not connected to the electrical power. after ensuring that all DIP switch are in the "ON" position, connect the data cable firs and then power up the bass module. Then you should see the bass module blink green twice and once you turn on the nedia center, the green blinking should turn steady green. That should sort out your problem.

Also do note tha this procedure applies only to Series II Lifesytle System and does not include the Series IV (with the smaller bass module).

If all still fails, there is an internal problem with the bass module which would require servicing.

Hope this helps!

Jan 27, 2008 | Bose Lifestyle 18 System

2 Answers

Only sound for cd/dvd

Could be damaged cable between the media centre and bass module (check along cable length for damage, kinks or at DIN plug ends for bent/damaged pins), faulty media centre (unlikely) or fault in the bass module....

Jan 13, 2008 | Bose Lifestyle 48 System

1 Answer

Sub woofer shuts off

please check sub cable first with another good one and then change sub itself.because it draw too much power.

Jan 05, 2008 | JVC TH-C50 System

Not finding what you are looking for?
JVC TH-C40 System Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top JVC Home Theater Systems Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

6993 Answers


Level 3 Expert

56798 Answers

Are you a JVC Home Theater System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides