Question about Creative Labs Sound Blaster Live! 5.1 Sound Card

1 Answer

I accidentaly deleted the sound driver for my computer, so i cant listen to any sounds can you help me in finding a way to get this driver?

Posted by on

  • Anonymous Dec 31, 2008

    i accidentaly deleted the sound problem

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 42 Answers

Hi. You can download the new driver here
http://support.creative.com/Products/Products.aspx?catid=1
but you have to find which card you have first to pick from. I assumed it was a Creative Labs sound card from your avatar. If you can't easily find it there here is another spot to download the driver from
http://www.nodevice.com/driver/company/Creative-Labs.html
You only need the driver and not the rest of the files that go with it.
Dale

Posted on Dec 30, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I need to reinstall my sound card but i cant find out what sound card i have. there is nothing listed in the device manager.


Hi there,
This could be due to the fact that the sound card driver might have been deleted by accident. Nevertheless, do a fresh install of the driver if you still have the CD with you.

Aug 10, 2010 | Toshiba (4CH-VOUT) Sound Card

1 Answer

I accidentaly disable my speaker


Do right click on my computer.
Click on manage.
It will open computer's system device.
Click on device manager.
It will open all drivers attached to your computer.
Now, click on the sound card driver and open it.
In this dialog box at the bottom of the dialog you will found out two options clicking on it.
You should to click on use this driver.
Your problem is solved.

Apr 22, 2010 | Sony (A-8067-475-A) Sound Card

1 Answer

I have a creative audigy Creative Labs Sound Blaster Audigy 2 Sound Card and Creative 7.1 surround sound speakers. When I was using XP all 7 speakers worked perfectly. Now with my newer Vista machine,...


Uninstall all sound drivers for the card. Delete all folder and use search to locate everything related to the sound card. Remove card , turn comp on w/o card. Turn off reinsert card.
Should fix it.
Vista has many,many issues like this.
If you have more types of sound listed in "SOUNDS" delete all but Audigy.
Re-install drivers AFTER you get ALL NEW VISTA UPDATES>
Mastersage

Feb 18, 2009 | Creative Labs Sound Blaster Audigy 2 Sound...

1 Answer

I want audio driver in my computer right now


First ,if you have a desktop computer, and the sound card biult in, you need the drivers from the mother board manufactures' site" intel , Ge..ets" and if if you have laptop , it can be found from the computer company site...pls more details about your PC

Nov 27, 2008 | Computers & Internet

1 Answer

I have the sound divice but i cant play any thing and i dont here


possible sound device failed, or drivers not the right ones, my newer note book had failed sound device (code 10 cannot start) it started doing static when listening. the failed all the way. i now use an external sound device myself that was about 15 dollars now i have sound again without large cost. this may be an option for you.

Nov 18, 2008 | Digidesign Mbox External Sound System

1 Answer

No sound


go into DEVICE MANAGER AND LOCATE SOUND AUDIO AND INSTALL UPDATED DRIVER, OR GO TO control panel and see if sound/audio reflects your card being there.

Jun 22, 2008 | Computers & Internet

1 Answer

Hello


It may be the same problem that I had recently, where it said "No audio device installed", but everything looked fine in Device Manager. (If you don't know how to get there, you can look it up. It's not hard.) If that's the case, all you have to do is restart your computer (possibly a couple times).

If you're fairly certain you actually don't have an audio device installed, try a Google search for audio drivers. There are a ton of websites that can help you find and download the right one for your system. (Check the sponsored ads first!) Hope this helps!

Jun 22, 2008 | Computers & Internet

2 Answers

Sound probs


have you tried to let windows find it?

right click on it in Device manager and delete it.
scan for hardware changes
windows should find and install

Nov 30, 2007 | Computers & Internet

Not finding what you are looking for?
Creative Labs Sound Blaster Live! 5.1 Sound Card Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Computers & Internet Experts

micky dee

Level 3 Expert

2635 Answers

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Shawn DuRee

Level 3 Expert

355 Answers

Are you a Creative Labs Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...