Question about MA Audio HK401SX Car Audio Amplifier

1 Answer

Protect light i own a 2 channel amplifier and it is hooked to 1 12 in i pipe sup and there is a protect light on the amp and when the protect light turns on the sub will not work but the light flickers on and off constantally how do i fix this proublem?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 42 Answers

Does the amplifier do this when you don't have the sub hooked to it? If so, you have a pinch/short in your ground or power wire. If not, the subwoofer has a short in its voice coil or the amplifier needs to be repaired as it cannot handle a typical load.

Posted on Dec 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2 amps instalkled in my car one is sony 1200w 2 channel amp for speakers and one is solid audio f2500d for 3 subs my sound and every thing was good but suddenly from yesterday im having trouble when...


First disconnect the CD head unit from the sub amp and see if the other amp works. If yes, the problem is the wires to the amp, the amp itself, or the subs/sub wiring. If no, the problem is the head unit--probably an internal short.
If the other amp works with the sub amp disconnected, reconnect the sub amp to the head unit, but disconnect the sub wires from the amp. Try the CD player. If the amp goes to protect with no speaker wires attached, the amp is bad. If the amp is OK, the problem is the subs or sub wires. Hook the wires up to the amp again, but disconnect them from the speakers. Try the player again. If the amp goes to protect, the problem is the amp wiring. If not, the problem is the subs. Check the impedance of each sub using an ohmmeter to determine which amp is out of spec.
Please let me know if you have questions, and thanks for using Fixya.

Jun 11, 2011 | Solid Audio F2500D 1-Channel Amplifier Car...

1 Answer

Why is the red light that says protect on? my amp turns on but it dosent work, i have a sup hooked up & it dosent work. the red light that says protect is on.


first thing check all ground and power wires and make sure ur rca wire make sure it isnt cut in anyway. after that unplug ur sub and unplug the negative wire from ur amp, while its out check the fuses on the amp if all is well put all fuses back if not get new. then plug the negative wire back in if protect goes off check for heat and if no heat inspect the wires from speaker out put all the way to the sub, look for any wire touching another this is were most problems are even the smallest wire can trip a protect. if u still cant find the problem. an amplifier specialist is in order.if its trashed go on ebay and buy a powerbass there goin cheap right now. hope i could help

Oct 12, 2010 | Lanzar VIBE266 Car Audio Amplifier

1 Answer

Have 600w amp 2 10's and they aint even bumpin, DO I NEED TO BRIDGE IT


No, that'll use two channels to power one sub. First, is the gain turned up? There's a knob on the amp to turn it up. If the gain is already up, and if the amp is two-ohm stable, then wire the subs in parallel. I'm assuming the subs are each hooked up to their own individual channel. Swap the two negative wires at the amp, so sub 1 is hooked up to channel 1 positive and channel 2 negative, and vice versa for the other sub. That'll dramatically increase the output. Again, make sure the amp documentation says it is 2-ohm stable, or you'll damage your system.

Dec 24, 2009 | Kenwood KAC-729S Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Amplifiers

1 Answer

I have a rockford fosgate p250.2 amp hooked up to two 12' subs but the amp is not powering on... instead the protect light is on and im not sure if its because its so cold outside... please help and thank...


Remove the load from the amplifier (subs) and the RCAs
Retry.
If the light stays on, there are internal problems with the amplifier, and it needs to be serviced.
If the amplifier works normally, attach the RCA's and power on again.
If it remains on, connect one sub, and then the other.
Your amplifier is a 2 channel amplifier rated at
60 Watt - 4 Ohm - 2 channel(s)
125 Watt - 2 Ohm - 2 channel(s)
250 Watt - 4 Ohm - 1 channel(s)
Your amplifier is not rated for a 2 ohm mono load.
If you have Single voicecoil subs wired in parallel, you have a 2 ohm mono load - your amplifier will eventually fail.

Jan 16, 2009 | Rockford Fosgate Punch P2502 Car Audio...

1 Answer

Car system


if you have dual voice coils connect on each seporate sub negative left channel to possative right channel of the subwoofer same to other sub then conect the left possative and the right neggative to your box power terminal same to other sub then conect the two sub outs on your box left speaker positive to your positive left channel bridge then conect left speaker negative to the right speaker possative then connect your right speaker negative to your right channel negative brigdeg to your amp is single coil hook the box its self up the same way to your amp i have two dual voice cooil 12" hooked up to the same amp that way and it rocks without the power protecter turning on

Nov 09, 2008 | Pyle PLA2200 Car Audio Amplifier

1 Answer

Amp Not working!


If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Sep 20, 2008 | Power Acoustik TS620-2 Synchronized...

1 Answer

Blinking protection light on mrv-t757 amp


Could be the power supply or output stage electrolytic capacitors.
Possibly breaking down/drying out inside.

Mar 17, 2008 | Alpine MRV-T757 Car Audio Amplifier

1 Answer

Protection light stays on no output


i have the same amp and have that same issue before. yes you are correct that if you take off the RCA cables on the input there will be no light. either you have plug the remote line on the 12v or a grounded sub. it should be 12v/remote/ground from the corner. good thing im just fixing my sub earlier. it is no problem if you have hooked the remote line on the 12v, it is the same supposed to be. to check if your amp is working, short the 12v/ and the remote line and play your stereo and see if your sub is working. by the way, what sub are you using? i just blew my sub and need a new one.

Feb 02, 2008 | Pyle 1800-Watt 2-Channel Bridgeable MOSFET...

2 Answers

Protection light


You cannot parallel two subs AND run them on the Bridge. You must have at LEAST a 4 ohm load on the bridge, and 2 4 ohm subs in parallel equals TWO OHMS. BAD!!! Move each sub to it's own channel or your amp will soon fry.

Sep 10, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
MA Audio HK401SX Car Audio Amplifier Logo

Related Topics:

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top MA Audio Car Amplifiers Experts

Robert Rankin

Level 2 Expert

338 Answers

Ronald Prier

Level 1 Expert

26 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Are you a MA Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...