Question about Kenmore 35912 / 35913 Progressive Upright Vacuum

1 Answer

Progressive with Direct Drive not picking up

All of a sudden, vacuum attachments have almost no suction... Any help appreciated... Thanks!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 281 Answers

Check and see if your brush roller is turning.remove the hose and see if you have suction.if not then you have something stuck in the suction intake. after removing the hose turn it on and put your hand over the hole wher the hose was connected to the base.if there is suction there then you have a blockage in your hose.if thats the case take the hose completely off the vacuum and take it outside and blow it out with a garden hose.if the blockage is in the intake then get a coat hanger and bend the tip so it is round,then work it down into the hole where the hose was connected to the base.you should be able to push push out the clog through the bottom.also clean all the filters real good.you can also take the filters out and then turn it on if you have suction then ,then its the filters

Posted on Apr 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My vaccuum has no more suction


There is no drive belt on a progressive drive vacuum. It is direct drive meaning it is attached via the motor. No vacuum means no air flow somewhere in the unit. Torn bag,Wrong bag, pluged filter under bag.Make sure the opening in the bag is the correct size,too big and it will not seal. Make sure when you close the housing it seals also. No housing seal no vacuum. Kenmore vacuums tend to be plastic housings. Cracks are comon in the wheel housing area. Check there first. Plastic expoxy will work with this fix if so needed.

Feb 22, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore Progressive with direct drive model 116.36923502 stopped picking up debris and empted it into the floor and is there something you need to do to switch from floor to using the hose. It does not...


sounds like you have a clog in your hose, full bag, or dirty filters. take the bag door off and feel inside at the bottom for suction or air movement. if you have suction there chances are its a clog in the hose. You can use a coat hanger or something similar to reach into the hose just be careful not to puncture the hose. First just try turning the unit on and stretching the hose as far as you can. try to feel for a clog and try to free it with the hose stretched.

Jan 22, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore vac has no suction in hose or base


Find a Shop that sells these & get them to show you.how it works.

Apr 08, 2009 | Kenmore 31912 Progressive Direct Drive...

2 Answers

Kenmore progressive/direct drive-- roller stopped turning


We have the same vacuum & had the same problem. As the vacuum ages & the hose is periodically removed from the nozzle to use with the attachments, the white switch, adjacent to the nozzle connection, wears. If the hose is not fully reinserted or if the attachment notches are inadvertently aligned with the white stitch, the agitator may not work reliably. Assuring the hose is fully inserted, with the locking notches away from the switch has eliminated this problem with our vacuum cleaner.

Jan 24, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vacuum will not pick up even fuzz on the carpet


If the suction is strong through the hose and its still not picking up, then something is definately clogged despite the strong suction and rolle brush. Check all inspection tubes including the main dirt channel behind the roller brush. You may find something that keeps getting in the way when dirt or hair is trying to bypass through.

Jan 23, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

I have the upright kenmore progressive with direct drive and the filter canister stops bringing in air and picking up when hose is put into vaccum, when you remove hose and use as an attachment it starts...


Check the hose after the brushes. With this problem there is normally a clog in between where you disconnect the hose (to use attachment) and the brushes that clean the carpet.

Dec 21, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore direct drive model 116 31912100 lost vacuum


Check the inlet where the dirt is first sucked in for a clog, also your hose may be clogged.

Sep 01, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore progressive Direct Drive Vacuum w/Hepa


Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.

May 03, 2008 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Getting suction to use attachments


When the vacuum is in the upright position, it should give you suction thru the hose.

Dec 02, 2007 | Kenmore 31913 Progressive Direct Drive...

Not finding what you are looking for?
Kenmore 35912 / 35913 Progressive Upright Vacuum Logo

332 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18297 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60541 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...