Question about Electrolux UltraLux 2000 Bagged Canister Vacuum

3 Answers

Lack of suction even with filter removed.

There is some suction but not nearly what it should be. Bag is new, and for a test I removed the filter and that only made minimal improvement.

Posted by on

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,976 Answers

I used to be a service manager for Electrolux. It sounds like possibly a clogged fan or hose. Take the hose off and check the amount of vacuum at the opening of the cleaner. If it has more suction without the hose, hold the hose in place backwards to try to **** the junk out of it. If the hose was damaged inside, it may be necessary to have it cleaned out with a very small hook. Make sure you have the filter & bag in place. They are needed to make a complete seal in the vacuum system. Make sure the suction control door on the hose (near the handle) if shut. This is normally only opened to vacuum curtains and loose hanging draperies.

Posted on Jan 01, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 128 Answers

What you can do is
check that the pipes are not blocked
this happens alot

to check if it is your vacume or pipes
unclip the pipes and put your hand to where the pipe conects with the unit on
if there is still no suction look to see if there is a speed switch and turn this up if it is low
if this dose not work you might need a new motor
hope this helps ;-)
ricko

Posted on Dec 29, 2008

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 50 Answers

It could be the motor

Posted on Dec 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model No. 116.39110900


Remove the filter / bag from the compartment, close the cover and briefly turn on the vacuum - is there suction? If so, check that the bag isn't already full / or replace with a new bag. Make sure it the bag is not being pinched / caught under the cover.

If no suction, look closely at the edge of the filter / bag compartment opening of the vacuum. There should be a gasket that the cover presses against to help ensure a good seal. If this gasket is missing, cut, has an object lodged on it or is otherwise damaged - it may be preventing proper sealing of the door; allowing air to be pulled through the gap in the seal - and responsible for the loss of suction at the hose.

Oct 19, 2015 | Kenmore Vacuums

2 Answers

Model UH60010, Series X12.0, Mfg code K09A. While attempting to use the hose and the extensions to clean shelves, my wife reported no suction. I removed the brush roller and the plastic piece just below...


There are six different reasons a vacuum can lose suction, a plugged vacuum hose, bad motor, full vacuum bag, or cracked or damage hoses. Purchasing a vacuum cleaner can be a costly expense while repairing the suction on the unit can be virtually free. Most suction loss problems on a vacuum can be easily fixed or remedied with common house hold tools and very little technical expertise.
If your vacuum cleaner losses suction, the first and easiest solution is to check the bag. If the vacuum cleaner bag is full suction will be greatly reduced and the unit will become ineffective. A vacuum cleaner works by passing air through the bag fibers leaving dirt and debris behind inside the bag. If the refuse bag becomes full, airflow is restricted, limiting the amount of air passing through the vacuum bag resulting in loss of suction. When replacing the vacuum bag always consult your owners manual to insure that the vacuum bag seals with the vacuum inlet hose. If your vacuum cleaner bag is not tightly sealed to the vacuum inlet hose you will decrease the air flow through the bag resulting in loss of suction.
The second and sometimes most common reason for loss of suction on a vacuum cleaner is a plugged vacuum hose. If the hose becomes plugged, air flow will become restricted. To unplug a vacuum hose detach it from the machine and inspect the inside. If there is a restriction in the hose, remove it with your fingers and replace the hose onto the unit. If the hose is long and the debris is hard to get too, a broom handle or other long object can be passed through the hose to dislodge the debris. Most vacuum cleaners contain more that one suction hose, so make sure to check each one by process of elimination. Another area that can become easily plugged on a vacuum cleaner is under the lower base of the unit by the roller brush. Large debris can get caught in this area and restrict air flow to the hose.
If your vacuum refuse bag is not full and the suction hoses are not plugged the next thing to check is the condition of the hoses. Many hoses are made from plastic which can easily tear or crack. If your vacuum cleaner shows signs of wear or are cracked they need to be replaced. Even the smallest hole in a vacuum hose can leak enough air to greatly diminish the suction potential of your unit. Replace your vacuum cleaner parts with OEM parts from the original manufacturer to ensure the tightest fit.
Most vacuum cleaners contain filters. Filters are used as a last line of defense to remove dust and smaller debris particles before the air is recycled back into the environment. If vacuum cleaner filters become dirty or plugged they also can decrease the amount of air traveling through the unit. Some filters can be easily rinsed with water whereas others need to be replaced. It is important to check your owners manual before rinsing a vacuum filter.
The last and probably least common problem for a vacuum cleaner to loose suction is a bad or failing vacuum motor. Over time vacuum motors lose power due to worn carbon brushes or long term damage. A vacuum cleaners worst enemy is moisture. If water or moisture is sucked into the vacuum motor it will greatly diminish the amount of suction the unit has. Replacing a vac motor can be a costly and time consuming ordeal. In some cases, replacing a vacuum motor can outweigh the cost of buying a new vacuum. Vacuum suction is measured in water lift which can easily be measured by using a water lift gauge. If the water lift measured in inches, falls below half the original water lift specifications for the unit, it is time to replace your motor. Most vacuum cleaner repair shops carry this type of equipment and can easily tell you if it is time for a new vac motor.

Jul 25, 2010 | Vacuums

1 Answer

Electrolux 2100 vac dies when you attach hose even with new bag.


If the bag full light keeps coming on, you can first try adjusting the dial on top of the vacuum cleaner. If that does not work, then you need to change the control valve. This is an internal component of the canister and is directly below the dial. You will need to follow the instructions on a previous post to open the Electrolux plastic canister vacuum, and remove the bage cage. Once you remove the bage cage you can change the control valve, and this will solve your problem with the bag full indicator.

Mar 31, 2010 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

After we change the bag, it still gives us a red light


Greetings,

The bag full indicator on most vacuum cleaners is not completley fool proof. Most vacuums will just register a loss of suction, and they will then illuminate the bag full indicator, whether or not the bag is full.

If you've changed the bag, and the machine is still indicating a full bag, then this could mean one of two things.

1. Dirty Filter. According to the part diagram for your vacuum, there is a filter underneath of the vacuum cleaner bag (Bissell Part Number
203-1013) that is there to protect anything from getting into the motor. Since the filter is located before the motor, most refer to this as a pre-motor filter. Sometimes if this filter is really dirty, it can cause the vacuum to loose suction, which will also cause the bag full indicator to incorrectly display. Simply clean this filter by running it under warm water, then allow it to completely dry before replacing it in the vacuum. While the filter is out of the vacuum you can turn it back on and test to see if the light is off now that the filter is out. If the light goes off, then you have found the problem! If the bag full indicator is still on, please see the next possible problem.

2. Clog In the Vacuum. If the vacuum was run with a full bag, and when you removed the bag, the bag was completely jammed full, then your vacuum cleaner may be clogged somewhere. When the bag is packed full of dirt, the vacuum continues to try and put more and more dirt in the bag, even if it's full. Sometimes the dirt will even start accumulating inside the hose as it has no other place to go. The first place you should check is the hole that you connect the bag to. Remove the new bag that you installed and examine the hole that the bag connects to inside the vacuum. Can you see anything stuck here? If yes, do your best to try and dislodge it. If you're not able to visibly see anything here, your clog may be inside the hose, or even in the base of the vacuum.

If you have another vacuum cleaner this will really help you in clearing the clog. With the other vacuum, take the suction hose of the good vacuum, and connect it to the hose on your Bissell (still while the bag is removed, and the bag housing door is open). When you connect the hose of the other vacuum, can you hear a difference in the motor? Does the motor start running at a higher pitch when it's connected to your Bissell? If yes, then you've narrowed it down to a clog in your hose. If you can feel suction from the other vacuum through the hole that the bag connects onto, and the good vacuum's motor doesn't change noise when connected to the Bissell, then your clog is in the bottom section of the vacuum. You can sometimes stretch out the hose of the Bissell while the other vacuum is attached, and this will dislodge the clog.

If you don't have another vacuum, simply remove the hose from the Bissell completely. I believe that there maybe 2 screws that hold this hose onto the back of your Bissell, simply remove these two screws, and remove the hose. An easy way you can clear clogs is to take the hose outside, and use a water hose that has a pressurized nozzle on it, and spray down the hose while holding the hose of your Bissell vertically to allow gravity to work its magic. You can also stretch out the hose of the Bissell to get maximum benefit of gravity and the water.

If the clog is in the lower part of the vacuum, it is usually right at the suction port behind the roller brush. This is the most narrow part of the vacuums suction intake in the lower part of the vacuum, and is prone to clogs. Simply remove the four screws on the bottom of your Bissell to remove the bottom plate. Look behind the roller brush to where the suction port is to see if you can see any clogged debris.

If this doesn't help clear your clog, or fix the bag full indicator, I'd really like to try and diagnosis this further with you. Please just use the Clarification Request or add a comment and explain what happend after trying these things I mentioned above. I'll be more then happy to try and assist your further. I really hope that this was helpful to you. If you found this helpful, please be kind and rate my repair by clicking the thumbs up icon in the review.

Thank you very much,

Chris J.

Mar 21, 2010 | Bissell 3522 PowerForce Bagged Upright...

1 Answer

Bag was not on good, resulted in dust,dirt, dog hair everywhere...have cleaned pretty thoroughly but vacuum does not have any suction. After taking apart did find that the larger wide belt is broke but I...


Greetings from GoVacuum,

There are two things that you should check on this vacuum after running it without a bag inside. The first thing you should check is the filter that is underneath of the vacuum bag. This filter is underneath of a bracket, and the bracket can be removed by pulling straight up on the bracket. The bracket and filter are directly below the vacuum bag inside the vacuum bag housing. If the machine was run without a bag (or the bag fell off) then this filter is most likely going to be extremely clogged. You can simly remove the filter, and run it under hot water until clean. Make sure the filter is 100% completely dry before putting it back in the vacuum and using it. Running the vacuum with a wet filter will destroy your motor.

Now in terms of the belts. Where as the belts don't directly control the suction of the vacuum cleaner, they certainly facilitate the pick up of dirt and debris on the floor. Many people assume that since the vacuum is not picking up from the floor, then the vacuum doesn't have suction. You can test this by pulling out the attachment hose and feeling for suction, is there suction at the end of the hose? If yes, then the reason the vacuum is not picking up on the floor is because of the belts. If you don't have suction at the end of the hose, then you have a clog, some where or a dirty filter.

The belts actually are what spin the brush, and the brush basically sweeps the carpet, and throws the dirt and debris into the suction port, and when the dirt and debris are near the suction port, the suction then takes over and takes it to the bag.

There are two belts on this model, it's best to replace both of these belts at the same time. If you replace just one, then the other belt will wear out quicker. It's always best to replace these two belts in conjunction.

The two belts that are used on this vacuum are:

Hoover Windtunnel V-Belt Part 38528034

Hoover Windtunnel Flat Belt, Hoover Part 38528035

Once you have the belts, and you're ready to replace them, here's a great video that we shot here at Govacuum.com that shows you exactly how to replace these belts, as well as some basic maintenance on your roller brush;





I really hope that my repair solution was helpful to you in fixing your vacuum cleaner. If you have any further questions about this repair, or any repair, feel free to contact me at chris.jones@govacuum.com, or request a clarification here on Fixya.

If you did find this repair solution helpful, please kindly rate this repair helpful by clicking the 4 Thumbs Up Icons in the top right hand corner of this solution.

Thank you very much,

Chris Jones
GoVacuum.com

Mar 19, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Vacuum not picking up


At the top of your wand, do you have a plastic swivel that cover a hole in the wand? This is for when you are cleaning curtains, and if that is open, or cracked you will loose suction there... also check your hose for cracks, or breaks. If it were in the shop I would put a gauge on it... normal suction is about 80-95 inches of water lift at the end of the hose. Once you have check each section of the hose, and wand, check the housing for cracks, a missing gasket (Very Good Reason For Lack Of Suction) As to your Filter, how long have you used that one filter, you can clean them for a while, but once a paper filter gets full of FINE dust you won't get it all out, you will have to replace the filter itself at that point. I hope this was helpful.

Jan 19, 2009 | Kenmore 22512 Bagged Canister Vacuum

1 Answer

Lack of suction


I use a broom handle..works very well

Nov 26, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

2 Answers

Panasonic mc-v6840 Low suction.Changed bag and cleaned hose blockage


Check the sole plate where the roller brush is. There may be an obstruction leading from the sole plate to the main dirt channel. Usually on many Panasonic uprights the main dirt channel is a removable bent plastic tube before it meets the bottom of the hose. Check to see if this isn't obstructed. ALso check your filters on the vacuum as sometimes a blocked filter means a lack of suction.

Jul 04, 2008 | Panasonic Vacuums

1 Answer

No hose suction with replacement bag


The Bag must be blocking the port it connects to. Remove the bag and close it up. Test it again with no bag in it. If you have suction now, the bag is blocking the port. Maybe it is the wrong type, or installed wrong.

Feb 24, 2008 | Kenmore 28075 Bagged Canister Vacuum

Not finding what you are looking for?
Electrolux UltraLux 2000 Bagged Canister Vacuum Logo

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...