Question about Hoover U5180-900 Vacuum

1 Answer

Hoover Fusion U5180-900

I purchased a Hoover Fusion U5180-900. It powers on and off great but there is no suction. I have checked all the filters and checked for blockage in all hoses. What else can I try to fix this problem.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 247 Answers

Double-checking for blockages in the hoses (if necessary by making sure you can poke a bit of wire through them) still has to be a good next move. Next, follow the path the sucked-in air is meant to take, checking for leaks (best way to do this is to run the machine an listen for loud sucking noises). Likely causes are things not put together right, controls set wrong,hoses not properly attached to their couplings or missing seals. If none of these things, and it is new, I'd take it back to the place you got it from and get them either to show you why there's nothing wrong with it, or to replace it. A

Posted on Apr 26, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My vax pet Hoover has lost its suction I've emptied it there's no blockages and Iv cleaned the filter


first, if it has a hose check for being plugged, you may have to take the vacuum apart further till you reach the fan on motor which may have hair,lint,etc wrapped around it which can cause low suction.
Checking for Blockages in Your Vax Upright Vacuum Cleaner
press helpful button

Jan 09, 2016 | Hoover Vacuums

4 Answers

My carpet shampooer will not **** the water back up. It is a Hoover Steamvac Deluxe 1600.


Hi,

Check the filters, make sure they aren't clogged. Also if this has the foam filter on the inside of the tank lid, make sure it has at least a 1/4 is gap from the top.

Jun 18, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

My Hetty Hoover has no suction, but when I take the filter out it has suction Please help!


Throw away your old filter if it is not cleanable. Only clean it if it is a washable filter. If not, buy a new one

Dec 10, 2014 | Hoover Vacuums

1 Answer

The Hoover switches on and the brush rotates but the actual Hoover doesn't come on?


Hi, is there suction when you open the top of the wand handle?

If no, have you emptied the container. next check the tubes that are removable, you may find there is a blockage of hair and bits, have you removed filter and given it a goos wash.

Jun 04, 2014 | Dyson DC25 All Floors Bagless Upright...

1 Answer

I have a Hoover Windtunnel UH70212. Just a few months old. I used the attachments a while back and now there is very little suction. The power brush attachment doesn't work at all. Any suggestions?


If there is no suction, there has to be a blockage somewhere in the dirt path. You should hear the motor working a little harder in this condition. Please check the entire dirt path from floor to exhaust (clean all filters too) to find the obstruction.

Thanks for your question @ FixYa.com

Mar 13, 2011 | Hoover U8341-900 WindTunnel 2 Bagless...

2 Answers

I have a Hoover Wind Tunnel Self propelled 12amp. There seems to be very little suction. I have cleaned the hoses and filters but still not much suction. any ideas? thanks.


Make sure all filters are cleaned out and entry ways are clear of all debris. Remove hose and check for blockage. Usually the low suction can be remedied when all filters are cleaned. Hope this works for you.

Jul 17, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Just bought this Hoover Fusion vaccum used, cleaned it up, checked belt and filter, turned it on and is extremely loud, almost like a scream. Any idea what could be causing this and how to fix?


Loud noises from this model are caused by dirt build up on the suction fan mounted directly to the motor. Under the dirt cup there is a filter screen that should have a foam filter insert, when not used or cleaned properly allows dirt to get into the motor. Cleaning is the best option. Although if you are inclined, you can take it apart or take it to your local deaLer.

May 01, 2010 | Hoover Fusion Plus Cyclonic Upright Vacuum...

1 Answer

My suction blocked light keeps coming on my Hoover Whisper vacuum. I've check all areas and can't find a blockage.


Remove the filter bin and open the compartment pictured under it. You probably need to wash the sponge filter per the manual. It fixed the problem for me and doubled the suction.
11_21_2015_8_26_34_pm.jpg

Feb 07, 2010 | Vacuums

2 Answers

There is no suction


check for blockages and clean your filters

Jun 24, 2009 | Hoover U8171-900 / U8172-900 / U8173-900 /...

Not finding what you are looking for?
Hoover U5180-900 Vacuum Logo

Related Topics:

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...