Question about Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED 2 HP 115/230V

1 Answer

Magnum Force Jacuzzi Pump stopped working

The pump is connected to the waterfall by the pool. Are there any maintenance/troubleshooting guides for it?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

No serviced by pool technician. But you can look in your breaker box for a popped breaker, it should be 20 amp and be positioned in the middle instead of on or off position. Kirk

Posted on Feb 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The waterfall is not working. How can I fix it?


To give you some advice about how to fix your waterfall probably you should specify your equipmente.
Now, without knowing a word about your system I guess the problme is the motor of your pump. If you have no experience repainng the electric board of a pump you should call an authorized repairmen

Jul 08, 2015 | Pool & Spa

1 Answer

Carvin jacuzzi water pump troubleshooting


How long from the last working of that pump?
Was the Pump stored? unused?
Disassembly and try to make turns the shaft and see if it is Blocked.maybe the bearings are with water and it is rusted.
If the bearings are rusted, the mechanic seal is damaged,you need to change it and the bearings.

Sep 01, 2014 | Carvin Pool Equipment Complete pool pump...

1 Answer

Spa waterfall isn't flowing


If you turn the valve to operate the waterfall feature on your spa and no water is coming out of it, my best guess would be the valve is broken and not turning to allow the water to go to the waterfall.
Pull the top of the valve off and look inside for a broken part.


Rod
US Parts Center
888-521-6183

Feb 11, 2013 | Pentair IntelliFlo VS-3050 & VS+SVRS...

1 Answer

Jacuzzi J315 spa waterfall lights flickering.


A flickering light would indicate a short in a wire some where along the way.
You will have to look at each wire until you find the short.


Rod
US Parts Center
888-521-6183

Feb 11, 2013 | Pool & Spa

1 Answer

Replace waterfall in hot spa


possible bad relay for waterfall or pump to waterfall

Feb 05, 2013 | Dream Maker Spas Dream Maker Ez Spa Hot...

1 Answer

My jacuzzi magnum force pump is hot is this normal?


the pump is pumping and circulating hot water into jacuzzi, it will get hot. I think it is ok

Jul 06, 2012 | Jacuzzi Magnum Force Series Pool Pump 1...

1 Answer

Jandy Aqualink waterfall pump won't turn on.


with off go to back of motor take off cover try spinning by hand if ok then make sure aux plug is connected for waterfall make sure voltage to relay careful either120 volt or 220 volt if voltage to relay see if voltage to motor if voltage to motor bad start up capacitor

May 07, 2012 | Jandy AQUALINK RS TELELINK KIT

Not finding what you are looking for?
Jacuzzi MAGNUM FORCE POOL PUMP - TWO SPEED 2 HP 115/230V Logo

360 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jacuzzi Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1368 Answers

Mike

Level 3 Expert

4345 Answers

john h

Level 3 Expert

12744 Answers

Are you a Jacuzzi Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...