Question about Kenwood KAC-X501F Car Audio Amplifier

1 Answer

Amp trouble I noticed that one of my two subs wern't working, so i checked the + and - wires, and they were fine, and I noticed that one of the rows of lights on the top of my amp wern't lighting up, so i replaced the fuses, and still the same problem. Do you think i may have blew a channel on my amp, or do i need to replace it thanks

Posted by on


1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

You proberbly just blew that channel on your amp, maybe you should just take it in o a sound shop and ask them to fix it, the problem shouldn't be big enough for you to throw away the amp...

Posted on Aug 15, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Protect Light On Amp Being Weird

Could try switching right and left subs. If the problem moves to the other side pull the wiring and redo.
Then if the wiring is ok check the sub.

May 15, 2013 | Jensen JPA600D - 600 Watts Digital Mono...

1 Answer

Hit bump and subs and amp wont work

Loose wire or connection is causing stereo to short out, Check all connections including amp,Stereo,Speakers and make sure nothing is touching places it shouldn't

Jul 29, 2010 | Jl Audio Class D E1400D Car Audio...

1 Answer

I have a Pioneer 5400t amp hooked up to a 10" 400w sub of unknown brand. The system was working perfectly for about a week, then I noticed the sub wasnt working. I blew both 30a fuses on the amp. I...

Your best bet is to buy a cap. A capacitor is an external battery booster like device. It boost power to amp. The thicker the wire the better. Power and ground. Shorter thicker ground wire the better. Make sure it is not on a painted surface. Scrape down to metal surface!!!!

Nov 12, 2009 | Cars & Trucks

1 Answer

I have a Pioneer GM-5300T amp wired to a 10 inch kicker sub. The music plays throughout the speakers of my car but the sub goes in and out. I noticed that the amp's power light dims when the sub goes in...

Hello pburgfootbal,

You do not specify which Kicker sub you have or how it is wired to the amp. The GM-5300T is only stable to 4ohms in bridged mode and if your sub is a 4ohm DVC with the coils in parallel, it presents a 2ohm load. If the sub is 2ohm DVC with the coils in parallel, the load is only 1ohm. Either configuration would be too low of an impedance for the amp in bridged mode. I'd check the sub specifications and make sure that the wiring configuration properly matches it to the amp.

Hope this helps.

Jul 31, 2009 | Pioneer GM-5300T Car Audio Amplifier

1 Answer

Subwoofer buldging out problem

When speakers are wired in the wrong way the will do the "pushing out" you're describing. Basically the polarities have been reversed and if kept like this over a period of time will blow the speaker. Best thing to do is to disconnect the power by the negative on the amp and take out the fuse from the power supply. Check the wires running from the amp to the subs, negative to negative and positive to positive. I know it sounds basic but many people do mix it up! I would also check to see what channels the subs have been wired into?

Best way is to have one sub from channel 1 and the other sub from channel 2 for example. Or if its a bridged 4 channel amp, have 1 sub running from channel 1&2, and the second sub running from channel 3&4 still making sure of the polarities. Again this all depending what kind of amp and sub you have.

For example;
A 4 channel (bridged) 1000W amp. 250W max per channel or 500W per 2 channels! So if you have 2 500W subs, by connecting one to a single channel will decrease subs ability due to the lack of power supplied. However by combining 2 channels you optimize the output!

Once you know all your wiring from your amp to subs are ok/good connections/good wires etc you shouldnt have to "wiggle the wires" to get it to work as this is just a bad connection. Also ensure that no 2 wires are touching. Make sure that the master volume on the amp is turned down. You dont need this to be on loud at all, in fact far from it or you'll risk damaging both the amp and subs!

Hope this helps!

May 27, 2009 | Car Audio & Video

1 Answer

Amp doesn't come on

Hello rheabarb,

You did not say whether or not you checked the wiring going to your subs. Many times, a shorted or grounded speaker wire will cause an amp to fail. And if the amp powers up OK with the subs disconnected, I'd suspect one or more of the wires.

Hope this helps.

May 19, 2009 | Clarion APX1300 Subwoofer Mono Amp - 300W...

1 Answer

Kicker zx750.1 Amp in Protection Mode (Red LED)

My kicker amp zx1500.1 keep going in protection mode I unhooked the sub speak wires and put the ACR cords back in and it didn't go in protection mode what next

Mar 18, 2009 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

Alpine type-r 2ohm dual voice coil help

try reconnecting your rca's from the deck to the amp when finished wire one speaker positive to positive on left channel and negative to negative on right channel then connect the 1st subwoofer. if all power and sound is fine and working turn off power to amp and connect negative terminal of 1st sub to positive on 2nd sub and positive from first sub to negative on second crossing the wires runs the speakers in series another way to try is parralel the speakers wiring by connecting positive left channel output of amp to positive on 1st sub same with the negative then splice positive to positive on second sub and same with negative.

Feb 09, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

1 Answer

Problem with amp...

In virtually all instances where the protection light is illuminated, the amplifier has gone into protection because the output transistors are shorted. To eliminate external wiring problems do the following.

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still goes into protect, the amp likely has blown output transistors.

If it does have blown outputs, it's is likely due to the speaker wires shorting together when the woofer was out of the vehicle.

Dec 29, 2007 | Jensen XA4150 Car Audio Amplifier

1 Answer


Check your ground wire! Relocate it to another place in the car and try to get a heavier ground wire aswell.

Apr 03, 2007 | Sony XM-2200GTX Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-X501F Car Audio Amplifier Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers


Level 3 Expert

78010 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides