Question about Alpine MRP-M650 Car Audio Amplifier

1 Answer

I have a mrp- m650 and will not put out any sound

So I swapped this over from a previous vehicle and it was working at the time, now that i have it in my other vehicle I have no sound output. I have rechecked all wiring and I have 12 v for power, I am only running a 16 gauge for remote but thats what I had last time, and my ground is good b/c the light comes on. The only thing different is that I am running the rear speaker input rather than RCA's b/c I wanted to keep my factory deck.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

USE A HI TO LOW CONVERTER A GOOD ONE BUT ALSO MAKE SURE WHAT KIND OF FACTORY SYSTEM IS THIS BEING HOOKED UP TO BECAUSE IF THERE IS A FACTORY AMP GET THE SIGNAL BEFORE THE OUTPUT

Posted on Dec 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My mrp m650 alpine amp power light is on but no sound. it works if i hook it to other vehicles but not in mine.


Check your speakers and speaker wires to make sure you have no shorts or grounds. Not knowing what vehicle you are putting the amp in, there is also a possibility that there may be a stock amp in the vehicle. If this is the case, you may have to rewire the speakers and bypass the stock amp.

Feb 27, 2012 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

How many watts does this amp put out


50 watts RMS x 4 at 4 ohms (75 watts RMS x 4 at 2 ohms)
150 watts RMS x 2 in bridged mode (4-ohm stable in bridged mode)

Feb 19, 2012 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

When i turn my alpine MRP-M650 amp on there is a click in the sub and then nothing else. when i was driving with volume down low the sub just stopped working.


sounds like a short. did you check the amp fuse and the fuse on the power wire (under the hood) make sure there are no wires touching. most common is the wires to the sub touching on the amp. let me knwo if that helped

May 17, 2011 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Will it push 2 alphine type rs


no it could one 12 but no 2 and def not a 15 when mach speakers to a amp you want to mach up the rms power you want to amp to put out enough to power bolth speakers so like 2 500 watt rms you would want a 1000 watt rms amp

Apr 01, 2010 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Subs dont work when base is up high


Sounds like the amps needing more current available to it-You should have 4 gauge power coming off the battery going into a distribution block from there a 4 gauge to a 1 farad capacitor off the block -4 gauge to the ground for the capacitor -and two + leads from the block to your amps-you would do well with 6 gauge there.- That is to ensure that you have plenty of power on tap when needed and not trying to draw it off your charging system on heavy current demands.Make sure that your grounds are well placed and solidly connected. As for putting 600+watts on a pair of 8z......i hope that they are the CVR or the L5 / L7 series to take that much power,I've seen it done and the ones i heard sounded badass(L7 series)-but that was at the stereo shop so they had they stuff on HITTN status up in there. If your running the "cvr" or the "comp" series you might be throwing too much power on them -might want to step up your subs to a set of 12s just to get more air moving in there- good luck

May 28, 2009 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Problems with MRP-M650


as far as it staying on it may have been wired to your hot unstead of your remote on your radio

when it runs wide open it gets hot
how are your gains

I have an alpine and I just hooked up jl 12 w3s and it kinda j did what yours did
it played.. hit hard then no subs.. my mids and highs platyed, but until I would turn off the car and restart the radio the subs immediately came on and the subs are only connected to this aplpine mrp m 650 amp

what speakers and what ohm did they wire it too?

i think my problem was I was overloading my amp feeding it a 2 ohm load or a one ohm load and it was shutting down my subs.. protectection I suppose?


Jun 02, 2008 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

MRP-M450 puts out no sound to the subs


The amplifier may be overloaded, check to see if it can handle 4 OHM loads and 2 OHM loads. if it turns off at high volume the amp may be overloaded. if so try a 8 OHM load. if it still turns off it may be an internal problem.

Jan 07, 2008 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Alpine MRP-M650 : Power LED turns on but no sound. All the connections are made. Subs have been tested on another amp.


is the remote lead properly connected to the head unit? if the power led is on then the power cable and earth must be good, check the remote lead 2 your head unit first, if thats all good try looking at the amp to see whether theres a small switch to adjust the output going to the subs, if its very low or right off then nothing will be going through to the subs. if its on high and fine it only realy leaves the neg and pos inputs from the amp 2 the subs.

cheers, adam

Oct 30, 2007 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

Alpine MRP-M650 problem


The built in power supply is probably bad. This supplyds the voltage from the 12volts and inverts it up to 20 to 30 mvolts DC. You will need to get a manual to service this unless you know the inverter circuit really well. good Luck

Jun 30, 2007 | Alpine MRP-M650 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRP-M650 Car Audio Amplifier Logo

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jaime Hernandez

Level 3 Expert

2296 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...