Question about Kenwood KAC-X401M Car Audio Amplifier

2 Answers

Kenwood excelon kacx401m

When i power the amp it plays for about 1 second and then the power indicator starts to flash, and there is no sound. can u tell me what the problem is. it's also missing the power slide door, could this be the problem? it worked when i first hooked it up but now it cuts out immediately. any info would be greatly appreciated

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: kenwood excelon kacx401m

Actually i have the same amp and the power connector was bad and was blowing fuses. It was a bad solder joint. I took it apart and gooped it up with more solder and now it works like a champ. I tested the resistance on the connectors and the power cable had more than the rest. Not sure if this is the same problem you are having but it worked for me.

Posted on Oct 12, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert whose answer got voted for 20 times.


    An expert who has answered 20 questions.

  • Expert
  • 84 Answers
Re: kenwood excelon kacx401m

Sounds like an overload, amp switches on, can't get enough juice and switches off. Get a friend with a volt meter to measure the voltage at the amp power terminal as you turn it on, if it drops below 10.5v the amp hasn't got enough juice. Some amps can cut out before the fuse blows, so you never know it's an overload. I'm not sure what you mean by a 'power slide door'

Posted on Apr 24, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Kenwood excelon x1r red light blinks

You've got a faulty amp there. The blinking indicates that the output stage that drives the speakers are shorted, most likely due to running too low of an impedance off the amp and it shutting down continuously. The Output stage would need to be replaced by a tech as they are soldered onto the PCB and thermally coupled to the aluminum chassis internally.
Unfortunately there are no resets you can perform, or anything else besides component replacement on this amp.

Nov 12, 2013 | Kenwood Excelon KAC-X1R - 2400W 1-Channel...

1 Answer

Red light is on and subwoofers dont play but regular speakers play

when you say redlight is on it isnt very clear as the power light for the amp is red...right above the cooling fan are 2 indicator lights and if either of them is on your issue can normally be addressed by faulty wiring, you may have wired the speakers at at an ohm load the amp isnt made for which over time will blow the amp if not right away. Also if you dont have inline fuses and such setup i the system then something as simple *** a power surge could have blown the amp...again since the power indicator(red triangle in the center of the amp) is red it could always be that your head units RCA outputs are bad if you have any hooked up at all.

Sep 06, 2010 | Kenwood eXcelon X1200M Car Amp

2 Answers

My subs/amp are not working

when you car is running, it charges the battery somewhat. So the voltage problem is not a problem. The red light means the amp is going into ''Protect Mode". This usually happens when something is wrong with the amp. Usually the amp is getting hot. Check all of you connectiong and check the final impedance of the subs. Make sure the amp can handle the impedance of the subs. If you need anymore help, message me.

Feb 12, 2010 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

On a kac-x650d does the power light stay on or flash

Hello mpredday,

The Kenwood Excelon KAC-X650D power light is ON during normal operation. It blinks blue to indicate BMS selection, yellow for low voltage, purple for DC voltage on the outputs, red for overheating, and green for a shorted or grounded speaker wire.

Hope this helps.

Jul 29, 2009 | Kenwood Car Amplifiers

1 Answer

Blinking E-03

somthing is fried on your motherboard

Apr 28, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

No sound flashing e-02 in window

Turn power off this will release the protection turn power back on if code is still flashing contact kenwood dealer

Jan 04, 2009 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

Kenwood Excelon KAC-X812D mono amp

Right next to the rca inputs you will see a reset switch, Reset the amplifier by holding that switch in for about 20 to 30 seconds. This amp has a microprocessor in it that controls the fan. The LCD display that you played with only shows the status of the fan, it does not control the fan. the fan should turn on when the amp starts to get hot. It operates at high or low or stop. If the fan never comes on, even when the amp is very hot, you will need to take it in to be serviced. There is no easy fix to some of the problems. You need the fan to work, so check it out soon and determain if the fan ever comes on. It may take a while to come on, but if it comes on after it starts getting hot, it is working.

Jun 17, 2008 | Kenwood eXcelon KAC-X812D Car Audio...

1 Answer

It comes on but

I believe that the amplifier is in protection mode; more than likely you either have an internal short in the amp or a bad speaker running off of the amp.

Jun 06, 2008 | Kenwood eXcelon KAC-X812D Car Audio...

Not finding what you are looking for?
Kenwood KAC-X401M Car Audio Amplifier Logo

Related Topics:

411 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1333 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides