Question about Electrolux UltraLux 2000 Bagged Canister Vacuum

1 Answer

? light come on no power

? light come on but vac. does not come on

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 128 Answers

You motor might be broken
this is the only thing i can think of unless your motor is not getting power
this could be a loose wire
if the light is comming on then the unit its self has power

hope this helps:-)
ricko

Posted on Dec 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The panasonic EComax light rollers not turning , belt is fine. filters are fine.. and even with power on nothing happens. switch is on carpet mode.


"belt is fine" . Not likely. Belts need replacing yearly. Just because it isn't broken doesn't mean it's working properly. Most vacs should be serviced annually. Take it to your local vac shop for service.

Oct 26, 2014 | Vacuums

1 Answer

My central vaccum just stop working last night. It does not turn on at all.


I've gone through 3 vx475 vac in the past 7 yrs. Last one was sent to me in Apr 2010. Just yesterday, once again, my vac just quit. Green power light is on but no other sign of anything. Had a burning smell when vac quit, like motor just fried. Called Nutone again and they can't imagine whats going on but will send out another vac free and was told to throw out old one. They said dust may get into the motor and cause it to quit. These vacs aren't cheap, can't imagine that its so simple to just call up and have a brand new one sent to me. I've asked if they are rebuilt units and was told no. So my advise to you, if you haven't already, is to simply call them up w/model and serial # and they shouldn't give you any prob. good luck.

Sep 03, 2010 | Broan-NuTone VX475 Bagged Central System...

1 Answer

I have an electolux [ lux classic] vacuum cleaner, and there is no power to it. I think it is a loose wire, as it was tempermental before. I can't find a way to get into it to see if it is a wire


Does the green power light located on the top of the vac come on with the cord plugged in the outlet ? If so your switch could be bad. If not, you could have a bad connection or a broken wire. Caution ! If you do get into the vac, you can cause more damage to the vac. Is the vac more than five years old. If not, your vac is still under waranty and you should get it fixed for free. Take it back to you Aerus/Electrolux shop. You can find out if the unit is still under waranty by calling the customer service with the serial number. They can tell you. 1-800-243-9078.
If you still want to get into the vac (which I do not recommend) let me know and I will tell you.
Joe

Nov 15, 2009 | Electrolux Vacuums

1 Answer

On my kenmore central vac no power unplug unit plug it back green light comes on but try turning vac on green light goes off again .


Please clarify that we are talking about the central vac LED/switch panel panel and plugging it into a 110 V wall receptacle.
If I understand when you unplug from the power source ,then plug back in the green LED comes on, looking normal ? But when you manually activate the switch on the motor housing of the vac itself the vac does not start and the LED goes out, so no green or red LED at that point?
If this is the case , Kenmore CV's built approx 5 years ago (MADE by EUREKA) and prior had a circuit board with attached cord (as opposed to detachable) which was prone to relay failure. There were several symptoms, most common was that the relay on that switch panel /circuit board would fuse on and the vac would continue to run when the hose was detached from the wall.However some I worked on from that era had exactly the same symptom you describe. If your unit is between 5 and 10 years old and this sounds accurate, you can unscrew this curved side panel relay with one philips screw. Inside on the PCB will be an L shaped black or white 24volt relay, generally rated at 10 amps. The replacement board or relay will be rated at least 24V/ 15 amps or more. If you can isolate your motor and test it separtely with a power cord or meter , the realy/board will be the only control componnet left.
If you have a small tipped soldering IRON, not a gun, you can generally find a replacement relay to rebuild the board for about $6 at an electronics parts store. Otherwise you will need to replace the control board itself, anywhere form $45 to $70 plus service call if you have a tech come out to the house, and the tech will just unscrew , detach wires and replace the board, no repair , approx 15 minutes work. This will likely cost over $100.
Please post back with your results

Oct 24, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

The beater of my kenmore vacuum won't turn on - the primary light goes on but none of the sensor lights go on.


Kenmore vacs generally have three male contacts at the machine end.Internally when the hoses swivels these contacts run on three brass rings which can also get dirty due to proximity to dirt. They can get dirty or dirt can fall into the corresponding female socket where the hose meets the vac. If you have just changed the bag inspect these connections near the intake port on the vac.
The working LED means you have a partial connection. Also try wiggling and twisting gently at the handle of the hose and where the wand connects to the hose and the power head elbow... you have 4 connections between vac and head

Sep 06, 2009 | Kenmore 22812 Bagged Canister Vacuum

2 Answers

Need to replace belt on beater brush


If you press on either side of the raised top light cover it will come off. Then you will be able to see the light bulb and two screw heads. Remove the two screws and the top cover of the power brush will lift off and you will be able to access the belt. You can find this belt at www.vacbelts.com.

Jul 01, 2009 | Vacuums

1 Answer

Central Vac will not turn on.


These problems are nearly exclusively caused by a bad circut board and replacing it is the fix. Bad boards can cause many different effects so its nearly impossible to be sure. The 9v signal wire is not enough to short out an entire unit so it is unlikely the hose. If it is a direct connect system and you are pulling power from the 110 somehow that would cause main unit problems but that is unlikely at best. Sounds like a failed board to me.

Best of Luck

Jun 04, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

I need to know how to change my kirby into a blower?


Raise the light assessory on the front of the vac. Remove the roller assembly by rotating the square dial as indicated by the arrows. Then you must attach the accessory that sort of looks like a 4 inch square open box to the front of the vac where you removed the roller assembly and lock into place. Next you remove your bag assembly by unsnapping at the top of the handle to the vac, then at the base of the bag assembly you must unlock the plastic base from the metal vac unit by turning it counter clockwise and then pulling off. Finally you attach the hose assembly where you removed the bag assembly and lock into place by turning clockwise (reverse of taking off bag assembly base). Put vac in neutral and power on. Now you will blow from the hose assembly.

Apr 20, 2009 | Kirby G4 Bagged Upright Vacuum

1 Answer

Electrolux Z8240 Cyclonic Bagless Vacuum Cleaner


Be sure to check the hose , wands and power brush for obstructions as well.
If there's a burning hair electrical odor then it might be toast.
i despise bagless vac's as they always wind up being more maintenance and expence then bagged vac's.

Good Luck and let me know what you find out.

Oct 08, 2008 | Vacuums

2 Answers

Power nozzle not working on my vac but does on another vac


Is there a reset button somewhere on the power nozzle? Most of these have a breaker to prevent the motor from burning out.

Feb 08, 2007 | Electrolux UltraLux 2000 Bagged Canister...

Not finding what you are looking for?
Electrolux UltraLux 2000 Bagged Canister Vacuum Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18330 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...