Question about Mach Speed (S755) Motherboard

2 Answers

Viper MSNV-939 ATX Socket 939

Hey i recently purchased a Viper MSNV-939 ATX Socket 939 mobo and i cannot even load in the BIOS. I dont have a intergrated graphics card so i purchased a brand new X1300 PRO Radeon card. The screen is left black, no beeps from the mobo, but RAM [2gig] is brand new too.... I just need a way to boot up and load in the BIOS.

Posted by on

2 Answers

Re: Viper MSNV-939 ATX Socket 939

Make sure you've connected a power connector to the video card.

Posted on Jan 14, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 2,961 Answers
Re: Viper MSNV-939 ATX Socket 939

I assume you have tried with only one stick of ram individually at a time if you are using two to check it's not the ram as one faulty can cause the system to stop. Also assuming you bought the ram from the same place and is compatible with the board. Sometimes people also forget that the processor in some cases has to be powered by the 4 pin plug from the PSU and not just from the ZIF socket that older processors use to power up, so double check the manual. The other main common cause of the this problem is when you are putting together all the hardware onto the board, if you don't protect it underneath it may have overflexed the board and shorted or damaged the circuitry or the bios chip. That's not to say that the motherboard was'nt faulty in the first place.

Posted on Apr 18, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

How many graphics cards can you run on this motherboard ? also whats the maximum ram you can install on it ?


You may install 2 x PCI-Express X 16 slot, supports two PCI-Express interface Graphics cards with SLI mode and 4x1Gb Dual channel DDR400/ 333/ 266 -184pin RAMs onto your AMD Gigabyte GA-K8N-SLI nVidia nForce4 SLI Chipset 2000MT/s FSB Dual Channel DDR400 Socket 939 ATX motherboard.

Check out your motherboard's specifications through this LINK.

I hope this works for you. Kindly reply/comment for further assistance. Good Luck!

Thanks for using Fixya!

DELL Tech ID #456563
TIPS: Is your computer slow? This might help
(for Windows only)

Apr 09, 2011 | AMD Gigabyte GA-K8N-SLI nVidia nForce4 SLI...

2 Answers

What pcu

Both the K9AGM2-F/L and the               K9AGM2-FIH model both take the (AMD) AM2 socket CPU just like is stated on the box.

Feb 08, 2009 | MSI K9AGM2-FIH - Motherboard - micro ATX -...

2 Answers

Lan ports dont work

Where you able to check the Network adapter on the Windows Device manager?

How to verify your Network card is working properly

If you are unable to resolve the problem with your intergrated lancard then you can add additional LAN CARD on your computer or you can also buy USB to LAN CARD adapter.

Mar 07, 2008 | ASUS M2N32-SLI Deluxe/Wireless Edition ATX...

1 Answer

Very slow booting

If you're going to plug-in a video card you need to turn off the onboard video chip. Otherwise It sounds like a cold problem, you could heat areas of the motherboard with a hairdryer to find out..

Oct 18, 2007 | Mach Speed (MSNV-939) Motherboard

1 Answer

Consistent hard Drive BOOT ERROR after an upgrade to MSNV-939 motherboard

You can run a disk manager for your drive however, I'll bet you will find its windows boot.ini. It may read just fine for a dual boot system but think about this. Windows can get confused real quick. I'm talking about the regestry. Take the time and do a fresh install of your Linuex and than re-install windows "clean install". I'll bet everything works out just fine. When 1 changes MB's there is a whole list of new drivers PCI devices loading into windows. Your system will run better with one copy of drivers for your new board and windows will not carry a list of old drivers and PCI devices of your old board.

Oct 17, 2007 | Mach Speed (MSNV-939) Motherboard

1 Answer

Viper MSNV-939 ATX Socket 939 audio connector jumper settings

 u short the pins with jumpers as per the diag

        5    4     3    2    1
       10          8     7    6 

in this u short the   5,10  with one jumper &   3,8 wth another jumper  

was this helpful to u, give the rating for me


Oct 15, 2007 | Mach Speed (S755) Motherboard

5 Answers

No boot on start up all fans start but no video

I had same problem!
I figured there was something wrong with my memory because that is what the manual says the constant beeps mean.
I bought a new PNY memory stick 1 gb DDR and got the same beeps when i put it in.
So being totally disappointed I tried putting the Stick in the #3 DIMM. I booted up and IT WORKED!
I have not called tech support or tried both 1 & 3 DIMM together but I will try after I set up the rest of my computer.

Sep 03, 2007 | Mach Speed (MSNV-939) Motherboard

Not finding what you are looking for?
Mach Speed (S755) Motherboard Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mach Speed Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers


Level 3 Expert

56798 Answers

Are you a Mach Speed Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides