Question about Hifonics BX1500D Car Audio Amplifier

1 Answer

Hifonics 1605d stopped working

I have a hifonics amp 1605d. It was working good for about 2.5 months. Till yesterday it jus stopped working. it then started making the subs make a loud rattling noise. So then i unplugged the subs from the amp then turned the amp back on and the red light jus started blinking

Posted by on

  • Anonymous Mar 15, 2014

    hifonics amp no power to subs

  • Anonymous Mar 16, 2014

    Power seems to be going to teh amp but noting coming out to get Subs to work. worked fine Friday morning but not working Friday afternoon. Has been working for almost 3 years now

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

The red light blinking because your amplifaier its dead look for the alimentation cabel end replace the calibration protector

Posted on Apr 16, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Will hilfonics brutus 2010d mono work??


Well with the correct powering system, heaps of paralleled 12 volt Batteries, & a Beefed up Alternator to charge them, I guess so, BUT it is only Mono, so you will need TWO to provide stereo output

Mar 06, 2010 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

I got all power from my hifonics amp but no output. everything is hooked up correctly was working but all of a sudden stopped


check to make sure your rcas are good, check to make sure all your connections to your subs are good and if they are most the time this meens your pre amp in your amplifier is out.

May 04, 2009 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Cant get protect mode off on amp


you burned up a couple of dioeds if if wnt go back to a regular mode

Apr 01, 2009 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Knobs on amp!


Hi loredo.
Hifonics are outstanding amps.
I would need a complete description of your system ( or your system to be) including High quality pictures of all amp connections and controls followed by a chat or preferably a phone call.
Let me know, and if you ever want to get rid of that amp..........
Regards Paul

Jun 05, 2008 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

No output


Maybe you should check your remote wire!

Apr 16, 2008 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Think my amp might be fried!!


if the connections is good,then you have no out,then the problem is inside the amplifier,you must refer a qualified personnel near you
to open your amplifier.

Feb 21, 2008 | Hifonics Brutus BX 1605D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Hifonisc bx 1605d


i think you could but before doing that did the amp itself send the output to the line if it did then replacing the parts would be pointless. if it was a hook up problem then replace parts and don't let it happen again

Dec 15, 2007 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp


well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

Not finding what you are looking for?
Hifonics BX1500D Car Audio Amplifier Logo

Related Topics:

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1165 Answers

Jaime Hernandez

Level 3 Expert

2337 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...