Question about Hasbro I-DOG AMP'D

1 Answer

Won't turn on even after new batteries and reset

Just gave my daughter I-Dog amp'd and it was working fine in the store. Now that she has it opened it just stopped working; put in new batteries x2 and then tried resetting it as well; still nothing. Should I just give up and take it back tomorrow??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Did you turn the switch near the front legs? Press his nose and rub his nose. The tail is the volume and move it front to back.

Posted on Dec 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Robopanada wont turn on


hi i bot robopanda sec hand and he was working fine untill i put new batterys 4 rayovac 4.0 aa batterys it worked just two seconds the everything whent dead and i,m unable to start him agine i even pushes the reset button im so un happy about this please please help me martin.

Dec 28, 2011 | Wowwee Robopanda Robot

1 Answer

My son got an MP3 boombox, by discovery kids, as a gift for christmas. It will not work at all now. Even with fresh batteries. Can we get a new one?


Tell the person who gave you the gift, It might be embarrassing but if you want a new one and actually get something from the money spent, tell them that it doesn't work and you would like to exchange it at the store. If you really don't want to ask the person or the person is not available, go to the store you think is the most likely place they got it from, with the Boombox and tell them you got it as a gift and want to return it, some stores will allow an exchange something even without the receipt.(If it wasn't bought at that store, try again at another store) Lastly, you can contact Discovery Kids Costumer Support if you still need help.

Mar 01, 2011 | Dolls, Playsets & Toy Figures

2 Answers

My daughter's mobigo won't turn on even with new batteries


Here are some tips to try:

If your product has a "Reset" button, try using that.

Another tip. Try removing all of the batteries and holding down the "ON" button for about 45 seconds. Then replace the batteries (be sure they are fresh) and try your product again

Jan 21, 2011 | Vtech Mobigo Learning System

1 Answer

My sister gave my daughter her daughter's Butterscotch horse. When we started to put new batteries in, the old batteries were still in and battery acid leaked all in the battery pack. Is there a way to...


It all depends on the severity of the corrosion, but I have started with denatured alcohol and an acid brush. Do this over a plastic disposable cup. Let this dry and then try baking soda and water solution and see if it will cut the corrosion. I have Contact cleaner that I use then, if you have some where you can get that done. I use De-ox-it and again with a clean acid brush work it in.

Aug 10, 2010 | Hasbro Furreal Friends Butterscotch Pony

1 Answer

My idog will not turn on. i just replaced the bat...


Try plugging in your iPod and playing music worked for me and/or put new batteries in it but do NOT press reset

May 20, 2010 | Hasbro I-DOG AMP'D

1 Answer

Batteries-mio pup toy dog


On the bottom of each of the rear feet is a phillips-head screw. Remove the screws and you replace 2 batteries in each foot.

Mar 12, 2009 | Hasbro Oye Mio Pup - Pink White

3 Answers

Vsmile cyber pocket not working


Hi I'm ryan, try resetting it. Remove the battery cover, there should be a pin hole with a reset button in it. my daughters did the same thing and i just reset the system and it works fine.

Dec 25, 2008 | Vtech V.Smile Pocket

12 Answers

Our V-smile system will not turn on even though it is plugged in.


I got the system for my 4 year old daughter less than 2 weeks ago and it quit on me. It's rediculous! Anyway, at first we used batteries and it worked fine but the batteries went dead after she played it about 3 times so we went and bought the power cord. We plugged it in and it wouldn't work at all. I looked all over the internet trying to find a way to fix it because we also got her $100 worth of games and had already thrown away the box so we couldn't return it. Everyone was talking about a reset button and my system DOES NOT have one! I finally found a SOLUTION[most likely temporary] Take the batteries out. Hold the ON button down for 45 seconds, replace the batteries with FRESH ones and turn it on. Sounds like it won't work right?!? Well it did for me and before the game system would come on for NOTHING. Hopefully this helped! good luck

Nov 11, 2008 | Vtech V.Smile TV Learning System

Not finding what you are looking for?
Hasbro I-DOG AMP'D Logo

Related Topics:

289 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hasbro Dolls, Playsets & Toy Figures Experts

freddyfox

Level 2 Expert

236 Answers

Cindy Wells

Level 3 Expert

4756 Answers

ka4iup
ka4iup

Level 3 Expert

3944 Answers

Are you a Hasbro Doll, Playset and Toy Figure Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...