Question about Audio Technica AT-PL50 Turntable

1 Answer

I just got the turntable AT-PL50. Connected the red pin-plug to the right channel input and the white pin-plug to the left channel input of the amplifier. Seem to be getting noise when nothing is playing, and sound very distorted when record is playing.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 42 Answers

Your query incomplete. Please resubmit.

Posted on Jan 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Four wires coming from needle to cable, two are shield and two are left and right channels. Which color goes where


Actually it's not to hard to connect them. All you need is a stereo record where you know a sound of something is on the right or left channels. I use to have a Goodies LP where a one of them would say "bounce to the left" and the other said "bounce to the right" these coming on the respective channels.
To set it up just stick the red (right) on one of the cartridge pins and white - left on the opposite side - not underneath it. Then connect the other two to the pins below them. Play your test record. And if the sound which is supposed to be on the right channel come on the left - swap the two red and white wires around.
If the sound sounds (tinny spaced) out then swap the same side wires around.
So if you have say Red Green, Make it Green Red. If it is tinny only on one channel, don't switch the other channel around.
For example the right is tinny - do the above - but leave the other White Blue.
By the way some cartridges do have L and R marked on them and + and - for the channel types. " -" being for the green or blue wires.

Feb 08, 2014 | JVC Turntables

1 Answer

I have a Technics turntable Model: SL-BD22-KM, Ser.#: GF3Fc73813. The RCA and ground connection panel on the turntable has been jurked-out tearing the wires apart. I need to know which wires are soldered...


hi,
Here is the wiring of the turntable RCA plug ( RCA wire will have 4 connections like red and its outer wire then White and its outer wire.). connect these as follows.

For right channel

Red wire from the turntable to the red center wire of the RCA plug

Green wire from the turntable to the outer wire with red wire of the RCA plug

For left channel

White wire from the turntable to the white center wire of the RCA plug

Blue wire from the turntable to the outer wire with White wire of the RCA plug
OK

Oct 10, 2011 | Technics SL-BD22 Turntable

1 Answer

Which cables do i use for stanton str 8 30 the cables are red white with a grounded pit on them


HI, use both of them. The white one is the left channel and the red one is the right channel. The 3rd wire is a grounding wire. Cheers John. Styluscity.com

Sep 26, 2011 | Stanton STR8-30 Turntable

1 Answer

Need to know the wiring color placement for the cartrage to the head assembly. The four wires to the head. Thank you trail85@aol.com


Trial and error my friend. But it's easy to id the two main channels. First plug the turntable into the amp and with the amp on touch each each wire one at a time. One will buzz on the right, one on the left, the others are earths for either channel. You then attach them to the cartridge.
I can tell you my cartridge connections. But it might not be the same. Red - right, Blue earth right, White - Left, Green earth left.
You won't cause damage if you get them wrong, it just will sound ****!

Feb 20, 2011 | JVC Turntables

1 Answer

I have an Audio-Technica turntable (AT-PL50). I recently moved and when I hooked my turntable back up, the sound is terrible. It sounds distorted, similar to the sound of blown-out speakers. But, I checked...


it sounds like your cartridge is shot and damaged.
this turntable has fixed cartridge and only the stylus can be changed.

check out this manual: http://www.audio-technica.com/cms/resource_library/literature/0fb01429606842cf/at_pl50_om.pdf

Jun 20, 2010 | Audio Technica AT-PL50 Turntable

1 Answer

My Technic 1200's are only playing out of one speaker at a time.


Clearly there IS a setup issue. Take serrato out of the loop for the moment and the mixer. Plug each deck (one at a time) into a hifi with a MM Phono input. Are you getting stereo? If yes, you know the decks are ok. Now reset the mixer completey. All eqs and pans including volumes to 12 o clock position and volumes to 0.
Make sure you connect deck one to a red and white of one phono input channel. Do not use 1 channel from phono and 1 from line. Use both left and right of the phono chanels.
Ok, now hook up the mixer to the amp. Keep the x-fader on channel 1 and concentrate getting a good stereo signal from this one chanel. Now do the same for the other cahnnel.

This should hae helped you to get up an running, if not narrow down the problem.

Apr 18, 2010 | Technics SL-1200 Turntable

1 Answer

Sound only from left side speakers!


If you put the good channel from the deck into the right and then left phono imputs of your amp, the sound should come out from the left and right speakers. If it only comes out from the left, then the amp as a right hand channel fault. Now if other devices work on both channels, then it's the pre-amp for the phono socket that has a fault on it. You should be able to find this by following the wires from the phono socket. If you touch around that pre-amp you should get it to buzz on either channel (where it joins with the main pre-amp). Doing this with a screwdriver will pin-point where the faulty part is (working backwards). PS don't short anything by touching to bits of metal together with the screwdriver.
Magnetic cartridges need a small pre-amp before they can be past to the main pre-amp. That's why you can't hear anything with the deck plugged into another line socket.
If you get signal on both left and right speakers with the above test the deck is to blame.

Jan 11, 2010 | Sony PS-LX300USB Turntable

1 Answer

Sony PS-LX300USB Turntable, one channel not working


Have you tried swopping over the output leads from the turntable to the amp (normally one red and one white phono plug) so they are in each others socket? If you do this and you still get no sound from the right channel it is almost certain to be a faulty amp,or speaker.
If you swop and get no sound from the LEFT channel it is could be either a faulty lead or cartridge.

Apr 19, 2009 | Sony PS-LX250H Turntable

1 Answer

Sound very distorted


This turntable has a preamp switch on it, which is probably on and what is causing the distortion. Take off the metal record platter by lifting up on the two holes gently. Turn the pre-amp switch to 'off' and then try it again. This is probably it...

Or you can plug it into an input that doesn't have a preamp and that should work.

Dec 25, 2008 | Audio Technica AT-PL50 Turntable

Not finding what you are looking for?
Audio Technica AT-PL50 Turntable Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Technica Turntables Experts

 Grubhead
Grubhead

Level 3 Expert

4593 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you an Audio Technica Turntable Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...