Question about Koiiler XM-7676W Car Audio Amplifier

1 Answer

Wet Amp I spilled soda on my seat. the amp is underneath the seat and got into the amp a little bit. the amp still works but only with one of two subs. the second 10" sub does not even viabrate. inside the little window of the amp its fogged up. wat do i do or can i do is it the amp or the sub thats bad? its a 1000 Watt Koiiler amp.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

You probably too out an output on the amplifier. Will need repair.

Posted on Dec 25, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mounting amp to car


make sure you mount where you can get a good ground and where it can get enough air to keep cool. underneath the car seat is where a lot of installer put the amp, and if you are going power up a lot i would think about mounting a fan to blow air on it to keep it cool. i have fans connected to my laptop power supply transformer to keep the unit cool, here other ideas you will never be told, putting little holes around power supple, fan area, any where there a lot of heat is generated the air flow helps it stay cooler while powering up the amp.

good luck and be safe rod

Mar 01, 2014 | Volfenhag Car Audio & Video

2 Answers

My nitro bmw 486 cuts out when i turn the volume up alittle bit,subs start crackling and distorting turn volume back down sounds just fine amp doesn't go to protect mode still works 4 guage wire a


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D.A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-bmw-486-cuts-out-when-turn-volume-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Jul 20, 2012 | Nitro BMW-486 Car Audio Amplifier

1 Answer

I did install my amp on the back of my back seats. When the seat is down the amp dont work. then the seat is up the amp work! ground ?


Definitely check your wires, you don't want a short under the seats as it can also result in a fire. Also, if the amp is completely covered and there is no air circulation it will overheat and shut off. Make sure it's well ventilated.

Sep 20, 2011 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I have a 1000 watt sony explode mx-2165gtx and i have 2 12inch rockferd subs all hooked up in my truck. i turn on the sterio and turn it up just a little bit and it goes into protect mode i cant figure out...


Sounds like you're overloading the amp. Which rockford subs are they exactly? I can find the specs and see if theyre just too much for the amp or you just have to hook em up to the amp different so the amp wont go into protect mode

May 22, 2011 | Sony XM-2165GTX Car Audio Amplifier

2 Answers

I spilled soda in my car amp - can it be fixed?


Hello gene_lamando,

While it can probably be fixed, the cost may be more than it's worth. Liquid of any sort inside electronics will short out various components and cause extensive damage.

I'd recommend that you take the amp to a reputable car audio shop and have them check the extent of damage. If it is damaged beyond economical repair, just replace it.

Hope this helps.

Oct 31, 2009 | Car Audio & Video

1 Answer

Installed in my boat, got a little wet. power


ok,
connect your positive 12v of your amp to the remote part of your amp. youll see it will turn on.

Aug 31, 2009 | Sony XM-GTR2022 Car Audio Amplifier

1 Answer

Where is the factory amp on an xc90 located?? im trying to put in an aftermarket headunit..


Hello,

The factory amp is installed in a floor cavity underneath the seat.

Try this site for some pics of what it looks like:

http://forums.swedespeed.com/zerothread?id=61169

Hope this helps. If it does, please rate as "FixYa". Thanks!

Mar 27, 2009 | A D S Car Audio & Video

1 Answer

Rockford Fosgate P3002 Amp


what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Aug 22, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

Beer Spilled on my Power Acoustik PS2-820 Amp


Hi , now that you have the amp apart , just check the underside of the printed circuit board and check for any corrosion ,rub it with a soft brush . then try connecting without speakers . see if it still blows fuse, if it does then there is a likelihood that your mosfets / outputs may have shorted the first time you reconnected it . Good luck

Mar 21, 2007 | Power Acoustik PS2-820 Car Audio Amplifier

Not finding what you are looking for?
Koiiler XM-7676W Car Audio Amplifier Logo

Related Topics:

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Koiiler Car Audio & Video Experts

Robert marquette

Level 2 Expert

102 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

kakima

Level 3 Expert

98794 Answers

Are you a Koiiler Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...