Question about Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Amp will not power up at all

Today while I was driving to work, I lost all bass. I checked and my amp is no longer powering up, not lights what so ever come on. The amp is about 5 yrs old and so are the subs, I checked all the fuses and everything and all the wiring is in good condition. Could my head unit (which has been having problems) be causing this or is my amp more than likely dead? Thanks.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers
Re: Amp will not power up at all - Sony Xplod XM-1652Z Car Audio Amplifier Car Amplifiers

Check all power present.main,remote and gnd.

Posted on Aug 09, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Amp shuts off.

check the connection of power connection and the remote connection tone amp,you can check also you inside by using your hand ,turn on the amp and wiggle it the power connection parts.

Jun 15, 2013 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I recently purchased the mtx terminator amplified bass system and wired everything in, but the amp seems to not be working, i checked the power and the wires going in are a good circut but none of the...

If none of the lights are coming on for the amp then the amp is not getting power and/or ground. Check the connections. Check the fuses. Or the amp is no good.

May 05, 2011 | MTX Car Amplifiers

1 Answer

Remote bass control

there might be a hidden switch on the amp for with or with out bass control

Apr 25, 2010 | Power Acoustik GOTHIC OV2-1800 Car Amp

1 Answer

I have a 1800 watt amp but the red light is on but it dose sound like the bass works but not it its prime

the red light is for power in protect mode it should be orange and it will not emmit sound if you think you should have better sounding bass or more bass you can try to play with the gains on the amp or possibly if you have the negative or positive hooked up wrong from a speaker to the amp this will cause the bass to be lower and somewhat distorted double check your positive and negative wires from the speaker to the amp and make sure they are correct

Feb 28, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Amp burned out but fuses still good?

this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

3 Answers

Kicker zx 400.1 amp no power.. is it fried?

Well Friend, the chances that your amplifier is Fried are very low. First of all deactivate the Auto Turn On Feature on the Amplifier. Second, check that the voltage is received at the Power connector of the Lead that is coming from the Battery using the Multimeter to make sure that the Main Fuse is all right. If No Go, then check the Amplifiers fuses thoroughly. Then check if the Protection LED is lit. If it does not work after all of it, get it checked at any local radio shack as I'm sure, it cannot get fried just like that, as it is possible that some internal connection has fried or became loose and will be fixed without spending much. I wish it will help you..

Mar 14, 2009 | Car Amplifiers

1 Answer

No light on Alpine MRP-M1000

Ok. Have you check the Ground and the Power connection.

Jan 25, 2009 | Alpine MRP-M1000 Car Audio Amplifier

2 Answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP

Are you sure you don't have any shorted wiring or defective speakers?

Sep 30, 2008 | Jl Audio 300/2 Car Audio Amplifier

2 Answers

Powers on but no sound

Check the main amp fuse under the hood, even if it looks good just change it. Often times that light on the amp can come on just from the power amp tunon wire. Try a friends subwoofer box just to make sure the connectors on your box are good, and if that doesn't work then give me some more details....year/make/model of car, what kind of sub, what types of things do you see on the side of the there a green light as well as a red light?

Aug 18, 2007 | Xtant A3001 Car Audio Amplifier

3 Answers

Amp stopped working...

Has the amp been overheating lately? It's quite possible that the amp could have just blown. Smell around the outside of the amp for an electrical burnt smell. If available, see if a friend also has an amp hookup and try removing your amp and copnnecting to the friend's cables. That will tell you if it's a wiring problem or an amp problem.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56548 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides