Question about Eureka Altima Upright Vacuum Model 2996AVS Vacuum

1 Answer

Not picking up at all...burning smell..belt seems fine.

I have cleaned out every thing possible...taken apart every thing that will come off..belt seems a bit loose...is there an adjustment..how do you see if it is tight enough...i have completely cleaned out every thing...there is no dust on this machine..it is like new..and still not picking up.

Posted by on

  • Milo09 Feb 17, 2009

    It shouldn't be the belt...my vacuum is only four months old. How can I tell if it's the hose or if my brushbar needs to be changed?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Its one of 2 things, either your hose is blocked or you need a new belt,they do stretch over time. possibly the brushbar needs replacing too.
Iain

Posted on Dec 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Burning smell


The response by Lynnette is in reference to the power nozzle....if you are having this issue with the main unit, then it could be the armature is starting to go bad. Have your Rainbow in front of you and give us a call. We can walk you through some steps to narrow it down.

www.rainvac.com
800-523-0510

Apr 09, 2014 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

My cleartrak vacuum have a burning smell while I'm vacuuming. I replaced the belt and cleaned out the filter and it's still having that burning smell while i try to vacuum. Any advise on what i can try? ...


Take it apart for a thorough cleaning. Check that the motor brushes are in working order, they smell when they work too hard or need replacing

Sep 08, 2013 | Vacuums

1 Answer

Burning smell from vacuum, but not from the belt


Possibly motor is going bad like that stator wearing out.

Aug 26, 2009 | Vacuums

1 Answer

Burning smell and not picking up dirt


You probably need to change the belt. Here is a link to the belt you need and to the manual:

Eureka 2961AVZ Belts

Eureka 2961AVZ Owner's Guide (3.4 KB download)

Jul 02, 2009 | Eureka 2961AVZ Bagless Upright Vacuum

2 Answers

My Oreck Vacuum cleaner keeps burning up belts. I


I am having the same trouble. I bought the vacuum new in October 2007 when my wife and I purchased a newly constructed home. Since it is only two of us, she only has to vacuum once a month. I have taken it in three different times and get the same story. It needed a new belt. Mine has white smoke coming out of it and smells like burning rubber. I contacted Oreck and got no results. They refused to let me discuss this with Dave Oreck, stating that he nevers talks with customers! Gary Neeble

Jun 05, 2009 | Oreck XL2000 Bagged Upright Vacuum

3 Answers

Dirt Devil Jaguar Bagless Upright Burning Smell


take the belt off again you will see burnt rubber from the old belt stuck to the motor shaft.you can take a fine piece of emery cloth and clean the shaft down to its polished finish.always good to do this after each belt.check the brush roller and see if there are any signsd of plastic melted.make sure it turns freely if not the brush roller might be siezing uo on youhave you cleaned the hepa filter?does it smell like wires burning or rubber.with it unlugged take it apart to the motor and take a fine iece of emery cloth and go over the motor armature .then try it again.you can take all the filters out and run it without the filters.that will help you narrow it down.please leave feedback

Mar 15, 2009 | Dirt Devil Featherlite Bagless Vacuum...

1 Answer

Burning smell


The bottom doesn't come apart. you have to remove the top cover to get to any components. But if you have a burning smell, then it is probably ther motor and would have to be replaced. Motors cost anywhere from $70 to $90.

Jun 14, 2008 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers

Bissell upright vac, brush on bottom does not rotate


The front brush motor will not engage until the power is turned on and the handle is in the down position. In the upright position the brush motor wont engage. Typical faults will be the belt is broken and needs replacing or the fornt brush motor needs replacing.

May 21, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

6 Answers

Vaccum has no suction


Need a new belt -- you might have suction but you need the brush to spin (hard to help without make or model, upright or canister)

Oct 17, 2007 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Eureka Altima Upright Vacuum Model 2996AVS Vacuum Logo

Related Topics:

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...